aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sssd
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2019-01-30 20:08:24 +0100
committerHenrik Riomar <henrik.riomar@gmail.com>2019-01-30 20:08:24 +0100
commit85db300fda85085f3348c17cae7b9837ce604d6d (patch)
tree522cf684789c03d652252ef5b1749fd969b011b2 /testing/sssd
parentbb48a79e354ae6b01d4d1d09785d984209ece8a2 (diff)
downloadaports-85db300fda85085f3348c17cae7b9837ce604d6d.tar.bz2
aports-85db300fda85085f3348c17cae7b9837ce604d6d.tar.xz
testing/sssd: fix build
* Fix depends for changed pkgname * Fix build with new curl
Diffstat (limited to 'testing/sssd')
-rw-r--r--testing/sssd/APKBUILD6
-rw-r--r--testing/sssd/UTIL-Fix-compilation-with-curl-7.62.0.patch58
2 files changed, 62 insertions, 2 deletions
diff --git a/testing/sssd/APKBUILD b/testing/sssd/APKBUILD
index fc0f7fa576..65f42060cf 100644
--- a/testing/sssd/APKBUILD
+++ b/testing/sssd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Vince Mele <vmele@inoc.com>
pkgname=sssd
pkgver=1.16.3
-pkgrel=0
+pkgrel=1
pkgdesc="System Security Services Daemon"
url="https://pagure.io/SSSD/sssd"
arch="x86_64"
@@ -18,7 +18,7 @@ license="GPL-3.0"
depends="
bind
curl
- cyrus-sasl-gssapi
+ cyrus-sasl-gssapiv2
"
makedepends="
autoconf
@@ -56,6 +56,7 @@ source="https://releases.pagure.org/SSSD/$pkgname/$pkgname-$pkgver.tar.gz
0001-makefile.patch
0002-src.patch
0003-alpine.patch
+ UTIL-Fix-compilation-with-curl-7.62.0.patch
nss.h
cifsidmap.h
"
@@ -121,5 +122,6 @@ sha512sums="6165923f652f624bbe3ddc625ae682c4867eb7a20652d0cf74bbb8dda2307c917d31
a330383e7a334db47baf3f42cbb487c4875894e2120f55e71e2846d3d835ad9702137c93a4d233a237b944fb17410ed90b7fa374126f70db77259c0b83741ebc 0001-makefile.patch
573b6ce0eb8ac7b819a895e32f5feb1150f60c4e6ce45c3262b5af862245c968c85f4eef8b62b0e56c8ef12ca5742f368ee12b794942aeabf2bf32d1bf18bd53 0002-src.patch
1ec5048cbb0e184ca52e970b1a0bb0f69aeb647edfcf25610e51ff54e45e77e93a19c2cf22e12a768a474eba7eed8d9a41f7cfd2cbd0ba1495c1002170e77765 0003-alpine.patch
+4e846befc5321d4d0db9dc619ca30017629471c20247363a45348f9e56b395a973a1fe991ecba0f0adca1b80cfa788b239f50b24a15c3451fa681782e05d2477 UTIL-Fix-compilation-with-curl-7.62.0.patch
5abb1ffd1302eaa25736404ae148c0ffdeb7ce42fa2745be3436e887a2aa96b9620287f19b2790cb59cbccc2c04a9dee1adec4fa8e813d322cde82793500e33b nss.h
b88d4f1ba847477783b43542f1248881d4fb8e8a0d4165c65c358fcb442891d2cc7c96b05e2a8e7c05fdc17ecd76f16295c1ffac3f1c9bfd0375c5e65e56201d cifsidmap.h"
diff --git a/testing/sssd/UTIL-Fix-compilation-with-curl-7.62.0.patch b/testing/sssd/UTIL-Fix-compilation-with-curl-7.62.0.patch
new file mode 100644
index 0000000000..6ea7e3fe05
--- /dev/null
+++ b/testing/sssd/UTIL-Fix-compilation-with-curl-7.62.0.patch
@@ -0,0 +1,58 @@
+From 1ee12b05570fcfb8e4190c9ec704c5563138344d Mon Sep 17 00:00:00 2001
+From: Lukas Slebodnik <lslebodn@redhat.com>
+Date: Wed, 7 Nov 2018 23:06:10 +0000
+Subject: [PATCH] UTIL: Fix compilation with curl 7.62.0
+
+The macro CURLE_SSL_CACERT is deprecated in upstream curl
+since commit 3f3b26d6feb0667714902e836af608094235fca2.
+
+ commit 3f3b26d6feb0667714902e836af608094235fca2
+ Author: Han Han <hhan@thousandeyes.com>
+ Date: Wed Aug 22 11:13:32 2018 -0700
+
+ ssl: deprecate CURLE_SSL_CACERT in favour of a unified error code
+
+ Long live CURLE_PEER_FAILED_VERIFICATION
+
+ sh$ git tag --contains 3f3b26d6feb0667714902e836af608094235fca2
+ curl-7_62_0
+
+It was not removed. It is just an alias to
+CURLE_PEER_FAILED_VERIFICATION which causes compile time failures in
+switch/case.
+
+./src/util/tev_curl.c: In function 'curl_code2errno':
+./src/util/tev_curl.c:113:5: error: duplicate case value
+ case CURLE_PEER_FAILED_VERIFICATION:
+ ^~~~
+./src/util/tev_curl.c: 100:5: note: previously used here
+ case CURLE_SSL_CACERT:
+ ^~~~
+
+Merges: https://pagure.io/SSSD/sssd/pull-request/3878
+
+Resolves:
+https://pagure.io/SSSD/sssd/issue/3875
+
+Reviewed-by: Sumit Bose <sbose@redhat.com>
+---
+ src/util/tev_curl.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/util/tev_curl.c b/src/util/tev_curl.c
+index 6a7a580d5..d70a42972 100644
+--- a/src/util/tev_curl.c
++++ b/src/util/tev_curl.c
+@@ -97,7 +97,9 @@ static errno_t curl_code2errno(CURLcode crv)
+ return ETIMEDOUT;
+ case CURLE_SSL_ISSUER_ERROR:
+ case CURLE_SSL_CACERT_BADFILE:
++#if LIBCURL_VERSION_NUM < 0x073e00
+ case CURLE_SSL_CACERT:
++#endif
+ case CURLE_SSL_CERTPROBLEM:
+ return ERR_INVALID_CERT;
+
+--
+2.20.1
+