aboutsummaryrefslogtreecommitdiffstats
path: root/testing/stargazer
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-08-29 13:13:21 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 13:19:04 +0300
commit911268569afcf0b6c7692892bb1ee439dfd4a7be (patch)
tree8f9f8b0215d53fa7373ad69e5ca59127a2d1800a /testing/stargazer
parentae8104f666f2e70c73b727f9ff49bf4d8589f2cc (diff)
downloadaports-911268569afcf0b6c7692892bb1ee439dfd4a7be.tar.bz2
aports-911268569afcf0b6c7692892bb1ee439dfd4a7be.tar.xz
testing/stargazer: include limits.h for NAME_MAX
attempt to fix ppc64le build
Diffstat (limited to 'testing/stargazer')
-rw-r--r--testing/stargazer/APKBUILD15
-rw-r--r--testing/stargazer/fix-name-max.patch10
2 files changed, 19 insertions, 6 deletions
diff --git a/testing/stargazer/APKBUILD b/testing/stargazer/APKBUILD
index 5beedd9561..a707df3c29 100644
--- a/testing/stargazer/APKBUILD
+++ b/testing/stargazer/APKBUILD
@@ -12,25 +12,28 @@ depends=""
makedepends="expat-dev linux-headers"
install=""
subpackages="$pkgname-dev"
-source="http://www.$_pkgname.dp.ua/download/server/$pkgver/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver/projects/$pkgname"
+source="http://www.$_pkgname.dp.ua/download/server/$pkgver/$_pkgname-$pkgver.tar.gz
+ fix-name-max.patch
+ "
+builddir="$srcdir/$_pkgname-$pkgver"
options="!check"
prepare() {
default_prepare
- cd "$builddir"
+ cd "$builddir/projects/$pkgname"
sed 's/.*capture\/ipq_linux//' -i build
}
build() {
- cd "$builddir"
+ cd "$builddir/projects/$pkgname"
./build
}
package() {
- cd "$builddir"
+ cd "$builddir/projects/$pkgname"
mkdir -p "$pkgdir/usr/sbin"
make PREFIX="$pkgdir" install
}
-sha512sums="200e08cfd629dbacda31ffd3134c2908a1ad58604421cc288ad0ec1bdcd60fe021d51fed50fdc2517bb7c2b61ef23b0b9c71a606babd09bc7804cb899e0b7f75 stg-2.408.tar.gz"
+sha512sums="200e08cfd629dbacda31ffd3134c2908a1ad58604421cc288ad0ec1bdcd60fe021d51fed50fdc2517bb7c2b61ef23b0b9c71a606babd09bc7804cb899e0b7f75 stg-2.408.tar.gz
+b7572654091490bab39a6d6da081133df041df80f38f9de77156719ad05083dfa570a7a6df5db74ee30f3d22270271bd27a8793b6c0ee40ea123ddb4af11d6ec fix-name-max.patch"
diff --git a/testing/stargazer/fix-name-max.patch b/testing/stargazer/fix-name-max.patch
new file mode 100644
index 0000000000..987aef9d79
--- /dev/null
+++ b/testing/stargazer/fix-name-max.patch
@@ -0,0 +1,10 @@
+--- stg-2.408/stglibs/common.lib/include/stg/common.h.orig 2017-08-29 13:08:12.574050223 +0300
++++ stg-2.408/stglibs/common.lib/include/stg/common.h 2017-08-29 13:08:44.261161176 +0300
+@@ -33,6 +33,7 @@
+ #include <ctime>
+ #endif
+ #include <string>
++#include <limits.h>
+
+ #include "stg/os_int.h"
+ #include "stg/const.h"