aboutsummaryrefslogtreecommitdiffstats
path: root/testing/starship
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-22 20:07:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-23 02:16:13 -0300
commit90cd0f60578872f3cadb805111aca6f2de2ab3d3 (patch)
tree39f59ad8b744b26cba41a736425d4b46239143a7 /testing/starship
parent03188db294e1421a8d82610f065eabeab5bc1b1f (diff)
downloadaports-90cd0f60578872f3cadb805111aca6f2de2ab3d3.tar.bz2
aports-90cd0f60578872f3cadb805111aca6f2de2ab3d3.tar.xz
testing/starship: new aport
https://starship.rs/ Cross-shell prompt for astronauts
Diffstat (limited to 'testing/starship')
-rw-r--r--testing/starship/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/starship/APKBUILD b/testing/starship/APKBUILD
new file mode 100644
index 0000000000..c903aaeed9
--- /dev/null
+++ b/testing/starship/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=starship
+pkgver=0.18.0
+pkgrel=0
+pkgdesc="Cross-shell prompt for astronauts"
+options="!check" # All tests hardcode $HOME
+url="https://starship.rs/"
+arch="all"
+license="ISC"
+depends="font-noto-emoji"
+makedepends="cargo zlib-dev libgit2-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/starship/starship/archive/v$pkgver.tar.gz"
+
+export LIBGIT2_SYS_USE_PKG_CONFIG=1 # Use system libgit2
+
+build() {
+ cargo build --release
+}
+
+package() {
+ install -Dm0755 target/release/starship "$pkgdir"/usr/bin/starship
+}
+sha512sums="0b4514d22265393fffeee9d91fbf514d77a3827d039501592145e11a31b5e3318c3e4e686816bfbf17a25e8a37a39e183cde7e98c66fb215d7bf5c4ec5d04c97 starship-0.18.0.tar.gz"