aboutsummaryrefslogtreecommitdiffstats
path: root/testing/steghide
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-09-22 10:20:55 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-09-22 10:21:11 +0000
commitc591456e5d8bb81f9f380db4a52da44c839ea003 (patch)
treec69088b291c00097f145f44872f7d21e46d2193a /testing/steghide
parent3b11d3e83dc608d0508484cf6b72fb6cf1500f8c (diff)
downloadaports-c591456e5d8bb81f9f380db4a52da44c839ea003.tar.bz2
aports-c591456e5d8bb81f9f380db4a52da44c839ea003.tar.xz
testing/steghide: new aport
Diffstat (limited to 'testing/steghide')
-rw-r--r--testing/steghide/APKBUILD43
-rw-r--r--testing/steghide/build-fixes-new-gcc.patch164
-rw-r--r--testing/steghide/steghide-0.5.1-am.patch19
3 files changed, 226 insertions, 0 deletions
diff --git a/testing/steghide/APKBUILD b/testing/steghide/APKBUILD
new file mode 100644
index 0000000000..02d1c6b4b8
--- /dev/null
+++ b/testing/steghide/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=steghide
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="Steganography program that is able to hide data in various kinds of image- and audio-files"
+url="http://steghide.sourceforge.net/index.php"
+arch="all"
+license="GPL"
+makedepends="libmcrypt-dev jpeg-dev zlib-dev libmhash-dev
+bash libtool automake autoconf"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::http://prdownloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+steghide-0.5.1-am.patch
+build-fixes-new-gcc.patch"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ update_config_guess || return 1
+ autoreconf -i
+ ./configure \
+ --prefix=/usr \
+ --disable-rpath \
+ --disable-nls
+ make CXXFLAGS="$CXXFLAGS -fpermissive" || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="5be490e24807d921045780fd8cc446b3 steghide-0.5.1.tar.gz
+3b66fbf01bd02306f02f2fe392af6c36 steghide-0.5.1-am.patch
+a76c32c0718de1ba27c0c5792f16a3b0 build-fixes-new-gcc.patch"
+sha256sums="78069b7cfe9d1f5348ae43f918f06f91d783c2b3ff25af021e6a312cf541b47b steghide-0.5.1.tar.gz
+54a7743990743711614073b7245712bdc887b85cefc66d1199a6542badcb5612 steghide-0.5.1-am.patch
+668d2038bb94b1d4a0c7c5ec924f96a63bf3a412788ebcc1536076f267f701d2 build-fixes-new-gcc.patch"
+sha512sums="6cda3e33e91123fbc5caa112efcacf09180505abd4f6f229878cd443817c60a04498aead02509c7532fd6924225c6b752820c51e452a83c520f228273d610a57 steghide-0.5.1.tar.gz
+b41652a1cfcd5313cb79c220cebc308c5491de4b56433ca5c6099c0b23c532c565cb67b553c32d24398c0e26cec3d1749acd8890e45596464ed499a83fd04fb3 steghide-0.5.1-am.patch
+66443a0ca340969d568e0343fafcef6623f429f6a718b5ea55afcceb444f907521db22702c213d9b72a82e6b353c138f2703afcb4a6d573fe37f70891bc69334 build-fixes-new-gcc.patch"
diff --git a/testing/steghide/build-fixes-new-gcc.patch b/testing/steghide/build-fixes-new-gcc.patch
new file mode 100644
index 0000000000..1f866e3547
--- /dev/null
+++ b/testing/steghide/build-fixes-new-gcc.patch
@@ -0,0 +1,164 @@
+--- steghide-0.5.1.orig/src/ProgressOutput.cc
++++ steghide-0.5.1/src/ProgressOutput.cc
+@@ -23,6 +23,8 @@
+ #include "ProgressOutput.h"
+ #include "common.h"
+
++float ProgressOutput::NoAvgWeight = -1.0 ;
++
+ ProgressOutput::ProgressOutput ()
+ : Message("__nomessage__")
+ {
+--- steghide-0.5.1.orig/src/ProgressOutput.h
++++ steghide-0.5.1/src/ProgressOutput.h
+@@ -62,9 +62,9 @@
+ * \param rate the rate of matched vertices
+ * \param avgweight the average edge weight (is not printed if not given)
+ **/
+- void done (float rate, float avgweight = NoAvgWeight) const ;
++ void done (float rate, float avgweight = 1.0) const ;
+
+- static const float NoAvgWeight = -1.0 ;
++ static float NoAvgWeight ;
+
+ protected:
+ std::string vcompose (const char *msgfmt, va_list ap) const ;
+--- steghide-0.5.1.orig/src/wrapper_hash_map.h
++++ steghide-0.5.1/src/wrapper_hash_map.h
+@@ -29,7 +29,7 @@
+ namespace sgi { using ::hash ; using ::hash_map ; } ;
+ # else
+ # include <ext/hash_map>
+-# if __GNUC_MINOR__ == 0
++# if __GNUC__ == 3 && __GNUC_MINOR__ == 0
+ namespace sgi = std ; // GCC 3.0
+ # else
+ namespace sgi = __gnu_cxx ; // GCC 3.1 and later
+--- steghide-0.5.1.orig/src/wrapper_hash_set.h
++++ steghide-0.5.1/src/wrapper_hash_set.h
+@@ -30,7 +30,7 @@
+ namespace sgi { using ::hash ; using ::hash_set ; } ;
+ # else
+ # include <ext/hash_set>
+-# if __GNUC_MINOR__ == 0
++# if __GNUC__ == 3 && __GNUC_MINOR__ == 0
+ namespace sgi = std ; // GCC 3.0
+ # else
+ namespace sgi = ::__gnu_cxx ; // GCC 3.1 and later
+
+--- steghide-0.5.1.orig/src/Arguments.cc
++++ steghide-0.5.1/src/Arguments.cc
+@@ -28,6 +28,8 @@
+ #include "error.h"
+ #include "msg.h"
+
++float Arguments::Default_Goal = 100.0 ;
++
+ // the global Arguments object
+ Arguments Args ;
+
+--- steghide-0.5.1.orig/src/Arguments.h
++++ steghide-0.5.1/src/Arguments.h
+@@ -100,7 +100,7 @@
+ static const VERBOSITY Default_Verbosity = NORMAL ;
+ static const unsigned long Default_Radius = 0 ; // there is no default radius for all file formats
+ static const unsigned int Max_Algorithm = 3 ;
+- static const float Default_Goal = 100.0 ;
++ static float Default_Goal ;
+ static const DEBUGCOMMAND Default_DebugCommand = NONE ;
+ static const bool Default_Check = false ;
+ static const unsigned int Default_DebugLevel = 0 ;
+--- steghide-0.5.1.orig/src/AuData.h
++++ steghide-0.5.1/src/AuData.h
+@@ -26,22 +26,22 @@
+
+ // AuMuLawAudioData
+ typedef AudioDataImpl<AuMuLaw,BYTE> AuMuLawAudioData ;
+-inline BYTE AuMuLawAudioData::readValue (BinaryIO* io) const { return (io->read8()) ; }
+-inline void AuMuLawAudioData::writeValue (BinaryIO* io, BYTE v) const { io->write8(v) ; }
++template <> inline BYTE AuMuLawAudioData::readValue (BinaryIO* io) const { return (io->read8()) ; }
++template <> inline void AuMuLawAudioData::writeValue (BinaryIO* io, BYTE v) const { io->write8(v) ; }
+
+ // AuPCM8AudioData
+ typedef AudioDataImpl<AuPCM8,SBYTE> AuPCM8AudioData ;
+-inline SBYTE AuPCM8AudioData::readValue (BinaryIO* io) const { return ((SBYTE) io->read8()) ; }
+-inline void AuPCM8AudioData::writeValue (BinaryIO* io, SBYTE v) const { io->write8((BYTE) v) ; }
++template <> inline SBYTE AuPCM8AudioData::readValue (BinaryIO* io) const { return ((SBYTE) io->read8()) ; }
++template <> inline void AuPCM8AudioData::writeValue (BinaryIO* io, SBYTE v) const { io->write8((BYTE) v) ; }
+
+ // AuPCM16AudioData
+ typedef AudioDataImpl<AuPCM16,SWORD16> AuPCM16AudioData ;
+-inline SWORD16 AuPCM16AudioData::readValue (BinaryIO* io) const { return ((SWORD16) io->read16_be()) ; }
+-inline void AuPCM16AudioData::writeValue (BinaryIO* io, SWORD16 v) const { io->write16_be((UWORD16) v) ; }
++template <> inline SWORD16 AuPCM16AudioData::readValue (BinaryIO* io) const { return ((SWORD16) io->read16_be()) ; }
++template <> inline void AuPCM16AudioData::writeValue (BinaryIO* io, SWORD16 v) const { io->write16_be((UWORD16) v) ; }
+
+ // AuPCM32AudioData
+ typedef AudioDataImpl<AuPCM32,SWORD32> AuPCM32AudioData ;
+-inline SWORD32 AuPCM32AudioData::readValue (BinaryIO* io) const { return ((SWORD32) io->read32_be()) ; }
+-inline void AuPCM32AudioData::writeValue (BinaryIO* io, SWORD32 v) const { io->write32_be((UWORD32) v) ; }
++template <> inline SWORD32 AuPCM32AudioData::readValue (BinaryIO* io) const { return ((SWORD32) io->read32_be()) ; }
++template <> inline void AuPCM32AudioData::writeValue (BinaryIO* io, SWORD32 v) const { io->write32_be((UWORD32) v) ; }
+
+ #endif // ndef SH_AUDATA_H
+--- steghide-0.5.1.orig/src/AuSampleValues.cc
++++ steghide-0.5.1/src/AuSampleValues.cc
+@@ -21,17 +21,17 @@
+ #include "AuSampleValues.h"
+
+ // AuMuLawSampleValue
+-const BYTE AuMuLawSampleValue::MinValue = 0 ;
+-const BYTE AuMuLawSampleValue::MaxValue = BYTE_MAX ;
++template <> const BYTE AuMuLawSampleValue::MinValue = 0 ;
++template <> const BYTE AuMuLawSampleValue::MaxValue = BYTE_MAX ;
+
+ // AuPCM8SampleValue
+-const SBYTE AuPCM8SampleValue::MinValue = SBYTE_MIN ;
+-const SBYTE AuPCM8SampleValue::MaxValue = SBYTE_MAX ;
++template <> const SBYTE AuPCM8SampleValue::MinValue = SBYTE_MIN ;
++template <> const SBYTE AuPCM8SampleValue::MaxValue = SBYTE_MAX ;
+
+ // AuPCM16SampleValue
+-const SWORD16 AuPCM16SampleValue::MinValue = SWORD16_MIN ;
+-const SWORD16 AuPCM16SampleValue::MaxValue = SWORD16_MAX ;
++template <> const SWORD16 AuPCM16SampleValue::MinValue = SWORD16_MIN ;
++template <> const SWORD16 AuPCM16SampleValue::MaxValue = SWORD16_MAX ;
+
+ // AuPCM32SampleValue
+-const SWORD32 AuPCM32SampleValue::MinValue = SWORD32_MIN ;
+-const SWORD32 AuPCM32SampleValue::MaxValue = SWORD32_MAX ;
++template <> const SWORD32 AuPCM32SampleValue::MinValue = SWORD32_MIN ;
++template <> const SWORD32 AuPCM32SampleValue::MaxValue = SWORD32_MAX ;
+--- steghide-0.5.1.orig/src/EmbData.cc
++++ steghide-0.5.1/src/EmbData.cc
+@@ -26,6 +26,7 @@
+ #include "MCryptPP.h"
+ #include "MHashPP.h"
+ #include "common.h"
++#include "config.h"
+
+ EmbData::EmbData (MODE m, std::string pp, std::string fn)
+ : Mode(m), Passphrase(pp), FileName(fn)
+--- steghide-0.5.1.orig/src/Graph.cc
++++ steghide-0.5.1/src/Graph.cc
+@@ -33,6 +33,8 @@
+ #include "msg.h"
+ #include "wrapper_hash_set.h"
+
++#include <climits>
++
+ Graph::Graph (CvrStgFile *cvr, const BitString& emb, Selector& sel)
+ {
+ Globs.TheGraph = this ;
+--- steghide-0.5.1.orig/src/MHashPP.cc
++++ steghide-0.5.1/src/MHashPP.cc
+@@ -120,7 +120,7 @@
+
+ std::string MHashPP::getAlgorithmName (hashid id)
+ {
+- char *name = mhash_get_hash_name (id) ;
++ char *name = (char *) mhash_get_hash_name (id) ;
+ std::string retval ;
+ if (name == NULL) {
+ retval = std::string ("<algorithm not found>") ;
+
diff --git a/testing/steghide/steghide-0.5.1-am.patch b/testing/steghide/steghide-0.5.1-am.patch
new file mode 100644
index 0000000000..e261262bd7
--- /dev/null
+++ b/testing/steghide/steghide-0.5.1-am.patch
@@ -0,0 +1,19 @@
+--- steghide-0.5.1/po/Makefile.in.in.org 2003-09-28 17:57:14.000000000 +0200
++++ steghide-0.5.1/po/Makefile.in.in 2006-07-12 17:17:38.000000000 +0200
+@@ -27,7 +27,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
++mkinstalldirs = $(MKINSTALLDIRS)
+
+ GMSGFMT = @GMSGFMT@
+ MSGFMT = @MSGFMT@
+--- steghide-0.5.1/src/Makefile.am.org 2003-09-28 18:33:21.000000000 +0200
++++ steghide-0.5.1/src/Makefile.am 2006-07-12 17:13:26.000000000 +0200
+@@ -33,5 +33,4 @@
+ WavPCMSampleValue.cc error.cc main.cc msg.cc SMDConstructionHeuristic.cc
+ LIBS = @LIBINTL@ @LIBS@
+ localedir = $(datadir)/locale
+-LIBTOOL = $(SHELL) libtool
+ MAINTAINERCLEANFILES = Makefile.in