aboutsummaryrefslogtreecommitdiffstats
path: root/testing/stellarium
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-08-16 10:54:39 +0900
committerLeo <thinkabit.ukim@gmail.com>2019-08-16 05:59:29 -0300
commit4a05bdcecb058b7815897ed6f857947a6c71d5fe (patch)
treed7030b7e64b695f18f64d7b04ace7460e1a46594 /testing/stellarium
parent9a0b3d53d6860c83220e09792294d5cd2d10439d (diff)
downloadaports-4a05bdcecb058b7815897ed6f857947a6c71d5fe.tar.bz2
aports-4a05bdcecb058b7815897ed6f857947a6c71d5fe.tar.xz
testing/stellarium: new aport
Diffstat (limited to 'testing/stellarium')
-rw-r--r--testing/stellarium/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/stellarium/APKBUILD b/testing/stellarium/APKBUILD
new file mode 100644
index 0000000000..8455f187af
--- /dev/null
+++ b/testing/stellarium/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=stellarium
+pkgver=0.19.1
+pkgrel=0
+pkgdesc="A stellarium with great graphics and a nice database of sky-objects"
+url="http://stellarium.org/"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="
+ cmake boost-dev mesa-dev qt5-qttools-dev libpng-dev freetype-dev
+ openssl-dev qt5-qtscript-dev qt5-qtserialport-dev qt5-qtmultimedia-dev
+ qt5-qtlocation-dev gpsd-dev
+"
+subpackages="$pkgname-doc"
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/Stellarium/stellarium/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
+"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_TESTING=1 \
+ .
+ make
+}
+
+check() {
+ # Exclude a broken locale test
+ ctest -E testStelSkyCultureMgr
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="59ab715f7b81e037ed3d23444547dcd00a41b9a1925d58b40a17372e286bbea2c1b762582cd7e1f81d690204840cc23dd9627e2c0bd4abf52367a456849eefe9 stellarium-0.19.1.tar.gz"