aboutsummaryrefslogtreecommitdiffstats
path: root/testing/streamlink
diff options
context:
space:
mode:
authorRobert Sacks <robert@sacks.email>2019-07-05 21:35:06 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-11-29 18:10:32 +0100
commitf6a99e724537aec2dbea1e93264c97dc83a0ff22 (patch)
tree5bdae40271b9000ed253e5d56165f21aeafc6345 /testing/streamlink
parenta968689563c1fc163f3a6cdc5fa9d25c90861a5e (diff)
downloadaports-f6a99e724537aec2dbea1e93264c97dc83a0ff22.tar.bz2
aports-f6a99e724537aec2dbea1e93264c97dc83a0ff22.tar.xz
testing/streamlink: new aport
https://streamlink.github.io/ CLI for extracting streams from various websites to a video player of your choosing
Diffstat (limited to 'testing/streamlink')
-rw-r--r--testing/streamlink/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/streamlink/APKBUILD b/testing/streamlink/APKBUILD
new file mode 100644
index 0000000000..1321a4828c
--- /dev/null
+++ b/testing/streamlink/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Robert Sacks <robert@sacks.email>
+# Maintainer: Robert Sacks <robert@sacks.email>
+pkgname=streamlink
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="CLI for extracting streams from various websites to a video player of your choosing"
+url="https://streamlink.github.io/"
+arch="noarch"
+license="BSD-2-Clause"
+depends="python3 py3-pycryptodome py3-pycountry py3-requests py3-pysocks
+ py3-websocket-client py3-isodate rtmpdump"
+makedepends="py3-setuptools py3-sphinx py3-recommonmark"
+checkdepends="py3-pytest py3-pytest-cov py3-codecov py3-coverage py3-freezegun
+ py3-requests-mock py3-mock"
+subpackages="$pkgname-doc"
+source="streamlink-$pkgver.tar.gz::https://github.com/streamlink/streamlink/archive/$pkgver.tar.gz"
+
+build() {
+ export STREAMLINK_USE_PYCOUNTRY=1
+ python3 setup.py build
+ python3 setup.py build_sphinx -b man
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm644 build/sphinx/man/streamlink.1 \
+ "$pkgdir"/usr/share/man/man1/streamlink.1
+}
+
+sha512sums="23343e3276fa9345643213071f459b52dec4066641baf8321df6c056977c3e3a84f4f6427812ff7dce0628717d017087e22db720d3945ac8dea5e9284f433587 streamlink-1.1.1.tar.gz"