aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sunwait
diff options
context:
space:
mode:
authorStefano Marinelli <stefano@dragas.it>2018-01-18 10:39:28 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-04 21:39:39 +0000
commit74450f80dc9d10488bfd4f2a90df45b190886167 (patch)
tree65d6d7513a677bba952be16ce59dce5ebdb19e3d /testing/sunwait
parent5c21abb0a034e641fd61c624261c943d53060eaf (diff)
downloadaports-74450f80dc9d10488bfd4f2a90df45b190886167.tar.bz2
aports-74450f80dc9d10488bfd4f2a90df45b190886167.tar.xz
testing/sunwait: new aport
https://sourceforge.net/projects/sunwait4windows/ Sunwait calculates sunrise or sunset times with civil, nautical, astronomical and custom twilights.
Diffstat (limited to 'testing/sunwait')
-rw-r--r--testing/sunwait/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/sunwait/APKBUILD b/testing/sunwait/APKBUILD
new file mode 100644
index 0000000000..3d7a218c6a
--- /dev/null
+++ b/testing/sunwait/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Stefano Marinelli <stefano@dragas.it>
+# Maintainer: Stefano Marinelli <stefano@dragas.it>
+pkgname=sunwait
+pkgver=0.8
+pkgrel=0
+pkgdesc="Sunwait calculates sunrise or sunset times with civil, nautical, astronomical and custom twilights."
+url="https://sourceforge.net/projects/sunwait4windows/"
+arch="all"
+license="GPL-3.0-only"
+options="!check" # No test suite available
+source="http://downloads.sourceforge.net/sunwait4windows/sunwait${pkgver/./-}.tar"
+builddir="$srcdir/sunwait/$pkgver/"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin/
+ cd "$builddir"
+ cp sunwait "$pkgdir"/usr/bin/
+}
+
+sha512sums="5b54769d15c5bbbe4a43db1a98c92b6324f3f7718d5653482de056dcc2aede676077d89224f9b3744b4f68d74df63abbabf82c7d8abfe189f4c3028b7be98f69 sunwait0-8.tar"