aboutsummaryrefslogtreecommitdiffstats
path: root/testing/supercronic
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-07 10:56:57 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-07 14:44:12 +0000
commiteb1f9dc58a3a2164f4223290c21801d194a8c7ac (patch)
tree591a2fc14f258214eeaed1f79c17aff705e2be8a /testing/supercronic
parent694f673c3c5210a6af7dd2680ec2594f4f3acbcc (diff)
downloadaports-eb1f9dc58a3a2164f4223290c21801d194a8c7ac.tar.bz2
aports-eb1f9dc58a3a2164f4223290c21801d194a8c7ac.tar.xz
testing/supercronic: use python3 in tests
Diffstat (limited to 'testing/supercronic')
-rw-r--r--testing/supercronic/APKBUILD14
-rw-r--r--testing/supercronic/python3.patch13
2 files changed, 22 insertions, 5 deletions
diff --git a/testing/supercronic/APKBUILD b/testing/supercronic/APKBUILD
index 6c2e17f0d1..4839d96fc5 100644
--- a/testing/supercronic/APKBUILD
+++ b/testing/supercronic/APKBUILD
@@ -1,14 +1,17 @@
# Contributor: Thomas Kienlen <t.kienlen@adhoc-gti.com>
# Maintainer: Thomas Kienlen <t.kienlen@adhoc-gti.com>
-pkgname="supercronic"
-pkgver="0.1.9"
+pkgname=supercronic
+pkgver=0.1.9
pkgrel=0
pkgdesc="Cron for containers"
url="https://github.com/aptible/supercronic"
arch="all"
license="MIT"
-makedepends="go bash dep python"
-source="$pkgname-$pkgver.tar.gz::https://github.com/aptible/supercronic/archive/v$pkgver.tar.gz"
+makedepends="go bash dep"
+checkdepends="python3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/aptible/supercronic/archive/v$pkgver.tar.gz
+ python3.patch
+ "
builddir="$srcdir/src/github.com/aptible/$pkgname"
export GOPATH="$srcdir"
@@ -32,4 +35,5 @@ package() {
install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
}
-sha512sums="0e2a283c699b6f7ad1925d4d883290e42eb955b54e35ade71106c0e66886ac8f2c919f62acd5ff3064e4f71523e7415ae573b533a06ee762f27c87af29107ed3 supercronic-0.1.9.tar.gz"
+sha512sums="0e2a283c699b6f7ad1925d4d883290e42eb955b54e35ade71106c0e66886ac8f2c919f62acd5ff3064e4f71523e7415ae573b533a06ee762f27c87af29107ed3 supercronic-0.1.9.tar.gz
+fd88eccd0a18d65af57292e430a1c69b2de1d5c845522e1e1b8b217ab11b8d974543da747debbd6cd2c03d0929dcc04c028a0dc95fc27433331a0dec61d1dfae python3.patch"
diff --git a/testing/supercronic/python3.patch b/testing/supercronic/python3.patch
new file mode 100644
index 0000000000..6e3852efcb
--- /dev/null
+++ b/testing/supercronic/python3.patch
@@ -0,0 +1,13 @@
+diff --git a/cron/cron_test.go b/cron/cron_test.go
+index 9256514..25f17dd 100644
+--- a/cron/cron_test.go
++++ b/cron/cron_test.go
+@@ -132,7 +132,7 @@ var runJobTestCases = []struct {
+ },
+ },
+ {
+- fmt.Sprintf("python -c 'print(\"a\" * %d * 3)'", READ_BUFFER_SIZE), true, &basicContext,
++ fmt.Sprintf("python3 -c 'print(\"a\" * %d * 3)'", READ_BUFFER_SIZE), true, &basicContext,
+ []*logrus.Entry{
+ {Message: "starting", Level: logrus.InfoLevel, Data: noData},
+ {Message: strings.Repeat("a", READ_BUFFER_SIZE), Level: logrus.InfoLevel, Data: stdoutData},