aboutsummaryrefslogtreecommitdiffstats
path: root/testing/supermin
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-25 23:51:42 -0300
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-27 15:07:49 +0000
commit00c4a8d93fd8b8b6f0cdb77a74d8239b6d6d101b (patch)
tree773879855ed2f705329e2fab6cc311023412406b /testing/supermin
parent9727e629f2134583a0a7754ae7a46166bbb13c9f (diff)
downloadaports-00c4a8d93fd8b8b6f0cdb77a74d8239b6d6d101b.tar.bz2
aports-00c4a8d93fd8b8b6f0cdb77a74d8239b6d6d101b.tar.xz
testing/supermin: modernize, fix license
Diffstat (limited to 'testing/supermin')
-rw-r--r--testing/supermin/APKBUILD34
1 files changed, 13 insertions, 21 deletions
diff --git a/testing/supermin/APKBUILD b/testing/supermin/APKBUILD
index 964f143827..dc3855ad3b 100644
--- a/testing/supermin/APKBUILD
+++ b/testing/supermin/APKBUILD
@@ -2,30 +2,25 @@
# Maintainer: Fathi Boudra <fathi.boudra@linaro.org>
pkgname=supermin
pkgver=5.1.20
-pkgrel=0
+pkgrel=1
pkgdesc="tool for building supermin appliances"
url="http://libguestfs.org/"
arch="x86_64"
-license="GPL2"
+license="GPL-2.0-or-later"
depends="cpio e2fsprogs"
-makedepends="\
- bash \
- cpio \
- e2fsprogs \
- e2fsprogs-dev \
- gawk \
- ocaml \
- ocaml-findlib \
- perl \
-"
-install=""
+makedepends="
+ bash
+ e2fsprogs-dev
+ gawk
+ ocaml
+ ocaml-findlib
+ perl
+ "
subpackages="$pkgname-doc"
source="http://download.libguestfs.org/supermin/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
options="!check" # Disable tests as they fail under Alpine
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
@@ -36,14 +31,11 @@ build() {
make
}
-# Disable tests as they fail under Alpine
-#check() {
-# cd "$builddir"
-# make check
-#}
+check() {
+ make check
+}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}