aboutsummaryrefslogtreecommitdiffstats
path: root/testing/synapse
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-06 20:48:19 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-06 20:48:23 +0100
commit615f0ed66e611d8063d283dcbcf89c77e83bbaa8 (patch)
tree2ea51462019555f6a47f59ed134db26b71e49aa3 /testing/synapse
parent29dd8049cf52711e0974c947c94925b188ae38b5 (diff)
downloadaports-615f0ed66e611d8063d283dcbcf89c77e83bbaa8.tar.bz2
aports-615f0ed66e611d8063d283dcbcf89c77e83bbaa8.tar.xz
community/synapse: move from testing
Diffstat (limited to 'testing/synapse')
-rw-r--r--testing/synapse/APKBUILD80
-rw-r--r--testing/synapse/synapse.confd7
-rw-r--r--testing/synapse/synapse.initd21
-rw-r--r--testing/synapse/synapse.post-install11
-rw-r--r--testing/synapse/synapse.pre-install6
5 files changed, 0 insertions, 125 deletions
diff --git a/testing/synapse/APKBUILD b/testing/synapse/APKBUILD
deleted file mode 100644
index 24a7e4f0db..0000000000
--- a/testing/synapse/APKBUILD
+++ /dev/null
@@ -1,80 +0,0 @@
-# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
-pkgname=synapse
-pkgver=1.6.1
-pkgrel=1
-pkgdesc="Matrix reference homeserver"
-options="!check" # Unblock builders
-url="https://github.com/matrix-org/synapse"
-arch="noarch !s390x" # Tests fail
-license="Apache-2.0"
-depends="
- python3
- py3-eliot
- py3-txacme
- py3-jsonschema
- py3-frozendict
- py3-canonicaljson
- py3-pynacl
- py3-idna
- py3-service_identity
- py3-twisted
- py3-openssl
- py3-yaml
- py3-asn1
- py3-asn1-modules
- py3-daemonize
- py3-bcrypt
- py3-pillow
- py3-sortedcontainers
- py3-msgpack
- py3-phonenumbers
- py3-six
- py3-attrs
- py3-netaddr
- py3-jinja2
- py3-pymacaroons
- py3-prometheus-client
- py3-treq
- py3-lxml
- py3-psycopg2
- py3-signedjson
- py3-bleach
- py3-typing-extensions
- "
-makedepends="py3-setuptools"
-checkdepends="py3-mock py3-parameterized"
-pkgusers="synapse"
-pkggroups="synapse"
-install="$pkgname.pre-install $pkgname.post-install"
-subpackages="$pkgname-openrc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/matrix-org/synapse/archive/v$pkgver.tar.gz
- synapse.initd
- synapse.confd
- "
-
-build() {
- python3 setup.py build
-}
-
-check() {
- PYTHONPATH="." trial tests
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- install -d -g synapse -o synapse -m775 \
- "$pkgdir"/etc/synapse \
- "$pkgdir"/var/lib/synapse
-
- cp -a synapse/res "$pkgdir"/var/lib/synapse
- chown -R synapse:synapse "$pkgdir"/var/lib/synapse/res
-
- install -Dm755 "$srcdir"/synapse.initd "$pkgdir"/etc/init.d/synapse
- install -Dm644 "$srcdir"/synapse.confd "$pkgdir"/etc/conf.d/synapse
-}
-
-sha512sums="4fa30aae76f326ad4a58ca6abc6cadd3935cd0512601c004a3c48d5c6e847a35e032b75c6e75701cf5b15faf5767363efc595c29bccbd15d5821fb7a701830ae synapse-1.6.1.tar.gz
-4fa4a7bdd80e3b1af0f546723a64cec3b6014c5d52cfb296c41e831f73f72489bd90a3938831c0fd25cdcb03b6e27b54dfd222e325fb30525c39f5c6996687ff synapse.initd
-7c022f0e00c8ac363d6d2e003b6389fb06a3934f68390ebac156cb46bc1366585e6b6cda07b15176bc62a00f5bf21bfda153ff5418b07331257a7075102a6f83 synapse.confd"
diff --git a/testing/synapse/synapse.confd b/testing/synapse/synapse.confd
deleted file mode 100644
index e7667d7ab4..0000000000
--- a/testing/synapse/synapse.confd
+++ /dev/null
@@ -1,7 +0,0 @@
-# Configuration for /etc/init.d/synapse
-
-# Location of configuration file
-config="/etc/synapse/homeserver.yaml"
-
-# Extra arguments to be passed when starting synapse
-# command_args=""
diff --git a/testing/synapse/synapse.initd b/testing/synapse/synapse.initd
deleted file mode 100644
index 2b975a9718..0000000000
--- a/testing/synapse/synapse.initd
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/sbin/openrc-run
-supervisor=supervise-daemon
-
-name="synapse"
-description="Daemon for Synapse, the Matrix reference homeserver"
-
-: ${command_user:="synapse:synapse"}
-: ${config:="/etc/synapse/homesever.yaml"}
-
-command="/usr/bin/python3"
-command_args="-m synapse.app.homeserver --config-path=$config $command_args"
-
-depends() {
- need net
-}
-
-start_pre() {
- # /var/lib/synapse needs to be owned by the synapse user and so does the config location
- checkpath --directory --owner "$command_user" /var/lib/synapse
- checkpath --file --owner "$command_user" $config
-}
diff --git a/testing/synapse/synapse.post-install b/testing/synapse/synapse.post-install
deleted file mode 100644
index a3c61c5cfd..0000000000
--- a/testing/synapse/synapse.post-install
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-if [ ! -e etc/synapse/homeserver.yaml ]; then
- python3 -m synapse.app.homeserver \
- --server-name my.domain.name \
- --config-path /etc/synapse/homeserver.yaml \
- --generate-config \
- --report-stats=yes 2>/dev/null
-fi
-
-exit 0
diff --git a/testing/synapse/synapse.pre-install b/testing/synapse/synapse.pre-install
deleted file mode 100644
index f8f78ace6d..0000000000
--- a/testing/synapse/synapse.pre-install
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-addgroup -S synapse 2>/dev/null
-adduser -S -D -H -h /var/lib/synapse -s /sbin/nologin -G synapse -g synapse synapse 2>/dev/null
-
-exit 0