aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tau
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-02-08 21:01:12 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-02-14 21:37:33 +0000
commit3b688d6457197778ccafda14cdd203d1362cca03 (patch)
tree4020fac284055b624cfea06e5b9065337b32f49d /testing/tau
parent26e1e59c6cfb1cfe95d5f5110808006462c611d1 (diff)
downloadaports-3b688d6457197778ccafda14cdd203d1362cca03.tar.bz2
aports-3b688d6457197778ccafda14cdd203d1362cca03.tar.xz
testing/various: enable stackprotector
On x86, the stack protector was disabled by addinsg `-fno-stack-protector` to CFLAGS. This was due to rust not passing `-lssp_nonshared` to the linker, causing build errors while linking. Rust has been patched to fix this issue, so now we can enable stack protection again.
Diffstat (limited to 'testing/tau')
-rw-r--r--testing/tau/APKBUILD9
1 files changed, 1 insertions, 8 deletions
diff --git a/testing/tau/APKBUILD b/testing/tau/APKBUILD
index 369ff2b88e..029975f8ea 100644
--- a/testing/tau/APKBUILD
+++ b/testing/tau/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=tau
pkgver=0.10.2
-pkgrel=0
+pkgrel=1
pkgdesc="GTK frontend for the Xi text editor, written in Rust"
url="https://gitlab.gnome.org/World/Tau"
arch="all !s390x"
@@ -14,13 +14,6 @@ subpackages="$pkgname-lang"
source="https://gitlab.gnome.org/World/Tau/uploads/d7d7fc22a851466768edeace0f3d6b1b/tau-$pkgver.tar.xz"
build() {
- # Fails to compile libbacktrace-sys otherwise
- case "$CARCH" in
- x86)
- export CFLAGS="$CFLAGS -fno-stack-protector"
- ;;
- esac
-
meson \
--prefix=/usr \
--sysconfdir=/etc \