aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tb-tun/APKBUILD
diff options
context:
space:
mode:
authorDennis Przytarski <dennis@przytarski.com>2014-08-18 10:51:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-08-18 11:24:06 +0000
commite6008bf22b45fca963c2d76c23d530892adb1e3f (patch)
tree164dabe593620c73370fa6f02ede499486afeb44 /testing/tb-tun/APKBUILD
parent7dbdbbaf522ef80b645562364263137b6d69649f (diff)
downloadaports-e6008bf22b45fca963c2d76c23d530892adb1e3f.tar.bz2
aports-e6008bf22b45fca963c2d76c23d530892adb1e3f.tar.xz
testing/tb-tun: new aport
https://code.google.com/p/tb-tun/ An userspace program using TUN/TAP to build 6to4/tunnelbroker/ISATAP tunnel on Linux
Diffstat (limited to 'testing/tb-tun/APKBUILD')
-rw-r--r--testing/tb-tun/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/tb-tun/APKBUILD b/testing/tb-tun/APKBUILD
new file mode 100644
index 0000000000..676e981929
--- /dev/null
+++ b/testing/tb-tun/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Dennis Przytarski <dennis@przytarski.com>
+# Maintainer:
+pkgname=tb-tun
+pkgver=r18
+pkgrel=0
+pkgdesc="An userspace program using TUN/TAP to build 6to4/tunnelbroker/ISATAP tunnel on Linux"
+url="https://code.google.com/p/tb-tun/"
+arch="all"
+license="GPL1+ PerlArtistic"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://$pkgname.googlecode.com/files/${pkgname}_${pkgver}.tar.gz"
+
+_builddir="$srcdir"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ gcc tb_userspace.c -l pthread -o tb_userspace || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 tb_userspace "$pkgdir"/usr/sbin/tb_userspace || return 1
+}
+
+md5sums="7227ed964e9eaacb7fc7e08a86c3ffcc tb-tun_r18.tar.gz"
+sha256sums="3c4a18069a888a15b20da3a8ba12374bcae8257b59c0f2221513811df23dec12 tb-tun_r18.tar.gz"
+sha512sums="476532ffaa0eb584af04bc226507445fbe6f5d50aff25cbee6f1d85c0fae19621923905be2a01c52bad5bb01156237b232eed485fd45ffee1da48f14534a92c0 tb-tun_r18.tar.gz"