aboutsummaryrefslogtreecommitdiffstats
path: root/testing/telegraf
diff options
context:
space:
mode:
authorKonstantin Kulikov <k.kulikov2@gmail.com>2019-10-02 06:57:38 +0300
committerRasmus Thomsen <oss@cogitri.dev>2019-10-06 11:21:07 +0200
commit54b88d2c28b42276f6da2f9e155132fe6a0e4799 (patch)
tree072fd6bf420c5ba9c6f22600c2e7dfb06d577f8b /testing/telegraf
parentf466e4a9963db979639e7686f5fafc70c499d754 (diff)
downloadaports-54b88d2c28b42276f6da2f9e155132fe6a0e4799.tar.bz2
aports-54b88d2c28b42276f6da2f9e155132fe6a0e4799.tar.xz
testing/telegraf: upgrade to 1.12.2
Diffstat (limited to 'testing/telegraf')
-rw-r--r--testing/telegraf/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/testing/telegraf/APKBUILD b/testing/telegraf/APKBUILD
index 9d98d38a84..8aadf55615 100644
--- a/testing/telegraf/APKBUILD
+++ b/testing/telegraf/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Katie Holly <holly@fuslvz.ws>
# Maintainer: Konstantin Kulikov <k.kulikov2@gmail.com>
pkgname=telegraf
-pkgver=1.12.1
+pkgver=1.12.2
pkgrel=0
pkgdesc="A plugin-driven server agent for collecting & reporting metrics, part of the InfluxDB project"
url="https://www.influxdata.com/time-series-platform/telegraf/"
@@ -18,7 +18,8 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/influxdata/$pkgname/archive/
builddir="$srcdir/src/github.com/influxdata/$pkgname"
export GOPATH="$srcdir"
-export GOCACHE="$srcdir/gocache"
+export GOCACHE=${GOCACHE:-$srcdir/go-build}
+export GOTMPDIR=${GOTMPDIR:-$srcdir}
prepare() {
mkdir -p ${builddir%/*}
@@ -35,7 +36,9 @@ build() {
check() {
# filecount tests are excluded because they depend on exact file sizes
# which depend on filesystem used.
- go test -short $(go list ./... | grep -v plugins/inputs/filecount)
+ # Prometheus tls test depends on specific bytes returned by http server,
+ # disabling tls13 workarounds test failure for now.
+ GODEBUG=tls13=0 go test -short $(go list ./... | grep -v plugins/inputs/filecount)
}
package() {
@@ -46,6 +49,6 @@ package() {
install -dm755 "$pkgdir/etc/$pkgname.conf.d"
}
-sha512sums="8018d48482ec1cdada9d57bb6b8068a0758d58908a4c88deb089645282fde662191bd356e0081178b0e7bc1be6bb19cb2c29bba0039398b7d64f53de9fbf87d6 telegraf-1.12.1.tar.gz
+sha512sums="5e6f57840a215b407055b1c1cdb550e151079a692746436bd67d6a8ef1e830b6fa1c002656b8b56081c4a61a5b6b6b064bbff254640f560836253aa2ab4ab1e9 telegraf-1.12.2.tar.gz
abe483deb8e12fe140de2c36d17bbfbc97ed7a5de8c3d76162357f7ba6575b8236b7197b92a26ed6d54f95c1ccbfc12ca62d6cc0371bf49d10a1ea5622a51ed1 telegraf.initd
90188e1ba88d3a0714e1590f78a2abf3719cbe2f3d734f9c72ded13cf9c8495c1bf6696f2780289775bf53da347eee72aea8fe5555a4754360d1fbaa9d3c362b telegraf.confd"