aboutsummaryrefslogtreecommitdiffstats
path: root/testing/telegram-desktop/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-10 14:46:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-10 16:55:35 -0300
commit2c53309a6f4421e4289a83fae031f20f78f89127 (patch)
treee482bc57f2f180ae7ed3ca25a8ee8926afda6e50 /testing/telegram-desktop/APKBUILD
parentc2cf326d1c321124c0e8971d898c06776d358006 (diff)
downloadaports-2c53309a6f4421e4289a83fae031f20f78f89127.tar.bz2
aports-2c53309a6f4421e4289a83fae031f20f78f89127.tar.xz
testing/telegram-desktop: upgrade to 1.8.1
Diffstat (limited to 'testing/telegram-desktop/APKBUILD')
-rw-r--r--testing/telegram-desktop/APKBUILD71
1 files changed, 36 insertions, 35 deletions
diff --git a/testing/telegram-desktop/APKBUILD b/testing/telegram-desktop/APKBUILD
index 305e10a261..32f25e0fbd 100644
--- a/testing/telegram-desktop/APKBUILD
+++ b/testing/telegram-desktop/APKBUILD
@@ -2,16 +2,16 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# TODO(Leo): remove pulseaudio dep, use system xxhash
pkgname=telegram-desktop
-pkgver=1.7.14
+pkgver=1.8.1
# https://github.com/telegramdesktop/tdesktop/blob/v$pkgver/docs/building-cmake.md
-_libtgvoip_commit=0e92a22746d15157bea46faddd61b79e9964275a
-_GSL_commit=d846fe50a3f0bb7767c7e087a05f4be95f4da0ec
+_libtgvoip_commit=d4a0f719ffd8d29e88474f67abc9fc862661c3b9
+_gsl_commit=d846fe50a3f0bb7767c7e087a05f4be95f4da0ec
_variant_commit=550ac2f159ca883d360c196149b466955c77a573
-_crl_commit=9ea870038a2a667add7f621be6252db909068386
-_rlottie_commit=40ccf084445c60a32d72d4811edf0efd0580dcaa
-_Catch2_commit=5ca44b68721833ae3731802ed99af67c6f38a53a
+_crl_commit=52baf11aaeb7f5ea6955a438abaa1aee4c4308d8
+_rlottie_commit=d08a03b6508b390af20491f2dbeee3453594afc8
+_catch2_commit=5ca44b68721833ae3731802ed99af67c6f38a53a
_xxhash_commit=7cc9639699f64b750c0b82333dced9ea77e8436e
-pkgrel=1
+pkgrel=0
pkgdesc="Telegram Desktop messaging app"
options="!check" # Requires Catch2 to be packaged.
url="https://desktop.telegram.org/"
@@ -45,14 +45,14 @@ makedepends="
qtchooser
"
source="
- $pkgname-$pkgver.tar.gz::https://github.com/telegramdesktop/tdesktop/archive/v${pkgver}.tar.gz
- libtgvoip-$_libtgvoip_commit.tar.gz::https://github.com/telegramdesktop/libtgvoip/archive/${_libtgvoip_commit}.tar.gz
- GSL-$_GSL_commit.tar.gz::https://github.com/Microsoft/GSL/archive/${_GSL_commit}.tar.gz
- variant-$_variant_commit.tar.gz::https://github.com/mapbox/variant/archive/${_variant_commit}.tar.gz
- crl-$_crl_commit.tar.gz::https://github.com/telegramdesktop/crl/archive/${_crl_commit}.tar.gz
- rlottie-$_rlottie_commit.tar.gz::https://github.com/john-preston/rlottie/archive/${_rlottie_commit}.tar.gz
- Catch2-$_Catch2_commit.tar.gz::https://github.com/catchorg/Catch2/archive/${_Catch2_commit}.tar.gz
- xxhash-${_xxhash_commit}.tar.gz::https://github.com/Cyan4973/xxHash/archive/${_xxhash_commit}.tar.gz
+ $pkgname-$pkgver.tar.gz::https://github.com/telegramdesktop/tdesktop/archive/v$pkgver.tar.gz
+ libtgvoip-$_libtgvoip_commit.tar.gz::https://github.com/telegramdesktop/libtgvoip/archive/$_libtgvoip_commit.tar.gz
+ GSL-$_gsl_commit.tar.gz::https://github.com/Microsoft/GSL/archive/$_gsl_commit.tar.gz
+ variant-$_variant_commit.tar.gz::https://github.com/mapbox/variant/archive/$_variant_commit.tar.gz
+ crl-$_crl_commit.tar.gz::https://github.com/telegramdesktop/crl/archive/$_crl_commit.tar.gz
+ rlottie-$_rlottie_commit.tar.gz::https://github.com/john-preston/rlottie/archive/$_rlottie_commit.tar.gz
+ Catch2-$_catch2_commit.tar.gz::https://github.com/catchorg/Catch2/archive/$_catch2_commit.tar.gz
+ xxhash-$_xxhash_commit.tar.gz::https://github.com/Cyan4973/xxHash/archive/$_xxhash_commit.tar.gz
CMakeLists.inj
0001-musl.patch
0002-tdesktop.patch
@@ -63,10 +63,9 @@ source="
0007-no-gtk2.patch
0009-lz4.patch
0010-libtgvoip.patch
- 0011-no-static-qt.patch
- 0012-ffmpeg.patch
0013-lz4.patch
0014-clock_gettime.patch
+ 0015-revert-headers.patch
"
builddir="$srcdir/tdesktop-$pkgver"
@@ -80,18 +79,21 @@ prepare() {
rmdir Telegram/ThirdParty/xxHash
# Copy fetched libraries to their appropriate locations
- mv ../libtgvoip-${_libtgvoip_commit} "${builddir}"/Telegram/ThirdParty/libtgvoip
- mv ../GSL-${_GSL_commit} "${builddir}"/Telegram/ThirdParty/GSL
- mv ../variant-${_variant_commit} "${builddir}"/Telegram/ThirdParty/variant
- mv ../crl-${_crl_commit} "${builddir}"/Telegram/ThirdParty/crl
- mv ../rlottie-${_rlottie_commit} "${builddir}"/Telegram/ThirdParty/rlottie
- mv ../Catch2-${_Catch2_commit} "${builddir}"/Telegram/ThirdParty/Catch
- mv ../xxHash-${_xxhash_commit} "${builddir}"/Telegram/ThirdParty/xxHash
+ mv ../libtgvoip-${_libtgvoip_commit} "$builddir"/Telegram/ThirdParty/libtgvoip
+ mv ../GSL-${_gsl_commit} "$builddir"/Telegram/ThirdParty/GSL
+ mv ../variant-${_variant_commit} "$builddir"/Telegram/ThirdParty/variant
+ mv ../crl-${_crl_commit} "$builddir"/Telegram/ThirdParty/crl
+ mv ../rlottie-${_rlottie_commit} "$builddir"/Telegram/ThirdParty/rlottie
+ mv ../Catch2-${_catch2_commit} "$builddir"/Telegram/ThirdParty/Catch
+ mv ../xxHash-${_xxhash_commit} "$builddir"/Telegram/ThirdParty/xxHash
cd "$builddir/Telegram/ThirdParty"
rm -rf minizip lz4 # we have these system-wide
default_prepare
+
+ # disable static-qt for rlottie
+ sed "/RLOTTIE_WITH_STATIC_QT/d" -i "$builddir/Telegram/gyp/lib_rlottie.gyp"
}
build() {
@@ -116,7 +118,7 @@ build() {
sed -i "$NUM r ../CMakeLists.inj" out/Release/CMakeLists.txt
cd out/Release
- cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -UTDESKTOP_OFFICIAL_TARGET
make
}
@@ -129,23 +131,23 @@ package() {
"$pkgdir/usr/share/applications/telegramdesktop.desktop"
for icon_size in 16 32 48 64 128 256 512; do
- icon_dir="$pkgdir/usr/share/icons/hicolor/${icon_size}x${icon_size}/apps"
+ icon_dir="$pkgdir/usr/share/icons/hicolor/$icon_sizex$icon_size/apps"
install -d "$icon_dir"
- install -m644 "$builddir/Telegram/Resources/art/icon${icon_size}.png" \
+ install -m644 "$builddir/Telegram/Resources/art/icon$icon_size.png" \
"$icon_dir/telegram.png"
done
}
-sha512sums="b2b19aad5c276a389461964b82773f2d0380f0774557d1d81316dc0b10a915ee88b0439211ebbf8aafd8d3edc17dc0dc9d4b7ac894669fba45307a10f5fa946f telegram-desktop-1.7.14.tar.gz
-bf0f1d808b0458d081b5cddcdbf9b24d8a63a31d89c207cd20983abf4f328acea749107d1b0c021579923cfb7371da2a9a6f61d9ce008d6c5c55b3fd7052508e libtgvoip-0e92a22746d15157bea46faddd61b79e9964275a.tar.gz
+sha512sums="129725e87e32b97a9e1fe844cfc489e07bd47a1f54cfa79dbde59f26510fd79e786c39f09fb6cfe11d93059f5d6aa62c8d9a17c7c9d12de88d10ddbaabc940d0 telegram-desktop-1.8.1.tar.gz
+14eaadcb4ec25e7d603d3965f8dc003f0509bc215916e0f5e092564c76d2a440a8edc9e5e61ae279c0b18edffaa401df6aedc766c1e7355357bfb1c95e2b5f50 libtgvoip-d4a0f719ffd8d29e88474f67abc9fc862661c3b9.tar.gz
83560cb0c39b6a4781e916c6081ad2728296e1b19760ca1b6426a8431fb6d7093760a882c539dd77152f5892fe081b1795af6366ea91385bb10aba6adf27170f GSL-d846fe50a3f0bb7767c7e087a05f4be95f4da0ec.tar.gz
537ce0a1731274da63a5be063311f7113c1391081e43970663a994b82a7b2e860302406c2931184789661d86343b2c60064c7014b73dc42799573f5b93bc12ff variant-550ac2f159ca883d360c196149b466955c77a573.tar.gz
-7bb68c0b0c94bb266a765e01878a0e840fcc28922af8878ff5217da693092ef19c3e543e4ecb86efd41b2b29bb907d98e1998c0d4f3a9e3dbd65c23df4c29ece crl-9ea870038a2a667add7f621be6252db909068386.tar.gz
-54ab3c79b9e23b1d055e9bbf802d16e036d606923acfb61d13db2b620e869ce08aa8c0e2fa7728bfe45ee2221238302936698f75a26cf22c31a95604c15dc270 rlottie-40ccf084445c60a32d72d4811edf0efd0580dcaa.tar.gz
+cfe28a69cff822fab8ebb4379b105e3d69e610614359ba7b6b91cbf676c23067f75d34f259500ab7fb61d3e4b45a0dd77ee4bf4f0bdc6d6463dab5f3f447f6fe crl-52baf11aaeb7f5ea6955a438abaa1aee4c4308d8.tar.gz
+163a9cd566be8fd2bf0baaf34bf1ffdb96a3cfffe29b29e39f3991d0d2fdd957b78d0e9a07aff56e6483a57d2c7906cfc8ab5130fe28dbcaed0091c68187898e rlottie-d08a03b6508b390af20491f2dbeee3453594afc8.tar.gz
5b151e0a8c4594b19258a8aade7132521ffbdc97233c9d4a0e5cb2ea31eb9cb3ee51769884a8a08ab821571215ff32854bd76d2929e3b4c14a39e56657109dd6 Catch2-5ca44b68721833ae3731802ed99af67c6f38a53a.tar.gz
cada36066c14ed735f8f45a2d1e0c2d1bdb564dc18154aaabc12552d41065426d88cdeb8a67b8e697678b01f2e415c0a6caf428baa591d013739d7ac95048d4d xxhash-7cc9639699f64b750c0b82333dced9ea77e8436e.tar.gz
-069a3061649567483e4250abdd80aee69937f744aa5ef06bc465ce5bd3abb7b6d934604bd7a35312dd0593895b7709c51288b9063c2919d260909aefab73b3e9 CMakeLists.inj
+c81d82c65fb78e4832aaaa0aff3d33a1f235f0f213a115a8f7aded79f249f5724b3fb8f4cc1493fb06848a7ae4568bfd875a34f4f4c757a7a12c10d1f3603103 CMakeLists.inj
74e8adfe9cb6c224b12fb653798be1abb55cff40f326a9542e5ae23fb82b57a117b5f74dc8a2af80efcd8e261bbbc46c8e5c10fdb6a55ae3196429fd67afd183 0001-musl.patch
06da4b11ecbaba1f7c46e0afed97abc4b9817349492d947834d40e9e81a4dde43a5223721a6350f5fb34df0997d6ee0ae50558e0899c2ccccfabce5bbb7ddf90 0002-tdesktop.patch
6289d5a3eb224ebb05ab64e23ca3d081e617d905cec07edbba423265dc617548005eeb643ce5dfb2fcef9ac774e9f7b64150729bd894ca0e94af0e2aea9c823b 0003-fix-missing-use-of-pch.patch
@@ -155,7 +157,6 @@ ce6be003220267bac5483caf8302b492e1581892bc36d35a61236ebf9f9d766b8bd2159557a1c362
cb01655dd097b68e89b15e6e4b1f6da10c52e8bec681eeef9807ca376283b10cb3da34acc976c790f3c8dea05acbef1ba1967612920a2e4acb3b9da79e251a0d 0007-no-gtk2.patch
d4ef17600e095b753bcbc4df0078cc025dd235056a8f4946183fc5416e0452bceac020badda60221b98b410261c5aaef72d18e8abc82781257e8075a133908f6 0009-lz4.patch
7d5642672f42f435e206acd047a20b7e38346ed95548f16c0059913546e4e4f54a58927fccb8c1da8e43b6a691bbce2a9608d0db032774d7874d4800e7202d53 0010-libtgvoip.patch
-216f8fd0deae38d18d92815b84b4a945a2b83231117d5addd0aa9338acf5cb471c29b2fdfb86ca22c237230f61fbeac14f0445379db4daaddd512cf5e546166e 0011-no-static-qt.patch
-6b524ebfa5703f705ae66949aaef746e0b422597aa6aa2ed6f6b25b17529f6c9dc126a4a33e77440aa61e67e80c91121c2b7ac781bcaff18ec20f638af15a780 0012-ffmpeg.patch
aaff642634f42ba017ac94a2c2cd7df595d0a304a62f5f46dbec82e2c88c00a8cfd6346b2809013228f47f301aedf94e10e77197eebefa26b6df81267e8b1a64 0013-lz4.patch
-ab6ef737712cbc934a908aabb57332a4d207c223f50f0108668b8c3c9fd07cd840845ef99c0dc18dca2139f476fcb0309f99058af710ffaf1272023d1d2f1ab4 0014-clock_gettime.patch"
+ab6ef737712cbc934a908aabb57332a4d207c223f50f0108668b8c3c9fd07cd840845ef99c0dc18dca2139f476fcb0309f99058af710ffaf1272023d1d2f1ab4 0014-clock_gettime.patch
+d564ee17a610864b1708f7ad1050804e24921b8bb3c4da9713f804b3738ba63d6ee0e594b3fe7c28d0fb9a082a22021b1c7f2b60498265bbca08e89775a4f60a 0015-revert-headers.patch"