aboutsummaryrefslogtreecommitdiffstats
path: root/testing/telegram-desktop
diff options
context:
space:
mode:
authorAlex Raschi <raschi.alex@gmail.com>2019-05-07 17:23:44 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-11 18:34:37 +0000
commit9d33cdd3a0e5306bfd4bd3a6b353d4344cf714a0 (patch)
treed52fe403c8fb03b8b7347b694e6de56674a83fd4 /testing/telegram-desktop
parente3010b3374f7bc4a93c056e35c9bee3f6a5ec141 (diff)
downloadaports-9d33cdd3a0e5306bfd4bd3a6b353d4344cf714a0.tar.bz2
aports-9d33cdd3a0e5306bfd4bd3a6b353d4344cf714a0.tar.xz
testing/telegram-desktop: update to 1.6.7
Diffstat (limited to 'testing/telegram-desktop')
-rw-r--r--testing/telegram-desktop/APKBUILD8
-rw-r--r--testing/telegram-desktop/tdesktop.patch19
2 files changed, 8 insertions, 19 deletions
diff --git a/testing/telegram-desktop/APKBUILD b/testing/telegram-desktop/APKBUILD
index d76a56950e..e6f4f864c9 100644
--- a/testing/telegram-desktop/APKBUILD
+++ b/testing/telegram-desktop/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Alex Raschi <raschi.alex@gmail.com>
pkgname=telegram-desktop
-pkgver=1.5.8
+pkgver=1.6.7
_pkgurl="https://github.com/telegramdesktop/tdesktop.git"
# https://github.com/telegramdesktop/tdesktop/blob/v$pkgver/docs/building-cmake.md
_gypver=702ac58e477214c635d9b541932e75a95d349352
_gypurl="https://chromium.googlesource.com/external/gyp"
-_rangever=0.4.0
+_rangever=0.5.0
_rangeurl="https://github.com/ericniebler/range-v3.git"
pkgrel=0
pkgdesc="Telegram Desktop messaging app"
@@ -141,12 +141,12 @@ package() {
done
}
-sha512sums="9067f6c46d134f88931e702ba8007416b09fdcff7ef7735f9230cae1173236b92cf402473c47ca1eecdb88c10c23c0c3b76dbd77e19bfc381e0463e3569d9ce4 telegram-desktop-1.5.8.tar.gz
+sha512sums="7a6775c42869617789862594a0665b2b9e6a1b3a05162f3c684a0fcc9960f608404a0f21f1edea261ab01e0bc0fa843a37e0cf1b0c189f3d5593cbe1abd8bcf8 telegram-desktop-1.6.7.tar.gz
9ee0dbc4b04454a2f440daa381df765616962e8e8c4330e96851dbc5f2a283da687282d666d2667aac67c3467d2079a94e4fef358dbb18eb24a064d55adc7a40 libtgvoip.patch
fc672d8168f6b2807e596570bc57f3b89296891b5d62b8e12b38193ed4919e4eb17efd72691c4086fb0ff4383de54695a9faf9874a0727a0980ef35e5ca4bee7 musl.patch
cb01655dd097b68e89b15e6e4b1f6da10c52e8bec681eeef9807ca376283b10cb3da34acc976c790f3c8dea05acbef1ba1967612920a2e4acb3b9da79e251a0d no-gtk2.patch
9df70f5057fd9938cab87529693ad9617da0fdbb9084ff57395cd540343a0dcc1ecfba4f868b0043b252fe1aca33d0d214fb07931860296e66fbf11825f95fb9 no-pulse.patch
-3cbfe1cb1bf9eb18e79c49ac67560e3290b70a7ceb1e397f4623bbfc39227468b3ab489a5813d371de31438b45751505bf3af7424f92e0e8905e23ab0d2b565d tdesktop.patch
+cdcc343e8507aed807ffb683f2b728db78c3b981a765746bbda59a97c00b373bfeb13c4251e36e8bc78c84728e91f964eb9d31616b4082393e074d7c12b44454 tdesktop.patch
8de8c0508177da5fcac4f2dcee4d8baef4b99f74f1dca296567bc3689a6bd17a47c1c945df504abc8811b82a687010d0709503c7c32e47d2ebb1cf0e374c80c5 xdg.patch
3647ad5fff6326ba9c75fa98189a08c0909af8d1c2b704c8c62fd9da6603f5162af3176c37daa67eb5896bebe3814bf1fd66b9e93c78cbd9b439e472d0db4b44 ppc64le-enable-arch.patch
ce6be003220267bac5483caf8302b492e1581892bc36d35a61236ebf9f9d766b8bd2159557a1c36256aa85f461797a38bfaae57b12da7a72101b21c0b17ed653 system-wide-fonts.patch"
diff --git a/testing/telegram-desktop/tdesktop.patch b/testing/telegram-desktop/tdesktop.patch
index 1fc6fcdf0c..2cb7f18f16 100644
--- a/testing/telegram-desktop/tdesktop.patch
+++ b/testing/telegram-desktop/tdesktop.patch
@@ -11,12 +11,12 @@
+++ b/Telegram/SourceFiles/core/launcher.cpp
@@ -39,9 +39,10 @@ void Launcher::init() {
- QCoreApplication::setApplicationName(qsl("TelegramDesktop"));
+ QApplication::setApplicationName(qsl("TelegramDesktop"));
-#ifndef OS_MAC_OLD
+#if !defined(Q_OS_MAC) && QT_VERSION >= QT_VERSION_CHECK(5, 6, 0)
+ // Retina display support is working fine, others are not.
- QCoreApplication::setAttribute(Qt::AA_DisableHighDpiScaling, true);
+ QApplication::setAttribute(Qt::AA_DisableHighDpiScaling, true);
-#endif // OS_MAC_OLD
+#endif // not defined Q_OS_MAC and QT_VERSION >= 5.6.0
@@ -24,7 +24,7 @@
}
@@ -59,6 +60,13 @@ int Launcher::exec() {
Logs::start(this); // must be started before Platform is started
- Platform::start(); // must be started before QApplication is created
+ Platform::start(); // must be started before Sandbox is created
+ // I don't know why path is not in QT_PLUGIN_PATH by default
+ QCoreApplication::addLibraryPath("/usr/lib/qt5/plugins");
@@ -36,17 +36,6 @@
auto result = executeApplication();
DEBUG_LOG(("Telegram finished, result: %1").arg(result));
---- a/Telegram/SourceFiles/platform/linux/linux_libs.h
-+++ b/Telegram/SourceFiles/platform/linux/linux_libs.h
-@@ -21,7 +21,7 @@ extern "C" {
- } // extern "C"
-
- #ifndef TDESKTOP_DISABLE_UNITY_INTEGRATION
--#include <unity/unity/unity.h>
-+typedef void UnityLauncherEntry;
- #endif // !TDESKTOP_DISABLE_UNITY_INTEGRATION
- #endif // !TDESKTOP_DISABLE_GTK_INTEGRATION
-
--- /dev/null
+++ b/Telegram/SourceFiles/qt_functions.cpp
@@ -0,0 +1,94 @@
@@ -202,7 +191,7 @@
-#endif // OS_MAC_OLD
+#endif
);
- ev.setTimestamp(getms());
+ ev.setTimestamp(crl::now());
QGuiApplication::sendEvent(windowHandle, &ev);
--- a/Telegram/gyp/PrecompiledHeader.cmake
+++ b/Telegram/gyp/PrecompiledHeader.cmake