aboutsummaryrefslogtreecommitdiffstats
path: root/testing/texmaker
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-08-19 15:19:56 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-08-19 15:20:08 +0000
commit09a78aa6ff2d0efe57acaa2d40592340ee4dbc00 (patch)
tree35a8ac2ccd164ba11a728a3354a35fca92531c18 /testing/texmaker
parentc3e1a098ed909f2b9e0cbcd7ea675c38cd0c4ae4 (diff)
downloadaports-09a78aa6ff2d0efe57acaa2d40592340ee4dbc00.tar.bz2
aports-09a78aa6ff2d0efe57acaa2d40592340ee4dbc00.tar.xz
testing/texmaker: new aport
Diffstat (limited to 'testing/texmaker')
-rw-r--r--testing/texmaker/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/texmaker/APKBUILD b/testing/texmaker/APKBUILD
new file mode 100644
index 0000000000..056ea715f2
--- /dev/null
+++ b/testing/texmaker/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname="texmaker"
+pkgver="5.0.3"
+pkgrel=0
+pkgdesc="Free cross-platform LaTeX editor since 2003"
+url="https://www.xm1math.net/texmaker/index.html"
+arch="all"
+license="GPL"
+depends="desktop-file-utils"
+makedepends="qt5-qttools-dev qt5-qtbase-dev qt5-qtscript-dev poppler-qt5"
+source="https://www.xm1math.net/texmaker/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ qmake-qt5 PREFIX=/usr texmaker.pro
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share"
+ make INSTALL_PATH="$pkgdir" INSTALL_ROOT="$pkgdir" PREFIX="/usr" install
+}
+
+sha512sums="fed09b1ac628f4a8cab24257f2ca35093f20a82d1a3b8c38d12878ff94f0933b7449e5ba651831612b62417426396327ea8ba64e830fe0537757abe65bcd5284 texmaker-5.0.3.tar.bz2"