aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tf/APKBUILD
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2018-01-24 10:07:31 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-01-27 19:44:23 +0000
commit24915c3da0f470c30262dcb1af32788fc702dfbc (patch)
tree02c12661be569b1e72093d1ef87f91c90395fd1d /testing/tf/APKBUILD
parent73dc9eda8622e8f570d143fcd9fcadd822006553 (diff)
downloadaports-24915c3da0f470c30262dcb1af32788fc702dfbc.tar.bz2
aports-24915c3da0f470c30262dcb1af32788fc702dfbc.tar.xz
testing/tf: new package
Diffstat (limited to 'testing/tf/APKBUILD')
-rw-r--r--testing/tf/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/tf/APKBUILD b/testing/tf/APKBUILD
new file mode 100644
index 0000000000..a266d9ce3e
--- /dev/null
+++ b/testing/tf/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=tf
+pkgver=5.0b8
+_pkgver=50b8
+pkgrel=0
+pkgdesc="Powerful curses-based MUD client"
+url="http://tinyfugue.sourceforge.net/"
+arch="all"
+license="GPL-2.0+"
+depends=""
+depends_dev=""
+makedepends="libressl-dev ncurses-dev pcre-dev $depends_dev"
+install=""
+source="https://sourceforge.net/projects/tinyfugue/files/tinyfugue/5.0%20beta%208/tf-$_pkgver.tar.gz
+ 0001-Add-DESTDIR-support.patch
+ 0002-Correct-use-of-va_list.patch
+ 0003-Minor-man-page-fixes.patch
+ 0006-Fix-library-install-path.patch
+ 0007-Fix-spelling-errors.patch
+ 0008-Build-on-musl.patch
+ "
+builddir="$srcdir/tf-$_pkgver"
+# no testsuite provided
+options="!check"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="3b99c039d7a9c6ab7ee7b1040ff7c99fe39cbe991f373333ea7c130d54383f102f14ae33303a415f5419cd43238caffc46114e842c6964329c0999e0f506e3d0 tf-50b8.tar.gz
+9fb762886bfbe9e6c205e7a5cde6b17c516711daafba3999bdc4f2d1aa427043d95c6d6fa0a8b057e04222726b7692f0b35622c9d5fe063cfae50d3d9429cb25 0001-Add-DESTDIR-support.patch
+7d2b2da0f4213fcfbce86eb9042cb83751c80aba5881861d5f49d4604a4eba52d60b5254c8b119528f0890ae7a68dfe4fea7eb2c94dd0d01676b194bca4db219 0002-Correct-use-of-va_list.patch
+1e8f05d2744b60cc78f494283bb5f9ef7a804a6811d16028d5486a7394658a03aed04962adfd5bc60fe1517d3831b41f4ca1c3956a624f09a2a4b14f5ab91608 0003-Minor-man-page-fixes.patch
+0066bbb3919e6b157eb276c3975cadc258a195037c0f199c3f9db83868d6035f81b79b9a41a743c99f317fd253a2f670dcf122d5f7c449fc1677c56cfaa8bb6a 0006-Fix-library-install-path.patch
+a84aeaf097eb1ec61f9c86f73795ad9f8c111057837b1a0b127905302372e01b6489f9a19f14a29171cef9a787314d511dc98e1140d0c122dd9af5f526eb4bc0 0007-Fix-spelling-errors.patch
+f9eadd1ffb2bc51db5d2bd0e9636573ef560bf849a780c8ee99bccb3870463a1b2caeaa1d3005e11d99c7689ae6ecd8f75056db09cf2d3df084058b4a3db32f0 0008-Build-on-musl.patch"