aboutsummaryrefslogtreecommitdiffstats
path: root/testing/thermald
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-21 17:11:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-21 17:11:44 -0300
commit2fc082707c9b448ac2206b07c09668c1a4bd6d8b (patch)
tree8c1be51fce207b8aac754ba16ea8b24bf8be593d /testing/thermald
parenta3749a34e4047c915c2a7bc32c255671fcd348c5 (diff)
downloadaports-2fc082707c9b448ac2206b07c09668c1a4bd6d8b.tar.bz2
aports-2fc082707c9b448ac2206b07c09668c1a4bd6d8b.tar.xz
testing/thermald: fix ppc64le build
Diffstat (limited to 'testing/thermald')
-rw-r--r--testing/thermald/APKBUILD4
-rw-r--r--testing/thermald/ppc64le.patch15
2 files changed, 18 insertions, 1 deletions
diff --git a/testing/thermald/APKBUILD b/testing/thermald/APKBUILD
index 09bc0a8947..f29c514ff2 100644
--- a/testing/thermald/APKBUILD
+++ b/testing/thermald/APKBUILD
@@ -13,6 +13,7 @@ subpackages="$pkgname-doc $pkgname-openrc"
source="$pkgname-$pkgver.tar.gz::https://github.com/01org/$_pkgname/archive/v$pkgver.tar.gz
thermald.initd
no-werror.patch
+ ppc64le.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -42,4 +43,5 @@ package() {
sha512sums="71fa6e9fc2f55623ed0acdb65f9699d5ea2c89c4092546a73d53ac3ea3ca0a5c60f3360c8bef0af9daeeecfe9a20411d9e4d25bc1d89349cfe83ebb03ba387a8 thermald-1.9.tar.gz
ea8964b15fdebc2fb59e93c15b813b93691c2ba01689ac6080f1308a3063b23cba56b4539ccae87575689036f74300a1c22c9b0e77d4ecef9bc08198d7fe4892 thermald.initd
-ea72002dcdfa907964f2ffc28947d8b2b536a93876d65872085aa9ebf2bdb549fae9c43412d74590ad88d2d71c48067726cc755630c41e30d77eb9c0c56d7308 no-werror.patch"
+ea72002dcdfa907964f2ffc28947d8b2b536a93876d65872085aa9ebf2bdb549fae9c43412d74590ad88d2d71c48067726cc755630c41e30d77eb9c0c56d7308 no-werror.patch
+789d1fa0411339b12bebfb55c3e21ba19aa3cabd94d2345c680af34d2b776c473b33871d46ff9021431cd42eea0b3626fb5c9a8b7137da17177c5918d2dea8a3 ppc64le.patch"
diff --git a/testing/thermald/ppc64le.patch b/testing/thermald/ppc64le.patch
new file mode 100644
index 0000000000..537f1503b6
--- /dev/null
+++ b/testing/thermald/ppc64le.patch
@@ -0,0 +1,15 @@
+diff --git a/src/thd_engine.cpp b/src/thd_engine.cpp
+index 82882dd..6efd7cb 100644
+--- a/src/thd_engine.cpp
++++ b/src/thd_engine.cpp
+@@ -35,7 +35,9 @@
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <sys/utsname.h>
++#ifndef __powerpc__
+ #include <cpuid.h>
++#endif
+ #include <locale>
+ #include "thd_engine.h"
+ #include "thd_cdev_therm_sys_fs.h"
+