aboutsummaryrefslogtreecommitdiffstats
path: root/testing/thunderbird-extension-enigmail
diff options
context:
space:
mode:
authorJoseph Benden <joe@benden.us>2019-07-18 00:10:48 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-08-28 12:33:37 +0000
commit641fc95383be633859e0c4cd1a22b95b3ef10c79 (patch)
tree7cb0a88f781352d32de2fa1ca85b57cb60169182 /testing/thunderbird-extension-enigmail
parent76a5e58c61aa5b678248a6eff0937cdf4a924acb (diff)
downloadaports-641fc95383be633859e0c4cd1a22b95b3ef10c79.tar.bz2
aports-641fc95383be633859e0c4cd1a22b95b3ef10c79.tar.xz
testing/thunderbird: new aport
https://www.thunderbird.net/ Thunderbird email client with package for GPG encrypted email (Enigmail). Signed-off-by: Joseph Benden <joe@benden.us>
Diffstat (limited to 'testing/thunderbird-extension-enigmail')
-rw-r--r--testing/thunderbird-extension-enigmail/0001-preferences-disable-pEpAutoDownload-by-default.patch27
-rw-r--r--testing/thunderbird-extension-enigmail/APKBUILD40
2 files changed, 67 insertions, 0 deletions
diff --git a/testing/thunderbird-extension-enigmail/0001-preferences-disable-pEpAutoDownload-by-default.patch b/testing/thunderbird-extension-enigmail/0001-preferences-disable-pEpAutoDownload-by-default.patch
new file mode 100644
index 0000000000..afc10a9d67
--- /dev/null
+++ b/testing/thunderbird-extension-enigmail/0001-preferences-disable-pEpAutoDownload-by-default.patch
@@ -0,0 +1,27 @@
+From 83d412cf08d76fab5e79b6f261c3145372337d5e Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz@archlinux.org>
+Date: Thu, 10 Jan 2019 11:38:38 -0500
+Subject: [PATCH] preferences: disable pEpAutoDownload by default
+
+Distributions should not automatically download this untrusted code;
+should be opt-in by users or be packaged separately.
+---
+ package/prefs/defaultPrefs.js | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/package/prefs/defaultPrefs.js b/package/prefs/defaultPrefs.js
+index d5ca1249..f8c10a47 100755
+--- a/package/prefs/defaultPrefs.js
++++ b/package/prefs/defaultPrefs.js
+@@ -204,7 +204,7 @@ pref("extensions.enigmail.warnDownloadContactKeys", true);
+ pref("extensions.enigmail.wrapHtmlBeforeSend", true);
+
+ // automatically download pepmda if it is available (without askin user)
+-pref("extensions.enigmail.pEpAutoDownload", true);
++pref("extensions.enigmail.pEpAutoDownload", false);
+
+ // holds the last result of the last check for pEp updates
+ pref("extensions.enigmail.pEpLastUpdate", 0);
+--
+2.20.1
+
diff --git a/testing/thunderbird-extension-enigmail/APKBUILD b/testing/thunderbird-extension-enigmail/APKBUILD
new file mode 100644
index 0000000000..32eea13f24
--- /dev/null
+++ b/testing/thunderbird-extension-enigmail/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Joseph Benden <joe@benden.us>
+
+pkgname=thunderbird-extension-enigmail
+pkgver=2.0.12
+pkgrel=0
+pkgdesc="OpenPGP message encryption and authentication for Thunderbird"
+url="https://www.enigmail.net/"
+arch="noarch"
+license="MPL-2.0 AND GPL-3.0-or-later"
+depends="thunderbird gnupg"
+makedepends="zip python2 perl"
+options="!check"
+source="https://www.enigmail.net/download/source/enigmail-${pkgver}.tar.gz
+ 0001-preferences-disable-pEpAutoDownload-by-default.patch"
+builddir="${srcdir}/enigmail"
+
+build() {
+ ./configure
+ make -j1 # fails with -j greater than 1
+}
+
+package() {
+ if [[ -f package/install.rdf ]]; then
+ _extension_id="$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' build/dist/install.rdf)"
+ else
+ _extension_id="$(sed -n 's/.*"id": "\(.*\)".*/\1/p' build/dist/manifest.json)"
+ fi
+ _extension_dest="${pkgdir}/usr/lib/thunderbird/extensions/${_extension_id}"
+ # Should this extension be unpacked or not?
+ if grep -q '<em:unpack>true</em:unpack>' build/dist/install.rdf 2>/dev/null; then
+ install -dm755 "${_extension_dest}"
+ cp -R build/dist/* "${_extension_dest}"
+ chmod -R ugo+rX "${_extension_dest}"
+ else
+ install -Dm644 build/enigmail-${pkgver}.xpi "${_extension_dest}.xpi"
+ fi
+}
+
+sha512sums="f9f4f1ed4c7244280be2fade0ccb2f4b5e7075dd60f53953478ffb84012e687b7ac7bad489c0b0cb2d8937916c783fe9e1841174bf1e5bdb9ab8cb58b415db74 enigmail-2.0.12.tar.gz
+4307c7b6bce7febba7a8186467c3bc93ec3428e1cd75cddad659e4d4a71832f1c8d46e4c811da38ff1dc38b1961a82bd84e7c90b7c63ce080be49ce69571c016 0001-preferences-disable-pEpAutoDownload-by-default.patch"