aboutsummaryrefslogtreecommitdiffstats
path: root/testing/thunderbird/APKBUILD
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-10-26 17:04:12 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-10-26 23:11:17 +0200
commit7e130731a332e3d5d593b52869e2f4e02da33f59 (patch)
tree5078b4359f3939c406c071405faea8bedc516154 /testing/thunderbird/APKBUILD
parent00be3a44472d6239a5052218d41d055fba9b3634 (diff)
downloadaports-7e130731a332e3d5d593b52869e2f4e02da33f59.tar.bz2
aports-7e130731a332e3d5d593b52869e2f4e02da33f59.tar.xz
testing/thunderbird: upgrade to 68.2.0
Diffstat (limited to 'testing/thunderbird/APKBUILD')
-rw-r--r--testing/thunderbird/APKBUILD113
1 files changed, 41 insertions, 72 deletions
diff --git a/testing/thunderbird/APKBUILD b/testing/thunderbird/APKBUILD
index 191fcf8c8b..a610b5e845 100644
--- a/testing/thunderbird/APKBUILD
+++ b/testing/thunderbird/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Joseph Benden <joe@benden.us>
pkgname=thunderbird
-pkgver=60.9.0
+pkgver=68.2.0
_pkgver=$pkgver
_xulver=$pkgver
pkgrel=0
pkgdesc="Thunderbird email client"
url="https://www.thunderbird.net/"
-arch="x86_64"
+arch="x86_64 aarch64" # limited by rust and cargo
license="GPL-3.0-or-later AND LGPL-2.1-or-later AND MPL-2.0"
options="!check !strip"
depends="
@@ -56,17 +56,16 @@ makedepends="
libtheora-dev
libtool
libvorbis-dev
- libvpx-dev
libxcomposite-dev
libxt-dev
- llvm-dev
+ llvm9-dev
mesa-dev
nasm
nodejs
nspr-dev
nss-dev
nss-static
- paxmark
+ python2
python3-dev
sed
sqlite-dev
@@ -77,38 +76,23 @@ makedepends="
"
source="https://ftp.mozilla.org/pub/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
stab.h
+
+ disable-ccache-stats.patch
fix-fortify-system-wrappers.patch
- fix-fortify-inline.patch
fix-seccomp-bpf.patch
fix-toolkit.patch
fix-tools.patch
mallinfo.patch
- mozilla-build-arm.patch
+
disable-moz-stackwalk.patch
+ fix-musl.patch
fix-rust-target.patch
- fix-bug-1261392.patch
fix-webrtc-glibcisms.patch
- sandbox-membarrier.patch
- rust-unitialized-field.patch
- rust133.patch
- 0003-Disable-ccache-stats.patch
- rust-cssparser.patch
+ fix-sandbox-membarrier.patch
thunderbird.desktop
"
_mozappdir=/usr/lib/$pkgname
-# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
-# Note: These are for Arch Linux use ONLY. For your own distribution, please
-# get your own set of keys. Feel free to contact foutrelis@archlinux.org for
-# more information.
-_google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
-
-# Mozilla API keys (see https://location.services.mozilla.com/api)
-# Note: These are for Arch Linux use ONLY. For your own distribution, please
-# get your own set of keys. Feel free to contact heftig@archlinux.org for
-# more information.
-_mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
-
# help our shared-object scanner to find the libs
ldpath="$_mozappdir"
sonameprefix="$pkgname:"
@@ -129,14 +113,11 @@ prepare() {
mkdir -p "$builddir"/objdir
echo "ac_add_options BINDGEN_CFLAGS='-I/usr/include/nspr -I/usr/include/pixman-1'" >>objdir/.mozconfig
- # add API keys
- echo -n "${_google_api_key}" > $builddir/objdir/google-api-key
- echo -n "${_mozilla_api_key}" > $builddir/objdir/mozilla-api-key
-
_clear_vendor_checksums cssparser
}
build() {
+ mkdir -p "$builddir"/objdir
cd "$builddir"/objdir
sed -e 's/checkImpl/checkFFImpl/g' -i ../js/src/vm/JSContext*.h
@@ -158,18 +139,29 @@ build() {
export CXXFLAGS="$CXXFLAGS -Wno-class-memaccess -Wno-multistatement-macros -Wno-ignored-qualifiers"
export LDFLAGS="$LDFLAGS -Wno-subobject-linkage"
- ../mach configure \
+ case "$CARCH" in
+ x86_64)
+ # disable-elf-hack: exists only on arm, x86, x86_64
+ _arch_config="--disable-elf-hack"
+ export RUST_TARGET="$CTARGET"
+ ;;
+ aarch64)
+ export RUST_TARGET="aarch64-unknown-linux-musl"
+ ;;
+ esac
+
+ ../configure \
--prefix=/usr \
--libdir=/usr/lib \
+ $_arch_config \
\
--disable-crashreporter \
- --disable-elf-hack \
--disable-gold \
- --enable-install-strip \
+ --disable-install-strip \
--disable-jemalloc \
--disable-profiling \
--disable-pulseaudio \
- --enable-strip \
+ --disable-strip \
--disable-tests \
--disable-updater \
--disable-debug \
@@ -180,22 +172,17 @@ build() {
--enable-application=comm/mail \
--enable-default-toolkit=cairo-gtk3 \
--enable-official-branding \
- --enable-optimize="$CFLAGS -fno-ident -fmerge-all-constants -ffunction-sections -fdata-sections -Wno-maybe-uninitialized -Wno-implicit-fallthrough -Wno-unused-function" \
+ --enable-optimize="$CFLAGS -O2 -fno-ident -fmerge-all-constants -ffunction-sections -fdata-sections -Wno-maybe-uninitialized -Wno-implicit-fallthrough -Wno-unused-function" \
--enable-release \
--enable-startup-notification \
--enable-system-ffi \
--enable-system-sqlite \
--enable-ffmpeg \
--enable-hardening \
- \
- --with-google-location-service-api-keyfile="${builddir}/objdir/google-api-key" \
- --with-google-safebrowsing-api-keyfile="${builddir}/objdir/google-api-key" \
- --with-mozilla-api-keyfile="${builddir}/objdir/mozilla-api-key" \
+ --enable-rust-simd \
\
--with-system-bz2 \
- --with-system-hunspell \
--with-system-icu \
- --with-system-jpeg \
--with-system-libevent \
--with-system-nspr \
--with-system-nss \
@@ -205,9 +192,9 @@ build() {
--without-ccache \
--with-clang-path=/usr/bin/clang \
--with-libclang-path=/usr/lib
- #--with-system-libvpx # requires 1.7x to work, we've got 1.8.0 currently
-
- ../mach build -v
+ # FIXME: fix build with --with-system-libvpx and libvpx 1.8.0
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1525393
+ make
}
package() {
@@ -233,14 +220,6 @@ package() {
install -m644 ${srcdir}/$pkgname.desktop ${pkgdir}/usr/share/applications/$pkgname.desktop
- # thunderbird currently does not work with mprotect. disable it for now
- local paxflags="-mp"
- [ "$CARCH" = "x86" ] && paxflags="-msp"
-
- paxmark "$paxflags" "$pkgdir"/$_mozappdir/thunderbird-bin
- paxmark "$paxflags" "$pkgdir"/$_mozappdir/plugin-container
- paxmark "$paxflags" "$pkgdir"/$_mozappdir/pingsender
-
_vendorjs="$pkgdir/usr/lib/$pkgname/defaults/preferences/vendor.js"
install -Dm644 /dev/stdin "$_vendorjs" <<END
// Use LANG environment variable to choose locale
@@ -270,11 +249,6 @@ app.distributor.channel=$pkgname
app.partner.alpinelinux=alpinelinux
END
- # Use system-provided dictionaries
- rm -r "$pkgdir/usr/lib/$pkgname/dictionaries"
- ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
- ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
-
# Install a wrapper to avoid confusion about binary path
install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
#!/bin/sh
@@ -287,22 +261,17 @@ END
"$pkgdir/usr/lib/$pkgname/thunderbird-bin"
}
-sha512sums="f59d48fba7fb8a4bf7cb160e6ca2508312a7fce950c12f133206935bcdb4c9844a9cb063aa3aae67c82562d2a51e123cc1f5bbad0238a1e5ce386c514295bdd1 thunderbird-60.9.0.source.tar.xz
+sha512sums="ca9afc870245dfaaabe3c75d4db266596c9dd714ea20b775b80e5d9df4671a5c71d2af84c734e27e07efcdb6f0fac0c34b48fda45a5a64e3e092bdafea474efc thunderbird-68.2.0.source.tar.xz
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
+3e57b2541f3889a1cf701860c8bf299f294cb077b0e8cfffda271cf02d1f59b25a697485d0df66e847e47f795b1ace54488a84a42851f2f8587717335537b44d disable-ccache-stats.patch
2f4f15974d52de4bb273b62a332d13620945d284bbc6fe6bd0a1f58ff7388443bc1d3bf9c82cc31a8527aad92b0cd3a1bc41d0af5e1800e0dcbd7033e58ffd71 fix-fortify-system-wrappers.patch
-09bc32cf9ee81b9cc6bb58ddbc66e6cc5c344badff8de3435cde5848e5a451e0172153231db85c2385ff05b5d9c20760cb18e4138dfc99060a9e960de2befbd5 fix-fortify-inline.patch
-183a4ef62cd79728117797235fe46ecd3e4336c008d615c2b2a64c707477e403aed1ee5e19feb86611b93ebecc00df339aa28a73735e045e38f0d1ce3080341b fix-seccomp-bpf.patch
-2f1bf85a340a82800dd6ba406c23489c319ec037b404f4240837854e2520b9ff11fcca0d51ac05b451c474e800fd8be13b1c57ae2917e9d1c7e5b6d91cf7e2d2 fix-toolkit.patch
-48683964624bb58b5a2a2a5c89da56e3b8dcd04f8d42c6910bea5365010a77d6d82bdd48259774ca54341edc05b6768eaa6aa1b453718c02f760361197e78b52 fix-tools.patch
-69e628668a2f450da249f761e375600e03674aeb6268dac9e282b1a7008ba47292cc8470cbc04a0ccc1d836d1653c56bb1495d5a127f906adf5807f7f95438c1 mallinfo.patch
-3671bf7623c1825c977668efec62b57873bc6052becfd8a68ddcbc2d0ba96e0c3966c61b24716e6c48167d44280d3e690a4ff986907ceba5811a653e87770fff mozilla-build-arm.patch
-e62be6e08c7e0a1d2486f271426d3986a0870f2118442ccb424a509dfc5f92cc17d05cd7e46336176afb7bd9f495b29bb739c8f88ccf918de86209efe00caf95 disable-moz-stackwalk.patch
-42cc44fda4b05259b38f055d6f51461746aa89a474cedc5e92fb9d20879da0d12b1b515b273a549e7302cda9c7eddde20d5fdba09853e5c658784ad6d0b20078 fix-rust-target.patch
-fdd698ddd94d4265cc82aa063fce1522908ad4f5f118fd207e0d64a0409e1e04e3f096625caacbacb251b42cafe0d743bb0a0b9463a882d8938b5bb4562a05e1 fix-bug-1261392.patch
-d09401eaa9620c9d4fa368865539fc4efb66eafb362d2195a653a6c6fd65e9370ced1b1b005993cbd181011360327dcb38e4b3e77b711f2c5ccf22d235ed4ef6 fix-webrtc-glibcisms.patch
-e725a6e9b2361cd566ae2f90861dbce9f2231f16721ec02f4b9f9986b7dc82cc006ea6a500ae7f30c095ce746132a5bd1d9532c4cf0d1541dcc672a20aef8807 sandbox-membarrier.patch
-01b48a708cc6bc6e3cd7cc7b16f5137ec344566ac891d699b65e322bc992726072fa14a54cef1a7775799fcbbcf90a6c170107c8524caba3bc311b42d93b7581 rust-unitialized-field.patch
-66a847c2889acc794f4db5c47f8a30e819c120f84457d5c2e094e4a2ba990036e6ca84af9d799d7446b058a5fd7292926c6e4996f105d494f1b6e8e5f3b9a6a5 rust133.patch
-3e57b2541f3889a1cf701860c8bf299f294cb077b0e8cfffda271cf02d1f59b25a697485d0df66e847e47f795b1ace54488a84a42851f2f8587717335537b44d 0003-Disable-ccache-stats.patch
-cbc7fdf297647e15ddbec87d6ac6392bb8d395a9a30d035a49d8779945f7dadbf8eb245f4220b01acbc6b3bd4e815a2eae77a2f83f2114785677fa432d2b2520 rust-cssparser.patch
+84b84d2d7dbc16002510bf856796ad345ac38ef6d3254670230189bba7c2d4781714d231236d5a3d70129a4597b430c3171644b01ad0f5a5bb13b55d407337a4 fix-seccomp-bpf.patch
+2c65ea7280e6e89826ebad563ee25203a99ff0b4ba8fc60ec261ada6c69874d649c6ac92fcecc6307a6e5a00de27d7956acf944d556ddfadec0411be16f4e0b8 fix-toolkit.patch
+4d55f41d15be7457ad630f8f07e4fc0314c2f75720010b4bbe6a2a7f3228210a1e069949e11795efbe2e784b0762e79fdfe5b8ec38e8a64cb8d9cf3b57dd5af1 fix-tools.patch
+a4a3e062661bda64d502d426c480ac9645345860118de9df9ffe6e0597738c70c11e5cdef2d4fd12c5e2ee30a09310159230524655a419a4f7e4eeeb0f3c06b0 mallinfo.patch
+454ea3263cabce099accbdc47aaf83be26a19f8b5a4568c01a7ef0384601cf8315efd86cd917f9c8bf419c2c845db89a905f3ff9a8eb0c8e41042e93aa96a85c disable-moz-stackwalk.patch
+e0df4fc649012f023443ce9165da29d36459dbca5df64a31008b28d96264fba909858de36d0cf1b1cb1aab898342413f0cd77c90ebe21d1f9a0504631d6d1d0e fix-musl.patch
+7903987b4b661286de03c6940bf67aaed6d78c9adc57680413407a84a1f1f26aaded35e6d53ea6ad527b474968b343d844e81e16d777c0e29b830b51aa2ca8c3 fix-rust-target.patch
+d35cacb9ede80e6bfbef0709823e536dddfb1c02d776275b0b7adb5969e9927d8c6117df96873569c3f3db0a18ee5db24f8086a9311a05077892be43a3dd8d79 fix-webrtc-glibcisms.patch
+f85f2c19c3dafab915bcb40e580fc442fd9eab5916696849edf0b105c758dd807dfe23a6479935613c81496711eb377c73227c03eb8582204c3442a4d0e397a2 fix-sandbox-membarrier.patch
95a2b1deb4f6c90750fdd2bfe8ca0a7879a5b267965091705a6beb0a0a4b1ccad75d11df7b9885543ca4232ff704e975c6946f4c11804cb71c471e06f9576001 thunderbird.desktop"