aboutsummaryrefslogtreecommitdiffstats
path: root/testing/thunderbird
diff options
context:
space:
mode:
authorJoseph Benden <joe@benden.us>2019-10-17 02:53:37 +0000
committerRasmus Thomsen <oss@cogitri.dev>2019-10-20 19:08:28 +0200
commit1549a700cf7c1e412f292868be23d506f62eec3b (patch)
tree2febc97d028aba29c208317b58133714b5433f21 /testing/thunderbird
parent48c4334e08aedbe7dbeb1fb316a4c9fcb68149b3 (diff)
downloadaports-1549a700cf7c1e412f292868be23d506f62eec3b.tar.bz2
aports-1549a700cf7c1e412f292868be23d506f62eec3b.tar.xz
testing/thunderbird: update to 60.9.0
This patch upgrades the version of Thunderbird to 60.9.0. Signed-off-by: Joseph Benden <joe@benden.us>
Diffstat (limited to 'testing/thunderbird')
-rw-r--r--testing/thunderbird/APKBUILD19
-rw-r--r--testing/thunderbird/rust-cssparser.patch92
2 files changed, 107 insertions, 4 deletions
diff --git a/testing/thunderbird/APKBUILD b/testing/thunderbird/APKBUILD
index c29c64ad03..191fcf8c8b 100644
--- a/testing/thunderbird/APKBUILD
+++ b/testing/thunderbird/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Joseph Benden <joe@benden.us>
pkgname=thunderbird
-pkgver=60.8.0
+pkgver=60.9.0
_pkgver=$pkgver
_xulver=$pkgver
pkgrel=0
@@ -92,6 +92,7 @@ source="https://ftp.mozilla.org/pub/thunderbird/releases/$pkgver/source/thunderb
rust-unitialized-field.patch
rust133.patch
0003-Disable-ccache-stats.patch
+ rust-cssparser.patch
thunderbird.desktop
"
_mozappdir=/usr/lib/$pkgname
@@ -112,6 +113,13 @@ _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
ldpath="$_mozappdir"
sonameprefix="$pkgname:"
+# we need this because cargo verifies checksums of all files in vendor
+# crates when it builds and gives us no way to override or update the
+# file sanely... so just clear out the file list
+_clear_vendor_checksums() {
+ sed -i 's/\("files":{\)[^}]*/\1/' third_party/rust/$1/.cargo-checksum.json
+}
+
prepare() {
default_prepare
@@ -124,6 +132,8 @@ prepare() {
# add API keys
echo -n "${_google_api_key}" > $builddir/objdir/google-api-key
echo -n "${_mozilla_api_key}" > $builddir/objdir/mozilla-api-key
+
+ _clear_vendor_checksums cssparser
}
build() {
@@ -170,7 +180,7 @@ build() {
--enable-application=comm/mail \
--enable-default-toolkit=cairo-gtk3 \
--enable-official-branding \
- --enable-optimize="$CFLAGS -fno-ident -fmerge-all-constants -ffunction-sections -fdata-sections -Wno-maybe-uninitialized -Wno-implicit-fallthrough" \
+ --enable-optimize="$CFLAGS -fno-ident -fmerge-all-constants -ffunction-sections -fdata-sections -Wno-maybe-uninitialized -Wno-implicit-fallthrough -Wno-unused-function" \
--enable-release \
--enable-startup-notification \
--enable-system-ffi \
@@ -193,7 +203,7 @@ build() {
--with-system-png \
--with-system-zlib \
--without-ccache \
- --with-clang-path=/usr/bin/clang-8 \
+ --with-clang-path=/usr/bin/clang \
--with-libclang-path=/usr/lib
#--with-system-libvpx # requires 1.7x to work, we've got 1.8.0 currently
@@ -277,7 +287,7 @@ END
"$pkgdir/usr/lib/$pkgname/thunderbird-bin"
}
-sha512sums="b465544a8cbedf0aff0f737cf98e2d030331f1ea016b2e541dfe30a5cf3172f9075e5a9c8d6b7e0f97ffc2e0d3eebbaf9a39e76a499b9fc976bbc0c944dfd058 thunderbird-60.8.0.source.tar.xz
+sha512sums="f59d48fba7fb8a4bf7cb160e6ca2508312a7fce950c12f133206935bcdb4c9844a9cb063aa3aae67c82562d2a51e123cc1f5bbad0238a1e5ce386c514295bdd1 thunderbird-60.9.0.source.tar.xz
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
2f4f15974d52de4bb273b62a332d13620945d284bbc6fe6bd0a1f58ff7388443bc1d3bf9c82cc31a8527aad92b0cd3a1bc41d0af5e1800e0dcbd7033e58ffd71 fix-fortify-system-wrappers.patch
09bc32cf9ee81b9cc6bb58ddbc66e6cc5c344badff8de3435cde5848e5a451e0172153231db85c2385ff05b5d9c20760cb18e4138dfc99060a9e960de2befbd5 fix-fortify-inline.patch
@@ -294,4 +304,5 @@ e725a6e9b2361cd566ae2f90861dbce9f2231f16721ec02f4b9f9986b7dc82cc006ea6a500ae7f30
01b48a708cc6bc6e3cd7cc7b16f5137ec344566ac891d699b65e322bc992726072fa14a54cef1a7775799fcbbcf90a6c170107c8524caba3bc311b42d93b7581 rust-unitialized-field.patch
66a847c2889acc794f4db5c47f8a30e819c120f84457d5c2e094e4a2ba990036e6ca84af9d799d7446b058a5fd7292926c6e4996f105d494f1b6e8e5f3b9a6a5 rust133.patch
3e57b2541f3889a1cf701860c8bf299f294cb077b0e8cfffda271cf02d1f59b25a697485d0df66e847e47f795b1ace54488a84a42851f2f8587717335537b44d 0003-Disable-ccache-stats.patch
+cbc7fdf297647e15ddbec87d6ac6392bb8d395a9a30d035a49d8779945f7dadbf8eb245f4220b01acbc6b3bd4e815a2eae77a2f83f2114785677fa432d2b2520 rust-cssparser.patch
95a2b1deb4f6c90750fdd2bfe8ca0a7879a5b267965091705a6beb0a0a4b1ccad75d11df7b9885543ca4232ff704e975c6946f4c11804cb71c471e06f9576001 thunderbird.desktop"
diff --git a/testing/thunderbird/rust-cssparser.patch b/testing/thunderbird/rust-cssparser.patch
new file mode 100644
index 0000000000..1fc1805234
--- /dev/null
+++ b/testing/thunderbird/rust-cssparser.patch
@@ -0,0 +1,92 @@
+This is a fix for rust version 1.38.0, which causes the warning below to become an error.
+
+backport of:
+
+From 3c98d22c5de3b696bf1fde2b6c90069812312aa6 Mon Sep 17 00:00:00 2001
+From: Simon Sapin <simon.sapin@exyr.org>
+Date: Tue, 23 Apr 2019 13:47:25 +0200
+Subject: [PATCH] Fix a future-compat warning
+
+```
+warning[E0506]: cannot assign to `self.input.cached_token` because it is borrowed
+ --> src/parser.rs:591:17
+ |
+566 | pub fn next_including_whitespace_and_comments(&mut self) -> Result<&Token<'i>, BasicParseError<'i>> {
+ | - let's call the lifetime of this reference `'1`
+...
+579 | Some(ref cached_token)
+ | ---------------- borrow of `self.input.cached_token` occurs here
+...
+591 | self.input.cached_token = Some(CachedToken {
+ | ^^^^^^^^^^^^^^^^^^^^^^^ assignment to borrowed `self.input.cached_token` occurs here
+...
+603 | Ok(token)
+ | --------- returning this value requires that `self.input.cached_token.0` is borrowed for `'1`
+ |
+ = warning: this error has been downgraded to a warning for backwards compatibility with previous releases
+ = warning: this represents potential undefined behavior in your code and this warning will become a hard error in the future
+```
+---
+ src/parser.rs | 50 +++++++++++++++++++++++++++-----------------------
+ 1 file changed, 27 insertions(+), 23 deletions(-)
+
+diff --git a/src/parser.rs b/src/parser.rs
+index 51f441e4..7cef117c 100644
+--- a/third_party/rust/cssparser/src/parser.rs
++++ b/third_party/rust/cssparser/src/parser.rs
+@@ -555,28 +555,34 @@
+ }
+
+ let token_start_position = self.input.tokenizer.position();
+- let token;
+- match self.input.cached_token {
+- Some(ref cached_token)
+- if cached_token.start_position == token_start_position => {
+- self.input.tokenizer.reset(&cached_token.end_state);
+- match cached_token.token {
+- Token::Function(ref name) => self.input.tokenizer.see_function(name),
+- _ => {}
+- }
+- token = &cached_token.token
++ let using_cached_token = self
++ .input
++ .cached_token
++ .as_ref()
++ .map_or(false, |cached_token| {
++ cached_token.start_position == token_start_position
++ });
++ let token = if using_cached_token {
++ let cached_token = self.input.cached_token.as_ref().unwrap();
++ self.input.tokenizer.reset(&cached_token.end_state);
++ match cached_token.token {
++ Token::Function(ref name) => self.input.tokenizer.see_function(name),
++ _ => {}
+ }
+- _ => {
+- let new_token = self.input.tokenizer.next()
+- .map_err(|()| self.new_basic_error(BasicParseErrorKind::EndOfInput))?;
+- self.input.cached_token = Some(CachedToken {
+- token: new_token,
+- start_position: token_start_position,
+- end_state: self.input.tokenizer.state(),
+- });
+- token = self.input.cached_token_ref()
+- }
+- }
++ &cached_token.token
++ } else {
++ let new_token = self
++ .input
++ .tokenizer
++ .next()
++ .map_err(|()| self.new_basic_error(BasicParseErrorKind::EndOfInput))?;
++ self.input.cached_token = Some(CachedToken {
++ token: new_token,
++ start_position: token_start_position,
++ end_state: self.input.tokenizer.state(),
++ });
++ self.input.cached_token_ref()
++ };
+
+ if let Some(block_type) = BlockType::opening(token) {
+ self.at_start_of = Some(block_type);