aboutsummaryrefslogtreecommitdiffstats
path: root/testing/thunderbird
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-04-25 02:27:01 +0200
committerTBK <tbk@jjtc.eu>2020-04-25 13:35:48 +0000
commitc290ece8c5d488bd50bc55c904dcb9e1fe0827d4 (patch)
tree4c1067fbdb4a62a41c6a9a75be36b3307ef6a7be /testing/thunderbird
parent7ebfa23b6119a24ca9b9375bdc55373259192da1 (diff)
downloadaports-c290ece8c5d488bd50bc55c904dcb9e1fe0827d4.tar.bz2
aports-c290ece8c5d488bd50bc55c904dcb9e1fe0827d4.tar.xz
testing/thunderbird: fix FTBFS
error: casts cannot be followed by a field access --> servo/components/style/stylesheets/viewport_rule.rs:314:39 | 314 | declaration!($min(value: shorthand.0, important: important)), | ^^^^^^^^^^^^^^^^ ... 323 | "width" => ok!(shorthand -> [MinWidth, MaxWidth]), | -------------------------------------- in this macro invocation | = note: this error originates in a macro (in Nightly builds, run with -Z macro-backtrace for more info) help: try surrounding the expression in parentheses | 314 | declaration!($min((value: shorthand).0, important: important)),
Diffstat (limited to 'testing/thunderbird')
-rw-r--r--testing/thunderbird/APKBUILD4
-rw-r--r--testing/thunderbird/fix-casts.patch198
2 files changed, 201 insertions, 1 deletions
diff --git a/testing/thunderbird/APKBUILD b/testing/thunderbird/APKBUILD
index 86dad8d7f7..c4c337adf3 100644
--- a/testing/thunderbird/APKBUILD
+++ b/testing/thunderbird/APKBUILD
@@ -7,7 +7,6 @@ pkgrel=1
pkgdesc="Thunderbird email client"
url="https://www.thunderbird.net/"
arch="all !s390x !armhf !mips !mips64" # limited by rust and cargo. Fails on armhf due to bad assembly
-arch="" # Limited by new rust failing to compile it
license="GPL-3.0-or-later AND LGPL-2.1-or-later AND MPL-2.0"
options="!check !strip"
depends="
@@ -87,6 +86,8 @@ source="https://ftp.mozilla.org/pub/thunderbird/releases/$pkgver/source/thunderb
fix-webrtc-glibcisms.patch
fix-sandbox-membarrier.patch
fd6847c9416f9eebde636e21d794d25d1be8791d.patch
+ fix-casts.patch
+
thunderbird.desktop
"
# secfixes:
@@ -306,4 +307,5 @@ e0df4fc649012f023443ce9165da29d36459dbca5df64a31008b28d96264fba909858de36d0cf1b1
d35cacb9ede80e6bfbef0709823e536dddfb1c02d776275b0b7adb5969e9927d8c6117df96873569c3f3db0a18ee5db24f8086a9311a05077892be43a3dd8d79 fix-webrtc-glibcisms.patch
f85f2c19c3dafab915bcb40e580fc442fd9eab5916696849edf0b105c758dd807dfe23a6479935613c81496711eb377c73227c03eb8582204c3442a4d0e397a2 fix-sandbox-membarrier.patch
60845dcb034b2c4459c30f7d5f25c8176cf42df794e2cc0e86c3e2abb6541c24b962f3a16ca70a288d4d6f377b68d00b2904b22463108559612053d835d9bff1 fd6847c9416f9eebde636e21d794d25d1be8791d.patch
+f1c22c40909507a98cfb87942cbd78f2a7e657eb339f8784734c23b9b188d3b612ef3b0667f56dd10d90474742f7ef2468414a4b221497730c2ac4393707a628 fix-casts.patch
95a2b1deb4f6c90750fdd2bfe8ca0a7879a5b267965091705a6beb0a0a4b1ccad75d11df7b9885543ca4232ff704e975c6946f4c11804cb71c471e06f9576001 thunderbird.desktop"
diff --git a/testing/thunderbird/fix-casts.patch b/testing/thunderbird/fix-casts.patch
new file mode 100644
index 0000000000..70b2880058
--- /dev/null
+++ b/testing/thunderbird/fix-casts.patch
@@ -0,0 +1,198 @@
+Based on upstream commit - https://github.com/servo/servo/commit/98e4a53b7241d562d127e0f7005ffb38f21d1380.patch
+
+---
+From 98e4a53b7241d562d127e0f7005ffb38f21d1380 Mon Sep 17 00:00:00 2001
+From: Simon Sapin <simon.sapin@exyr.org>
+Date: Fri, 16 Aug 2019 13:53:01 +0200
+Subject: [PATCH] Upgrade to rustc 1.39.0-nightly (f7af19c27 2019-08-15)
+
+---
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -235,7 +235,7 @@
+ version = "0.49.4"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ dependencies = [
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "cexpr 0.3.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "cfg-if 0.1.6 (registry+https://github.com/rust-lang/crates.io-index)",
+ "clang-sys 0.28.0 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -497,7 +497,7 @@
+ dependencies = [
+ "ansi_term 0.11.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "atty 0.2.11 (registry+https://github.com/rust-lang/crates.io-index)",
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "strsim 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "term_size 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "textwrap 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -510,7 +510,7 @@
+ version = "0.0.3"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ dependencies = [
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
+ [[package]]
+@@ -563,7 +563,7 @@
+ version = "0.17.1"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ dependencies = [
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "core-foundation 0.6.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "foreign-types 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.51 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -801,7 +801,7 @@
+ version = "0.5.4"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ dependencies = [
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "cubeb-sys 0.5.4 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
+@@ -1140,7 +1140,7 @@
+ version = "0.3.3"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ dependencies = [
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "fuchsia-zircon-sys 0.3.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
+@@ -1630,7 +1630,7 @@
+ version = "0.11.2"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ dependencies = [
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.51 (registry+https://github.com/rust-lang/crates.io-index)",
+ "lmdb-rkv-sys 0.8.4 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+@@ -2004,7 +2004,7 @@
+ name = "nsstring"
+ version = "0.1.0"
+ dependencies = [
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "encoding_rs 0.8.16 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
+@@ -2228,7 +2228,7 @@
+ version = "0.14.0"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ dependencies = [
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "deflate 0.7.19 (registry+https://github.com/rust-lang/crates.io-index)",
+ "inflate 0.4.5 (registry+https://github.com/rust-lang/crates.io-index)",
+ "num-iter 0.1.37 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -2283,7 +2283,7 @@
+ name = "pulse"
+ version = "0.2.0"
+ dependencies = [
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "pulse-ffi 0.1.0",
+ ]
+
+@@ -2665,7 +2665,7 @@
+ name = "selectors"
+ version = "0.21.0"
+ dependencies = [
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "cssparser 0.25.7 (registry+https://github.com/rust-lang/crates.io-index)",
+ "derive_more 0.13.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "fxhash 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -2881,7 +2881,7 @@
+ "arrayvec 0.4.6 (registry+https://github.com/rust-lang/crates.io-index)",
+ "atomic_refcell 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "bindgen 0.49.4 (registry+https://github.com/rust-lang/crates.io-index)",
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "byteorder 1.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "cssparser 0.25.7 (registry+https://github.com/rust-lang/crates.io-index)",
+ "derive_more 0.13.0 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -2944,7 +2944,7 @@
+ version = "0.0.1"
+ dependencies = [
+ "app_units 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)",
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "cssparser 0.25.7 (registry+https://github.com/rust-lang/crates.io-index)",
+ "euclid 0.19.5 (registry+https://github.com/rust-lang/crates.io-index)",
+ "lazy_static 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -3328,7 +3328,7 @@
+ name = "u2fhid"
+ version = "0.2.3"
+ dependencies = [
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "boxfnonce 0.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "core-foundation 0.6.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "devd-rs 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -3493,7 +3493,7 @@
+ dependencies = [
+ "base64 0.10.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "bincode 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "byteorder 1.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "cfg-if 0.1.6 (registry+https://github.com/rust-lang/crates.io-index)",
+ "core-foundation 0.6.3 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -3533,7 +3533,7 @@
+ dependencies = [
+ "app_units 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "bincode 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
++ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "byteorder 1.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "core-foundation 0.6.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "core-graphics 0.17.1 (registry+https://github.com/rust-lang/crates.io-index)",
+--- a/servo/components/style/stylesheets/viewport_rule.rs
++++ b/servo/components/style/stylesheets/viewport_rule.rs
+@@ -291,15 +291,18 @@ impl<'a, 'b, 'i> DeclarationParser<'i> for ViewportRuleParser<'a, 'b> {
+ ) -> Result<Vec<ViewportDescriptorDeclaration>, ParseError<'i>> {
+ macro_rules! declaration {
+ ($declaration:ident($parse:expr)) => {
+- declaration!($declaration(value: try!($parse(input)),
+- important: input.try(parse_important).is_ok()))
++ declaration!($declaration {
++ value: $parse(input)?,
++ important: input.try(parse_important).is_ok(),
++ })
+ };
+- ($declaration:ident(value: $value:expr, important: $important:expr)) => {
++ ($declaration:ident { value: $value:expr, important: $important:expr, }) => {
+ ViewportDescriptorDeclaration::new(
+ self.context.stylesheet_origin,
+ ViewportDescriptor::$declaration($value),
+- $important)
+- }
++ $important,
++ )
++ };
+ }
+
+ macro_rules! ok {
+@@ -311,8 +314,14 @@ impl<'a, 'b, 'i> DeclarationParser<'i> for ViewportRuleParser<'a, 'b> {
+ let important = input.try(parse_important).is_ok();
+
+ Ok(vec![
+- declaration!($min(value: shorthand.0, important: important)),
+- declaration!($max(value: shorthand.1, important: important)),
++ declaration!($min {
++ value: shorthand.0,
++ important: important,
++ }),
++ declaration!($max {
++ value: shorthand.1,
++ important: important,
++ }),
+ ])
+ }};
+ }