aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tiled
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-01-12 12:45:39 +0100
committerMilan P. Stanić <mps@arvanta.net>2020-01-12 14:00:40 +0100
commit1b2f8692602ecb45f9869dcd35ca31ed4df4286c (patch)
tree914ed6db397b4444c14675a3c6c875853b6dc78f /testing/tiled
parent1377f4e2394283d7db49be90b775a7e83ce82b48 (diff)
downloadaports-1b2f8692602ecb45f9869dcd35ca31ed4df4286c.tar.bz2
aports-1b2f8692602ecb45f9869dcd35ca31ed4df4286c.tar.xz
testing/tiled: new aport
http://mapeditor.org A powerful tile map editor
Diffstat (limited to 'testing/tiled')
-rw-r--r--testing/tiled/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/tiled/APKBUILD b/testing/tiled/APKBUILD
new file mode 100644
index 0000000000..2a729c4b2b
--- /dev/null
+++ b/testing/tiled/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname="tiled"
+pkgver=1.3.1
+pkgrel=0
+pkgdesc="powerful tile map editor"
+url="http://mapeditor.org"
+arch="all"
+license="Apache-2.0 AND BSD-2-Clause AND GPL-2.0-only"
+makedepends="qt5-qttools-dev qt5-qtdeclarative-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/bjorn/tiled/archive/v$pkgver.tar.gz"
+options="!check"
+
+build() {
+ qmake-qt5 -r INSTALL_HEADERS=yes PREFIX=/usr
+ make
+}
+
+package() {
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="b2ed5c0ff043990177809873417e31e8ee2894473b3084d0302e5557c19043c1763cf55d8ade16335ba3d64e7b4b903dd5fb88fd4bcf878c7c4d873bc9c7ed73 tiled-1.3.1.tar.gz"