aboutsummaryrefslogtreecommitdiffstats
path: root/testing/timew
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-04-04 18:42:28 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-04-04 18:42:28 +0000
commit1b40c9d35c549fd77a85942e44e2cbbbc0d599f5 (patch)
treec12096eae4145c7e2207646135875b3f8750b4e0 /testing/timew
parentfa0a5dbf864038261be4c415e5a9d8881945e4e2 (diff)
downloadaports-1b40c9d35c549fd77a85942e44e2cbbbc0d599f5.tar.bz2
aports-1b40c9d35c549fd77a85942e44e2cbbbc0d599f5.tar.xz
testing/timew: fix FTBFS on ppc64le
Currently timew FTBFS on ppc64le because there is no PATH_MAX defined implicitly. If your code needs to use PATH_MAX, it needs to include limits.h.
Diffstat (limited to 'testing/timew')
-rw-r--r--testing/timew/APKBUILD9
-rw-r--r--testing/timew/musl_limits.patch25
2 files changed, 30 insertions, 4 deletions
diff --git a/testing/timew/APKBUILD b/testing/timew/APKBUILD
index 3a64ba175c..224e077c72 100644
--- a/testing/timew/APKBUILD
+++ b/testing/timew/APKBUILD
@@ -11,7 +11,9 @@ depends=""
makedepends="cmake"
install=""
subpackages="$pkgname-doc"
-source="http://taskwarrior.org/download/$pkgname-$pkgver.tar.gz"
+source="http://taskwarrior.org/download/$pkgname-$pkgver.tar.gz
+ musl_limits.patch"
+
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -27,6 +29,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="edd5f8a064e5c8f030324e3d98b79d54 timew-1.0.0.tar.gz"
-sha256sums="ac027910e1e8365bdd218a8b42389b26d017d38d3c96516c408db6d5a44e0bb5 timew-1.0.0.tar.gz"
-sha512sums="0539ff93b2375c154d126c39aa84f21b57b62f51c220c80b2e323a4d6aefd2eda6f87c04112e096222102b019ee3683a78b9ee9d6fbf6736d4a34c529f6152f5 timew-1.0.0.tar.gz"
+sha512sums="0539ff93b2375c154d126c39aa84f21b57b62f51c220c80b2e323a4d6aefd2eda6f87c04112e096222102b019ee3683a78b9ee9d6fbf6736d4a34c529f6152f5 timew-1.0.0.tar.gz
+e0658719ff8ff70d811ebe90bde652160e69d7c4b1744569924e2047151395ea013fe492f526329b722c47728b78c1bbebea719b2eabc217b93cbf175da86584 musl_limits.patch"
diff --git a/testing/timew/musl_limits.patch b/testing/timew/musl_limits.patch
new file mode 100644
index 0000000000..31ec977ee4
--- /dev/null
+++ b/testing/timew/musl_limits.patch
@@ -0,0 +1,25 @@
+commit e8ae212aca78e332a03e79a4dacc75cfffa43011
+Author: Breno Leitao <breno.leitao@gmail.com>
+Date: Tue April 04 14:12:11 2017 -0300
+
+ Include limits.h if you want to use PATH_MAX
+
+ timew FTBFS on ppc64le due to lack of PATH_MAX being implicitly defined.
+ On ppc64le, if you wish to have access to this macro, you must have
+ limits.h included explicitly.
+
+ Signed-off-by: Breno Leitao <breno.leitao@gmail.com>
+
+Index: timew/src/timew-1.0.0/src/libshared/src/FS.cpp
+===================================================================
+--- timew.orig/src/timew-1.0.0/src/libshared/src/FS.cpp
++++ timew/src/timew-1.0.0/src/libshared/src/FS.cpp
+@@ -41,7 +41,7 @@
+ #include <shared.h>
+ #include <format.h>
+
+-#if defined SOLARIS || defined NETBSD || defined FREEBSD
++#if defined SOLARIS || defined NETBSD || defined FREEBSD || !defined(PATH_MAX)
+ #include <limits.h>
+ #endif
+