aboutsummaryrefslogtreecommitdiffstats
path: root/testing/timg
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-05-09 20:46:27 +0000
committerMilan P. Stanić <mps@arvanta.net>2019-05-19 22:14:39 +0200
commitb3e96a30a0369b698d07870cdf2e7ed6b769495f (patch)
tree6d8a440bcb4d8152353749fc492572b8f6f64aeb /testing/timg
parentd9e67a9156a75a51587b1e85a959cc8e9d01dfb4 (diff)
downloadaports-b3e96a30a0369b698d07870cdf2e7ed6b769495f.tar.bz2
aports-b3e96a30a0369b698d07870cdf2e7ed6b769495f.tar.xz
testing/timg: new aport
Diffstat (limited to 'testing/timg')
-rw-r--r--testing/timg/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/timg/APKBUILD b/testing/timg/APKBUILD
new file mode 100644
index 0000000000..aab8473b14
--- /dev/null
+++ b/testing/timg/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=timg
+pkgver=0.9.5
+pkgrel=0
+pkgdesc="24-Bit color image viewer for terminal"
+url="https://github.com/hzeller/timg"
+arch="all"
+options="!check" # package doesn't have test
+license="GPL-2.0-only"
+makedepends="libwebp-dev graphicsmagick-dev freetype-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hzeller/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"/src
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 timg "$pkgdir"/usr/bin/timg
+}
+
+sha512sums="993bdaf80f05fa7e7961d6f4fc5847313a679934750e0b38c78d3f3ad9ebe54d9b67b580a085734626ae43da58b33f2b2a0dcba203e00235095be667a4c01657 timg-0.9.5.tar.gz"