aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tinyxml2
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-06-30 23:09:43 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-03 12:33:03 +0000
commit8c0cda45bc8914d5e1c3009cfcfec33e6ecc3d3d (patch)
treeb8cabd62211572c0fa33e56b69a6e70bfa039f68 /testing/tinyxml2
parentb5c62a4bb7b6fb801febfe985f3ba72b04b39dee (diff)
downloadaports-8c0cda45bc8914d5e1c3009cfcfec33e6ecc3d3d.tar.bz2
aports-8c0cda45bc8914d5e1c3009cfcfec33e6ecc3d3d.tar.xz
testing/tinyxml2: new aport
Diffstat (limited to 'testing/tinyxml2')
-rw-r--r--testing/tinyxml2/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/tinyxml2/APKBUILD b/testing/tinyxml2/APKBUILD
new file mode 100644
index 0000000000..c5204007ee
--- /dev/null
+++ b/testing/tinyxml2/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=tinyxml2
+pkgver=5.0.1
+pkgrel=0
+pkgdesc="A simple, small, efficient, C++ XML parser"
+url="http://www.grinninglizard.com/tinyxml2/"
+arch="all"
+license="zlib"
+makedepends="cmake"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/leethomason/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/"$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ mkdir -p build && cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ make test
+}
+
+package() {
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="a51ec5843774df0482620c549fb6c61d30a6db5025be26ff6d25b3c53533a27a57f00b026bd9fbca78e9e30084b3f5f6fbff9dba315d078419da084b57f518ba tinyxml2-5.0.1.tar.gz"