aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tolua
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /testing/tolua
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'testing/tolua')
-rw-r--r--testing/tolua/APKBUILD46
-rw-r--r--testing/tolua/config37
2 files changed, 0 insertions, 83 deletions
diff --git a/testing/tolua/APKBUILD b/testing/tolua/APKBUILD
deleted file mode 100644
index b7349f6812..0000000000
--- a/testing/tolua/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=tolua
-pkgver=5.1.4
-pkgrel=0
-pkgdesc="Tool to integrace C/C++ code in lua"
-url="http://www.tecgraf.puc-rio.br/~celes/tolua/"
-arch="all"
-license="MIT"
-depends=""
-depends_dev="lua-dev"
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-dev"
-source="http://www.tecgraf.puc-rio.br/~celes/tolua/tolua-$pkgver.tar.gz"
-
-_builddir="$srcdir"/tolua-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- sed -i -e '/^CC=/d' \
- -e 's/^CCPP *=.*/CCPP=$(CXX)/' \
- -e 's/^CFLAGS *=/CFLAGS+=/' \
- -e 's/^CPPFLAGS *=/CPPFLAGS+=/' \
- config || return 1
- # clean up some stuff that probably not was supposed to be there
- find \( -name '.*DS_Store' -o -name '._*' \) -delete
-}
-
-build() {
- cd "$_builddir"
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- install -d "$pkgdir"/usr
- cp -r bin lib include "$pkgdir"/usr/
-}
-
-md5sums="46d67c3b9b4b983368a9ff0baa2139f9 tolua-5.1.4.tar.gz"
diff --git a/testing/tolua/config b/testing/tolua/config
deleted file mode 100644
index cf148eb13f..0000000000
--- a/testing/tolua/config
+++ /dev/null
@@ -1,37 +0,0 @@
-# configuration file for making tolua
-
-# == CHANGE THE SETTINGS BELOW TO SUIT YOUR ENVIRONMENT ======================
-
-# you need an ANSI C compiler. gcc is a popular one.
-CC?= gcc
-CXX?= g++
-CCPP=$(CXX)
-WARN= -ansi -Wall -g
-
-# on SGI's, cc is ANSI.
-#CC= cc
-#WARN= -ansi -fullwarn
-
-# if your system doesn't have (or need) ranlib, change "ranlib" to "true".
-# on some systems, "ar s" does it.
-RANLIB= ranlib
-#RANLIB= ar s
-#RANLIB= true
-
-# this should work in all unix systems.
-AR= ar rcu
-
-# set lua path
-LUA=/usr/local
-LUAINC=$(LUA)/include
-LUALIB=$(LUA)/lib
-
-# == END OF USER SETTINGS. DO NOT CHANGE ANYTHING BELOW THIS LINE ============
-
-INC= -I$(TOLUA)/include -I$(LUAINC)
-LIB= -L$(TOLUA)/lib -L$(LUALIB)
-
-#CFLAGS= -O2 $(WARN) $(INC)
-#CPPFLAGS= -O2 $(WARN) $(INC)
-CFLAGS+= -g $(WARN) $(INC)
-CPPFLAGS+= -g $(WARN) $(INC)