aboutsummaryrefslogtreecommitdiffstats
path: root/testing/toxcore
diff options
context:
space:
mode:
authorJonathanS <mail@strfry.org>2019-06-25 00:23:01 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-05 15:49:17 -0300
commit499ab24e729b1673118da3f143f11ae8a0b32e27 (patch)
tree6f21340e001450dcc2f3aaa6f6e439d3fb46764e /testing/toxcore
parentbde5d60a4ef124bb93eb835fed33ca5a83f4c3c5 (diff)
downloadaports-499ab24e729b1673118da3f143f11ae8a0b32e27.tar.bz2
aports-499ab24e729b1673118da3f143f11ae8a0b32e27.tar.xz
testing/toxcore: new package
Diffstat (limited to 'testing/toxcore')
-rw-r--r--testing/toxcore/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/toxcore/APKBUILD b/testing/toxcore/APKBUILD
new file mode 100644
index 0000000000..2290bcb474
--- /dev/null
+++ b/testing/toxcore/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jonathan Sieber <mail@strfry.org>
+pkgname=toxcore
+pkgver=0.2.9
+pkgrel=0
+pkgdesc="Tox communication project - Core Library"
+url="https://tox.chat/"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="linux-headers cmake libsodium-dev opus-dev libvpx-dev"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/TokTok/c-toxcore/archive/v$pkgver.tar.gz"
+
+# Toxcore's tests do require networking and are not working properly in Travis-CI
+options="!check"
+
+builddir="$srcdir/c-$pkgname-$pkgver"
+
+build() {
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=lib
+
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="917826a906a9ca4f04f34494616b8e36ec9e74c6b0709c50e8fe2dd9da680d170013fef242a3fe1b834e8e54cd2dde6be1c14e5d977f8531436ef34280bc3966 toxcore-0.2.9.tar.gz"