aboutsummaryrefslogtreecommitdiffstats
path: root/testing/traefik/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-21 16:04:33 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-21 16:04:33 +0000
commita5d52bc484be9e193e79a31509d9aabfae7de078 (patch)
tree1cc010a79c6ee5118b2d94c4010f65700a4984b0 /testing/traefik/APKBUILD
parent774e7fcd01c362cd13f6b1200afcae6a1414e094 (diff)
downloadaports-a5d52bc484be9e193e79a31509d9aabfae7de078.tar.bz2
aports-a5d52bc484be9e193e79a31509d9aabfae7de078.tar.xz
testing/traefik: add check
Diffstat (limited to 'testing/traefik/APKBUILD')
-rw-r--r--testing/traefik/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/traefik/APKBUILD b/testing/traefik/APKBUILD
index 5287e87b6e..b1fa0e5cd2 100644
--- a/testing/traefik/APKBUILD
+++ b/testing/traefik/APKBUILD
@@ -2,14 +2,13 @@
# Maintainer: Joe Holden <jwh@zorins.us>
pkgname=traefik
pkgver=1.7.5
-pkgrel=0
+pkgrel=1
pkgdesc="The Cloud Native Edge Router"
url="https://traefik.io"
arch="all"
license="MIT"
makedepends="go go-bindata"
install="$pkgname.pre-install"
-options="!check" # [no test files]
pkgusers="$pkgname"
pkggroups="$pkgname"
subpackages="$pkgname-openrc"
@@ -33,8 +32,13 @@ build() {
}
check() {
+ # Unit tests
cd "$builddir"
- GOPATH="$srcdir" go test
+ GOPATH="$srcdir" go test ./...
+
+ # Integration tests
+ cd "$builddir"/integration
+ GOPATH="$srcdir" go test -integration ./...
}
package() {