aboutsummaryrefslogtreecommitdiffstats
path: root/testing/translate-shell
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-29 01:58:19 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-29 16:34:04 -0300
commite2f4c93e6ee2aa7f380b79ec1799a6e87ffb62f5 (patch)
treec16ed1e51f40a6a5233c04f98e576abdebf204a8 /testing/translate-shell
parent430123f55ff34219f53bb4c996ac84651114c2bb (diff)
downloadaports-e2f4c93e6ee2aa7f380b79ec1799a6e87ffb62f5.tar.bz2
aports-e2f4c93e6ee2aa7f380b79ec1799a6e87ffb62f5.tar.xz
testing/translate-shell: new aport
https://www.soimort.org/translate-shell Command-line online translator
Diffstat (limited to 'testing/translate-shell')
-rw-r--r--testing/translate-shell/APKBUILD29
-rw-r--r--testing/translate-shell/drop-rlwrap-emacs-tests.patch24
2 files changed, 53 insertions, 0 deletions
diff --git a/testing/translate-shell/APKBUILD b/testing/translate-shell/APKBUILD
new file mode 100644
index 0000000000..7664a5e484
--- /dev/null
+++ b/testing/translate-shell/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=translate-shell
+pkgver=0.9.6.11
+pkgrel=0
+pkgdesc="Command-line online translator"
+url="https://www.soimort.org/translate-shell"
+arch="noarch"
+license="Unlicense"
+depends="gawk bash"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/soimort/translate-shell/archive/v$pkgver.tar.gz
+ drop-rlwrap-emacs-tests.patch
+ "
+
+build() {
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+}
+
+sha512sums="d4d376b3750e43e3de5b95790fea7fc91e94140526ac15ee9f7818554f95d410772c8f8887433b6fd4547f569b3d6f510c1bc1497d8237223c344dbb8f0ae87f translate-shell-0.9.6.11.tar.gz
+9eae49f31e709c4802bd8952abddf98445129b793394289afddef96bf790e84065abe6b808ce19fda933a141dfc92522d38777c8310243185db7880954aff85c drop-rlwrap-emacs-tests.patch"
diff --git a/testing/translate-shell/drop-rlwrap-emacs-tests.patch b/testing/translate-shell/drop-rlwrap-emacs-tests.patch
new file mode 100644
index 0000000000..ee5a7a30c6
--- /dev/null
+++ b/testing/translate-shell/drop-rlwrap-emacs-tests.patch
@@ -0,0 +1,24 @@
+diff --git a/test/TestUtils.awk b/test/TestUtils.awk
+index 2b7dc95..aaf907d 100644
+--- a/test/TestUtils.awk
++++ b/test/TestUtils.awk
+@@ -9,18 +9,6 @@ BEGIN {
+ assertTrue(GawkVersion ~ "^(4|5).")
+ }
+
+- T("Rlwrap", 1)
+- {
+- initRlwrap()
+- assertEqual(Rlwrap, "rlwrap")
+- }
+-
+- T("Emacs", 1)
+- {
+- initEmacs()
+- assertEqual(Emacs, "emacs")
+- }
+-
+ T("newerVersion()", 5)
+ {
+ assertTrue(newerVersion("0.9", "0.8"))
+