aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ttf-hack
diff options
context:
space:
mode:
authorIvan Tham <pickfire@riseup.net>2017-09-24 17:27:12 +0800
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-10 11:06:14 +0000
commitb904aa2b887d9fff286c367f08e41d7facc4052d (patch)
treed4e779103a6f0ce025c781f88e52a8741910a768 /testing/ttf-hack
parent0723227f894ae54e01e7a4d58a8ba3659531cc54 (diff)
downloadaports-b904aa2b887d9fff286c367f08e41d7facc4052d.tar.bz2
aports-b904aa2b887d9fff286c367f08e41d7facc4052d.tar.xz
testing/ttf-hack: new aport
http://sourcefoundry.org/hack/ A typeface designed for source code
Diffstat (limited to 'testing/ttf-hack')
-rw-r--r--testing/ttf-hack/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/ttf-hack/APKBUILD b/testing/ttf-hack/APKBUILD
new file mode 100644
index 0000000000..11235d2431
--- /dev/null
+++ b/testing/ttf-hack/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Ivan Tham <pickfire@riseup.net>
+# Maintainer: Ivan Tham <pickfire@riseup.net>
+pkgname=ttf-hack
+pkgver=3.003
+pkgrel=0
+pkgdesc="A typeface designed for source code"
+url="http://sourcefoundry.org/hack/"
+arch="noarch"
+options="!check"
+license="MIT"
+depends="fontconfig mkfontscale"
+source="https://github.com/source-foundry/Hack/releases/download/v$pkgver/Hack-v$pkgver-ttf.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+unpack() {
+ mkdir -p "$builddir"
+ busybox tar -Jxvf "$srcdir"/Hack-v$pkgver-ttf.tar.xz \
+ -C "$builddir" > /dev/null
+}
+
+package() {
+ cd $builddir
+ mkdir -p "$pkgdir"/usr/share/fonts/$pkgname
+ install -m644 *.ttf "$pkgdir"/usr/share/fonts/$pkgname
+}
+
+sha512sums="d6480957ef77b0e117a564b76e7b8b041a28cfc89441d394a27e2a1b230cae7a67c0b9f3cbe6aab48c5d2cc832b0ea653017a3b925db1d0cc2885e02eab9a81d Hack-v3.003-ttf.tar.xz"