aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ttf-roboto
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-07 18:51:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-11-08 02:36:11 -0300
commit911b96994f28062eae694c919cf15fb35099e4d7 (patch)
tree73731d3f41d04c3edce2d9e8f79139da157e5d7d /testing/ttf-roboto
parentd3d0a45bc5f6520282478eee8e8178e3ff8a85ce (diff)
downloadaports-911b96994f28062eae694c919cf15fb35099e4d7.tar.bz2
aports-911b96994f28062eae694c919cf15fb35099e4d7.tar.xz
testing/ttf-roboto: new aport
https://github.com/google/roboto The Roboto family of fonts
Diffstat (limited to 'testing/ttf-roboto')
-rw-r--r--testing/ttf-roboto/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/ttf-roboto/APKBUILD b/testing/ttf-roboto/APKBUILD
new file mode 100644
index 0000000000..e5a3a64332
--- /dev/null
+++ b/testing/ttf-roboto/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=ttf-roboto
+pkgver=2.138
+pkgrel=0
+pkgdesc="The Roboto family of fonts"
+options="!check" # No testsuite
+url="https://github.com/google/roboto"
+arch="noarch"
+depends="fontconfig"
+license="Apache-2.0"
+source="$pkgname-$pkgver.tar.gz::https://github.com/google/roboto/archive/v$pkgver.tar.gz"
+builddir="$srcdir/roboto-$pkgver"
+
+package() {
+ install -d "$pkgdir"/usr/share/fonts/TTF
+ find . -type f -name '*.ttf' | while read -r font; do
+ install -Dm644 "$font" -t "$pkgdir"/usr/share/fonts/TTF
+ done
+}
+
+sha512sums="f4bec4bd76745a625a946c98d52222d49e93e5480d9f25913ec2456dbd9252a07e4864eba98a8bb6ca724994fd82e7c8d91384ea315d028703e9a0e0b1df1446 ttf-roboto-2.138.tar.gz"