aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tuptime
diff options
context:
space:
mode:
authorRicardo F <rfraile@rfraile.eu>2019-03-08 18:27:14 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-08 20:58:56 +0000
commit89ccdebc8384a7acf42b91473b4d83f45b08ecb7 (patch)
tree80e501813927c61b0fff88e7eaafbad21a66c384 /testing/tuptime
parent7571cd56bd0c8766c334bf201140a80deafe9146 (diff)
downloadaports-89ccdebc8384a7acf42b91473b4d83f45b08ecb7.tar.bz2
aports-89ccdebc8384a7acf42b91473b4d83f45b08ecb7.tar.xz
testing/tuptime: fix .pre-install execution
Diffstat (limited to 'testing/tuptime')
-rw-r--r--testing/tuptime/APKBUILD9
-rw-r--r--testing/tuptime/tuptime-openrc.pre-install (renamed from testing/tuptime/tuptime.pre-install)2
-rw-r--r--testing/tuptime/tuptime.post-install6
3 files changed, 6 insertions, 11 deletions
diff --git a/testing/tuptime/APKBUILD b/testing/tuptime/APKBUILD
index c55a7c2df8..4425dbc308 100644
--- a/testing/tuptime/APKBUILD
+++ b/testing/tuptime/APKBUILD
@@ -2,18 +2,18 @@
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=tuptime
pkgver=3.4.2
-pkgrel=2
+pkgrel=3
pkgdesc="Report the historical and statistical real time of the system"
url="https://github.com/rfrail3/tuptime"
arch="noarch"
license="GPL-2.0-only"
depends="python3"
+install="$pkgname-openrc.pre-install"
subpackages="$pkgname-doc $pkgname-openrc"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/rfrail3/$pkgname/archive/$pkgver.tar.gz
$pkgname.cron
- $pkgname.pre-install
- $pkgname.post-install"
+ $pkgname-openrc.pre-install"
builddir="$srcdir/$pkgname-$pkgver"
@@ -27,5 +27,4 @@ package() {
sha512sums="c90e11a7d5dbee83325d4793316ccfa46b3f5ebe0914b6100757412b92446367070dca25b7fed3f4b7d8f08565dfc7c4e4e4027206b9dcfbb5b8942d36d94938 tuptime-3.4.2.tar.gz
d3a3f7820c2fbbc3a13412740934b5b62af462c35a9354a2f0d16b76500a406ea86dbec2cf368a24191df6c0221a8e6efff0dbf3e635af854cbe84eb6fe5630e tuptime.cron
-3ae52b4bfcac851dd9a649ddcc66358bc345bf83cee063223c33a19658a47106af471bdc5f1c5cb042a551432574ab1c2fb4e61dec6a15b2b06785764f66bcdf tuptime.pre-install
-6e6b8cef664cde72d6d157889ef377dcd8de91c8a4dcb5ddb909aa5b23f7e50fd7efe744ce66a00d53034d8d93045b2ccf0f96dc334e19d4ca5d8c312e673c87 tuptime.post-install"
+efbbd7fb8e00b68fd82bb30e89a0f419a4bdb845b2d76521bd83080bfaee2ef400a80569a383b98ade3f611608f367ca2c8ac105f6a8f3787016a8f160590bb5 tuptime-openrc.pre-install"
diff --git a/testing/tuptime/tuptime.pre-install b/testing/tuptime/tuptime-openrc.pre-install
index 19600617dc..68335091b8 100644
--- a/testing/tuptime/tuptime.pre-install
+++ b/testing/tuptime/tuptime-openrc.pre-install
@@ -3,4 +3,6 @@
addgroup -S tuptime 2>/dev/null
adduser -S -D -h /var/lib/tuptime -s /bin/false -G tuptime -g tuptime tuptime 2>/dev/null
+echo 'Tuptime needs to be executed now and at boot time, do it with: "rc-update add tuptime default && rc-service tuptime start"' 1>&2
+
exit 0
diff --git a/testing/tuptime/tuptime.post-install b/testing/tuptime/tuptime.post-install
deleted file mode 100644
index 388ded4932..0000000000
--- a/testing/tuptime/tuptime.post-install
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-rc-update add tuptime
-rc-service tuptime start
-
-exit 0