aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tuptime
diff options
context:
space:
mode:
authorRicardo F <rfraile@rfraile.eu>2019-03-09 15:16:31 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-14 22:07:19 +0000
commit3fd511e1d0088feeb88c539134d3b309d1a04442 (patch)
treec707eda965dbb2697047891cdd03d7afcffac846 /testing/tuptime
parent06e35a04566bb68ee304c893ee5cef495928460a (diff)
downloadaports-3fd511e1d0088feeb88c539134d3b309d1a04442.tar.bz2
aports-3fd511e1d0088feeb88c539134d3b309d1a04442.tar.xz
testing/tuptime: create user before main package installation
Diffstat (limited to 'testing/tuptime')
-rw-r--r--testing/tuptime/APKBUILD4
-rw-r--r--testing/tuptime/tuptime-openrc.post-install (renamed from testing/tuptime/tuptime-openrc.pre-install)3
-rw-r--r--testing/tuptime/tuptime.pre-install6
3 files changed, 8 insertions, 5 deletions
diff --git a/testing/tuptime/APKBUILD b/testing/tuptime/APKBUILD
index 5759e14497..f0bef6d739 100644
--- a/testing/tuptime/APKBUILD
+++ b/testing/tuptime/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=tuptime
pkgver=3.4.2
-pkgrel=3
+pkgrel=4
pkgdesc="Report the historical and statistical real time of the system"
url="https://github.com/rfrail3/tuptime"
arch="noarch"
license="GPL-2.0-only"
depends="python3"
-install="$pkgname-openrc.pre-install"
+install="$pkgname.pre-install $pkgname-openrc.post-install"
subpackages="$pkgname-doc $pkgname-openrc"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/rfrail3/$pkgname/archive/$pkgver.tar.gz
diff --git a/testing/tuptime/tuptime-openrc.pre-install b/testing/tuptime/tuptime-openrc.post-install
index 68335091b8..9ea355f663 100644
--- a/testing/tuptime/tuptime-openrc.pre-install
+++ b/testing/tuptime/tuptime-openrc.post-install
@@ -1,8 +1,5 @@
#!/bin/sh
-addgroup -S tuptime 2>/dev/null
-adduser -S -D -h /var/lib/tuptime -s /bin/false -G tuptime -g tuptime tuptime 2>/dev/null
-
echo 'Tuptime needs to be executed now and at boot time, do it with: "rc-update add tuptime default && rc-service tuptime start"' 1>&2
exit 0
diff --git a/testing/tuptime/tuptime.pre-install b/testing/tuptime/tuptime.pre-install
new file mode 100644
index 0000000000..19600617dc
--- /dev/null
+++ b/testing/tuptime/tuptime.pre-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+addgroup -S tuptime 2>/dev/null
+adduser -S -D -h /var/lib/tuptime -s /bin/false -G tuptime -g tuptime tuptime 2>/dev/null
+
+exit 0