aboutsummaryrefslogtreecommitdiffstats
path: root/testing/uacme
diff options
context:
space:
mode:
authorEivind Uggedal <eu@eju.no>2019-05-16 06:44:09 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-17 21:41:42 +0000
commitf533e2ab49b71c30b1cd10907268076b489e43bc (patch)
tree4df7bc1a744931e32c92d3bfc72c6fdc437e1ac0 /testing/uacme
parent435e068e0e00f56b3b0dc03e91851e0615ed8272 (diff)
downloadaports-f533e2ab49b71c30b1cd10907268076b489e43bc.tar.bz2
aports-f533e2ab49b71c30b1cd10907268076b489e43bc.tar.xz
testing/uacme: new aport
Closes GH-7896
Diffstat (limited to 'testing/uacme')
-rw-r--r--testing/uacme/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/uacme/APKBUILD b/testing/uacme/APKBUILD
new file mode 100644
index 0000000000..1906112ba4
--- /dev/null
+++ b/testing/uacme/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Eivind Uggedal <eu@eju.no>
+# Maintainer: Eivind Uggedal <eu@eju.no>
+pkgname=uacme
+pkgver=1.0.11
+pkgrel=0
+pkgdesc="Lightweight client for the RFC8555 ACMEv2 protocol"
+url="https://github.com/ndilieto/uacme"
+arch="all"
+license="GPL-3.0-or-later ISC MIT"
+makedepends="openssl-dev curl-dev asciidoc"
+subpackages="$pkgname-doc"
+options="!check"
+source="uacme-$pkgver.tar.gz::https://github.com/ndilieto/uacme/archive/v$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-maintainer-mode \
+ --with-openssl
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="895ada9a4beabf1d767a2cc8ead264c300e776c0690e0e8e49fb779fb03063306e89910d804ab025888e0ff9ccb94a500aa3c040f2905e1c463f368a66d05de6 uacme-1.0.11.tar.gz"