aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ucspi-ssl/0001-Add-missing-make-targets.patch
diff options
context:
space:
mode:
authorJesse Young <jlyo@jlyo.org>2015-07-26 21:08:06 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-07-29 06:05:05 +0000
commit4185895677aefef9ebd558a698fbae4a5c40537c (patch)
treecb945751332f15063beb496ba83e386958d20814 /testing/ucspi-ssl/0001-Add-missing-make-targets.patch
parent42d4b3a76cb7c28eb0614ab164d4dea2143b6505 (diff)
downloadaports-4185895677aefef9ebd558a698fbae4a5c40537c.tar.bz2
aports-4185895677aefef9ebd558a698fbae4a5c40537c.tar.xz
testing/ucspi-ssl: New aport
Diffstat (limited to 'testing/ucspi-ssl/0001-Add-missing-make-targets.patch')
-rw-r--r--testing/ucspi-ssl/0001-Add-missing-make-targets.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/ucspi-ssl/0001-Add-missing-make-targets.patch b/testing/ucspi-ssl/0001-Add-missing-make-targets.patch
new file mode 100644
index 0000000000..8c36dab94c
--- /dev/null
+++ b/testing/ucspi-ssl/0001-Add-missing-make-targets.patch
@@ -0,0 +1,41 @@
+From a4f0a53cab0caa35607a85378bc687468eaec466 Mon Sep 17 00:00:00 2001
+From: Jesse Young <jlyo@jlyo.org>
+Date: Fri, 24 Jul 2015 16:11:59 +0000
+Subject: [PATCH] Add missing make targets
+
+---
+ host/superscript.com/net/ucspi-ssl-0.95b/src/Makefile | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff --git a/host/superscript.com/net/ucspi-ssl-0.95b/src/Makefile b/host/superscript.com/net/ucspi-ssl-0.95b/src/Makefile
+index 452586c..089b1ff 100755
+--- a/host/superscript.com/net/ucspi-ssl-0.95b/src/Makefile
++++ b/host/superscript.com/net/ucspi-ssl-0.95b/src/Makefile
+@@ -454,6 +454,12 @@ compile remoteinfo.c buffer.h error.h fmt.h gen_alloc.h iopause.h \
+ remoteinfo.h socket.h stralloc.h tai.h taia.h timeoutconn.h uint16.h uint64.h
+ ./compile remoteinfo.c
+
++remoteinfo6.o: \
++compile remoteinfo6.c buffer.h error.h fmt.h gen_alloc.h iopause.h \
++remoteinfo.h socket.h stralloc.h tai.h taia.h timeoutconn.h uint16.h uint32.h \
++uint64.h
++ ./compile remoteinfo6.c
++
+ rules.o: \
+ compile rules.c alloc.h cdb.h gen_alloc.h ip4_bit.h open.h rules.h \
+ str.h stralloc.h uint32.h
+@@ -881,6 +887,11 @@ compile timeoutconn.c error.h iopause.h ndelay.h socket.h tai.h \
+ taia.h timeoutconn.h uint16.h uint64.h
+ ./compile timeoutconn.c
+
++timeoutconn6.o: \
++compile timeoutconn6.c error.h iopause.h ndelay.h socket.h \
++tai.h taia.h timeoutconn.h uint16.h uint32.h uint64.h
++ ./compile timeoutconn6.c
++
+ ucspissl.a: \
+ makelib ssl_ca.o ssl_cca.o ssl_certkey.o ssl_chainfile.o ssl_ciphers.o \
+ ssl_context.o ssl_env.o ssl_error.o ssl_io.o ssl_new.o ssl_params.o ssl_timeoutaccept.o \
+--
+2.4.6
+