aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ucspi-tcp
diff options
context:
space:
mode:
authorJohannes Findeisen <you@hanez.org>2016-12-05 23:55:56 +0100
committerTimo Teräs <timo.teras@iki.fi>2017-02-08 07:39:15 +0000
commit32de6d31c2975d3bafb90dfaeab91da13b0011e1 (patch)
treee714d9298bf862c0fb9ec36b003c4e5a98a0aa90 /testing/ucspi-tcp
parent3096d153c636ee75f5bb3e32cd0e4cf4adfc69c4 (diff)
downloadaports-32de6d31c2975d3bafb90dfaeab91da13b0011e1.tar.bz2
aports-32de6d31c2975d3bafb90dfaeab91da13b0011e1.tar.xz
testing/ucspi-tcp: moved from unmaintaned
made APKBUILD more consistent
Diffstat (limited to 'testing/ucspi-tcp')
-rw-r--r--testing/ucspi-tcp/APKBUILD46
-rw-r--r--testing/ucspi-tcp/ucspi-tcp-0.88.a_record.patch64
-rw-r--r--testing/ucspi-tcp/ucspi-tcp-0.88.errno.patch12
3 files changed, 122 insertions, 0 deletions
diff --git a/testing/ucspi-tcp/APKBUILD b/testing/ucspi-tcp/APKBUILD
new file mode 100644
index 0000000000..ce8a751831
--- /dev/null
+++ b/testing/ucspi-tcp/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Johannes Findeisen <you@hanez.org>
+
+pkgname=ucspi-tcp
+pkgver=0.88
+pkgrel=0
+pkgdesc="Easy-to-use command-line tools for building TCP client-server applications."
+url="http://cr.yp.to/ucspi-tcp.html"
+arch="all"
+license="public-domain"
+depends=""
+makedepends=""
+source="http://cr.yp.to/$pkgname/$pkgname-$pkgver.tar.gz
+ ucspi-tcp-0.88.a_record.patch
+ ucspi-tcp-0.88.errno.patch
+ "
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ echo "${CC:-"gcc"} ${CFLAGS}" > conf-cc
+ echo "${CC:-"gcc"} ${LDFLAGS}" > conf-ld
+ echo "/usr" > conf-home
+ make || return 1
+}
+
+package() {
+ local f
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+ for f in tcpserver tcprules tcprulescheck argv0 recordio tcpclient \
+ *\@ tcpcat mconnect mconnect-io addcr delcr fixcrio rblsmtpd; do
+ cp $f "$pkgdir"/usr/bin/$f
+ done
+}
+
+md5sums="39b619147db54687c4a583a7a94c9163 ucspi-tcp-0.88.tar.gz
+554ec0eb60f619667efde3fb5325310d ucspi-tcp-0.88.a_record.patch
+759a11fafff188d9580be6498a028095 ucspi-tcp-0.88.errno.patch"
+sha256sums="4a0615cab74886f5b4f7e8fd32933a07b955536a3476d74ea087a3ea66a23e9c ucspi-tcp-0.88.tar.gz
+5101354eb86d8e11edefd7b83df4e9c274a55b845f4cb2ce36dda912aced56f4 ucspi-tcp-0.88.a_record.patch
+3a4c0d8770c5716f749450a12b678b2282a06e43360478ce9c1d25bd3890e816 ucspi-tcp-0.88.errno.patch"
+sha512sums="44efbd477dacf31d39fc970e2d2f74526dc815b905742f6127f0d5c80928ecc7e743089eaab0492386a58d5b97905113fbe8bbc7214ae179b7be27966b7566c7 ucspi-tcp-0.88.tar.gz
+643514c57570fc0b4e817b07e6d26e831cec5b4657c3d1b9948bd90267fe370a340b911897d575eb94192e24ba71a03ac68ceb2774ef7c0e7ff819c5b4285bc3 ucspi-tcp-0.88.a_record.patch
+86b58807e5d2dcd4ab15a4c0f62baaa0988aa4c6b49b522fa1721da5dcab32b1ceb9bde6c07b2a7340471ed5932af5a9c160e345805626b16fd9b1bad55be0eb ucspi-tcp-0.88.errno.patch"
diff --git a/testing/ucspi-tcp/ucspi-tcp-0.88.a_record.patch b/testing/ucspi-tcp/ucspi-tcp-0.88.a_record.patch
new file mode 100644
index 0000000000..903125eaae
--- /dev/null
+++ b/testing/ucspi-tcp/ucspi-tcp-0.88.a_record.patch
@@ -0,0 +1,64 @@
+diff -ruN --exclude conf-* ucspi-tcp-0.88/rblsmtpd.c ucspi-tcp-0.88.fix/rblsmtpd.c
+--- ucspi-tcp-0.88/rblsmtpd.c Sat Mar 18 10:18:42 2000
++++ ucspi-tcp-0.88.fix/rblsmtpd.c Wed Aug 9 16:42:33 2000
+@@ -60,16 +60,54 @@
+
+ void rbl(char *base)
+ {
++ int i;
++ char *altreply = 0;
+ if (decision) return;
+ if (!stralloc_copy(&tmp,&ip_reverse)) nomem();
++ i = str_chr(base, ':');
++ if (base[i]) {
++ base[i] = 0;
++ altreply = base+i+1;
++ }
+ if (!stralloc_cats(&tmp,base)) nomem();
+- if (dns_txt(&text,&tmp) == -1) {
+- flagmustnotbounce = 1;
+- if (flagfailclosed) {
+- if (!stralloc_copys(&text,"temporary RBL lookup error")) nomem();
+- decision = 2;
++ if (altreply) {
++ if (dns_ip4(&text,&tmp) == -1) {
++ flagmustnotbounce = 1;
++ if (flagfailclosed) {
++ if (!stralloc_copys(&text,"temporary RBL lookup error")) nomem();
++ decision = 2;
++ }
++ return;
++ }
++ if (text.len) {
++ if(!stralloc_copys(&text, "")) nomem();
++ while(*altreply) {
++ char *x;
++ i = str_chr(altreply, '%');
++ if(!stralloc_catb(&text, altreply, i)) nomem();
++ if(altreply[i] &&
++ altreply[i+1]=='I' &&
++ altreply[i+2]=='P' &&
++ altreply[i+3]=='%') {
++ if(!stralloc_catb(&text, ip_env, str_len(ip_env))) nomem();
++ altreply+=i+4;
++ } else if(altreply[i]) {
++ if(!stralloc_cats(&text, "%")) nomem();
++ altreply+=i+1;
++ } else {
++ altreply+=i;
++ }
++ }
++ }
++ } else {
++ if (dns_txt(&text,&tmp) == -1) {
++ flagmustnotbounce = 1;
++ if (flagfailclosed) {
++ if (!stralloc_copys(&text,"temporary RBL lookup error")) nomem();
++ decision = 2;
++ }
++ return;
+ }
+- return;
+ }
+ if (text.len)
+ if (flagrblbounce)
diff --git a/testing/ucspi-tcp/ucspi-tcp-0.88.errno.patch b/testing/ucspi-tcp/ucspi-tcp-0.88.errno.patch
new file mode 100644
index 0000000000..7654c783a6
--- /dev/null
+++ b/testing/ucspi-tcp/ucspi-tcp-0.88.errno.patch
@@ -0,0 +1,12 @@
+diff -u ucspi-tcp-0.88.old/error.h ucspi-tcp-0.88/error.h
+--- ucspi-tcp-0.88.old/error.h 2000-03-18 09:18:20.000000000 -0600
++++ ucspi-tcp-0.88/error.h 2003-01-08 13:39:12.000000000 -0600
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;