aboutsummaryrefslogtreecommitdiffstats
path: root/testing/udevil/APKBUILD
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2015-05-05 00:26:28 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-05-05 06:54:39 +0000
commitf78426d7796bfa1982c67e4a25826b38d1761740 (patch)
tree866a955f3e3971a15325807045c47ec71bb967d9 /testing/udevil/APKBUILD
parent0eff8a29f717b1d635f95203156bcb5d0bfd5bc0 (diff)
downloadaports-f78426d7796bfa1982c67e4a25826b38d1761740.tar.bz2
aports-f78426d7796bfa1982c67e4a25826b38d1761740.tar.xz
testing/udevil: new aport
the build server will need the plugdev group for chown to succeed udevil is an alternative to udisks: https://ignorantguru.github.io/udevil/ Mount / unmount removable devices without being root (also mounts ISO / nfs://, smb://, ftp://, ssh:// WebDAV URLs, and tmpfs/ramfs. SUID bit removed & tested as in & out of the plugdev group.
Diffstat (limited to 'testing/udevil/APKBUILD')
-rw-r--r--testing/udevil/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/udevil/APKBUILD b/testing/udevil/APKBUILD
new file mode 100644
index 0000000000..e5f793142f
--- /dev/null
+++ b/testing/udevil/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=udevil
+pkgver=0.4.4
+pkgrel=0
+pkgdesc="Mount / unmount removable devices without a password (udisks alternative)"
+url="http://ignorantguru.github.io/udevil"
+arch="all"
+license="GPL3+"
+makedepends="$depends_dev glib-dev udev-dev intltool"
+install="$pkgname.post-install $pkgname.pre-install"
+subpackages="$pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://github.com/IgnorantGuru/$pkgname/archive/$pkgver.tar.gz"
+pkggroups="plugdev"
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --disable-systemd || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+ chown root:plugdev "$pkgdir"/usr/bin/udevil || return 1
+ chmod u+s,go-s,o-x "$pkgdir"/usr/bin/udevil # remove SUID bit
+}
+
+md5sums="281aa065d92c679cb41728069e72b272 udevil-0.4.4.tar.gz"
+sha256sums="ad2fd8375bd62622718a04235e9772119459089938dbb78e657955e595822b7c udevil-0.4.4.tar.gz"
+sha512sums="adce4916e06d1cc4965521abbcbc2901e53930691167f431cb18e28d3ef8bde740e95a6a5f40dfc58dfd7b4b661b4475d3dd2b6174a5d7a55ae7c65629b82327 udevil-0.4.4.tar.gz"