aboutsummaryrefslogtreecommitdiffstats
path: root/testing/umurmur
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2013-12-30 08:12:44 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2013-12-30 08:12:44 +0000
commitcbb05fc09fcab2d85bfbef57edfad0dafa7ae857 (patch)
tree5d179dc54381e89c302d9db5a57bc6aeb2e0c05c /testing/umurmur
parente4ea0f49f2b658b01f2f9798cad29a395f5f8565 (diff)
downloadaports-cbb05fc09fcab2d85bfbef57edfad0dafa7ae857.tar.bz2
aports-cbb05fc09fcab2d85bfbef57edfad0dafa7ae857.tar.xz
testing/umurmur: add missing config files
Diffstat (limited to 'testing/umurmur')
-rw-r--r--testing/umurmur/APKBUILD2
-rw-r--r--testing/umurmur/umurmur.conf58
-rw-r--r--testing/umurmur/umurmur.confd3
-rw-r--r--testing/umurmur/umurmur.initd19
4 files changed, 81 insertions, 1 deletions
diff --git a/testing/umurmur/APKBUILD b/testing/umurmur/APKBUILD
index cb2b4f0602..25a0f5fee3 100644
--- a/testing/umurmur/APKBUILD
+++ b/testing/umurmur/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leonardo Arena <rnalrd@gmail.com>
pkgname=umurmur
pkgver=0.2.13
-pkgrel=0
+pkgrel=1
pkgdesc="Minimalistic Mumble server primarily targeted to run on routers"
url="https://code.google.com/p/umurmur/"
arch="all"
diff --git a/testing/umurmur/umurmur.conf b/testing/umurmur/umurmur.conf
new file mode 100644
index 0000000000..cebcca28a5
--- /dev/null
+++ b/testing/umurmur/umurmur.conf
@@ -0,0 +1,58 @@
+# This configuration is based on the official example configuration. More information can be found
+# at http://code.google.com/p/umurmur/wiki/Configuring02x
+
+max_bandwidth = 48000;
+welcometext = "Welcome to uMurmur!";
+certificate = "/etc/umurmur/cert.crt";
+private_key = "/etc/umurmur/key.key";
+password = "";
+max_users = 10;
+
+# Specify port and/or address to bind to. Typically not needed.
+# Default is '*' for address and 64738 for port.
+# Can also be specified on the command line, which takes precedence if
+# both are specified.
+# bindport = 64738;
+# bindaddr = "192.168.1.1";
+
+# Specify this for privilege dropping. If username is specified but not
+# the groupname, the user's login group is used.
+username = "murmur";
+groupname = "murmur";
+
+# Root channel must always be defined first.
+# If a channel has a parent, the parent must be defined before the child channel(s).
+channels = ( {
+ name = "Root";
+ parent = "";
+ description = "The Root of all channels";
+ noenter = true;
+ },
+ {
+ name = "Lobby";
+ parent = "Root";
+ description = "Lobby channel";
+ },
+ {
+ name = "Red team";
+ parent = "Lobby";
+ description = "The Red team channel";
+ },
+ {
+ name = "Blue team";
+ parent = "Lobby";
+ description = "The Blue team channel";
+ }
+);
+# Channel links configuration.
+channel_links = ( {
+ source = "Lobby";
+ destination = "Red team";
+ },
+ {
+ source = "Lobby";
+ destination = "Blue team";
+ }
+);
+
+default_channel = "Lobby";
diff --git a/testing/umurmur/umurmur.confd b/testing/umurmur/umurmur.confd
new file mode 100644
index 0000000000..d83461ce72
--- /dev/null
+++ b/testing/umurmur/umurmur.confd
@@ -0,0 +1,3 @@
+# Additional flags to be passed to umurmurd
+UMURMURD_OPTS="-r"
+
diff --git a/testing/umurmur/umurmur.initd b/testing/umurmur/umurmur.initd
new file mode 100644
index 0000000000..151f49e4c8
--- /dev/null
+++ b/testing/umurmur/umurmur.initd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/umurmur/files/umurmurd.initd,v 1.1 2013/06/20 09:10:29 polynomial-c Exp $
+
+description="umurmurd - A minimalistic mumble server"
+pidfile="/run/umurmurd/umurmurd.pid"
+command="/usr/bin/umurmurd"
+command_args="-c /etc/umurmur/umurmur.conf -p ${pidfile} ${UMURMURD_OPTS}"
+start_stop_daemon_args="-p ${pidfile} -w 100"
+
+depend() {
+ need net
+ use logger
+}
+
+start_pre() {
+ checkpath -d -o murmur ${pidfile%/*}
+}