aboutsummaryrefslogtreecommitdiffstats
path: root/testing/unclutter-xfixes
diff options
context:
space:
mode:
authorMichael Pirogov <vbnet.ru@gmail.com>2017-04-17 13:42:04 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 10:51:40 +0000
commit05b47c058bb6fc5ac53dd786c18b16642b3aca05 (patch)
tree79bf927cce670950b238c722fcd0ca0023906c87 /testing/unclutter-xfixes
parent6ef185863d02432829a798fa28d887631833e187 (diff)
downloadaports-05b47c058bb6fc5ac53dd786c18b16642b3aca05.tar.bz2
aports-05b47c058bb6fc5ac53dd786c18b16642b3aca05.tar.xz
testing/unclutter-xfixes: new aport
Diffstat (limited to 'testing/unclutter-xfixes')
-rw-r--r--testing/unclutter-xfixes/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/unclutter-xfixes/APKBUILD b/testing/unclutter-xfixes/APKBUILD
new file mode 100644
index 0000000000..61c291918f
--- /dev/null
+++ b/testing/unclutter-xfixes/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Michael Pirogov <vbnet.ru@gmail.com>
+# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
+pkgname=unclutter-xfixes
+pkgver=1.2
+pkgrel=0
+url="https://github.com/Airblader/${pkgname}"
+arch="all"
+license="MIT"
+pkgdesc="Hides mouse pointer while not in use"
+makedepends="libxfixes-dev libev-dev libxi-dev asciidoc"
+subpackages="${pkgname}-doc"
+_myver="${pkgname}-${pkgver}"
+source="${_myver}.tar.gz::https://github.com/Airblader/${pkgname}/archive/v${pkgver}.tar.gz"
+builddir="${srcdir}/${pkgname}-${pkgver}"
+
+build() {
+ cd "${builddir}"
+ make
+}
+
+check() {
+ cd "${builddir}"
+ ./unclutter -v
+}
+
+package() {
+ cd "${builddir}"
+ install -D -m755 "${builddir}/unclutter" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m444 "${builddir}/man/${pkgname}.1" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+}
+
+sha512sums="59df9e0dcf917f83b11ce85ba3d7445234ed6e63fc060d5158a9278821fc01c7b0f1f1178ad41e6307d7e0e8dd0ae850dc8bb7a613949deb10496535058fe5e9 unclutter-xfixes-1.2.tar.gz"