aboutsummaryrefslogtreecommitdiffstats
path: root/testing/unetbootin
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /testing/unetbootin
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'testing/unetbootin')
-rw-r--r--testing/unetbootin/APKBUILD53
-rw-r--r--testing/unetbootin/allow-ntfs.patch20
2 files changed, 0 insertions, 73 deletions
diff --git a/testing/unetbootin/APKBUILD b/testing/unetbootin/APKBUILD
deleted file mode 100644
index 5d1f4928b0..0000000000
--- a/testing/unetbootin/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
-pkgname=unetbootin
-pkgver=608
-pkgrel=0
-pkgdesc="tool for building USB install media"
-url="http://unetbootin.sourceforge.net/"
-arch="x86 x86_64"
-license="GPL"
-depends="syslinux p7zip"
-depends_dev=""
-makedepends="qt-dev $depends_dev"
-install=""
-subpackages="$pkgname-lang"
-source="http://softlayer-ams.dl.sourceforge.net/project/unetbootin/UNetbootin/$pkgver/unetbootin-source-$pkgver.tar.gz
- allow-ntfs.patch"
-
-_builddir="$srcdir"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- lupdate unetbootin.pro
- lrelease unetbootin.pro
- qmake "DEFINES += NOSTATIC" "RESOURCES -= unetbootin.qrc"
- make
-}
-
-package() {
- cd "$_builddir"
- install -D -m755 "$srcdir"/unetbootin "$pkgdir"/usr/bin/unetbootin
-}
-
-lang() {
- arch="noarch"
- cd "$_builddir"
- install -D -m644 "$srcdir"/unetbootin_*.qm "$subpkgdir"/usr/share/unetbootin
-}
-
-md5sums="8c0f9f565a3dc0b093a0a9afd58fa9a7 unetbootin-source-608.tar.gz
-a7d9ea8ed464600bc3d5b018ad6024f6 allow-ntfs.patch"
-sha256sums="ce99c5f60b1f66da0ceb41859ce9198d96b3061b949b167fc952d3951b632080 unetbootin-source-608.tar.gz
-7e1153938a868d390bb0b54ade22299696e2d5c7a9d1347ecbe9d33d097e0b7b allow-ntfs.patch"
-sha512sums="d164537c96845eb90ac5aae1fa0c553c9392d778696e4818760cb11f78341e6a3ea6a05f702678583c5d680dc8fb1348cdc2b2dfba9bebfdf793779c23611d16 unetbootin-source-608.tar.gz
-7b5d415a226356697d7e4ce18d8e9cc4e7c5357ef94fc7a063a320f1f2fa5d03109bd399fafe4565144327643284d3b3ddbf57568cccf34f81e0bd61e151208b allow-ntfs.patch"
diff --git a/testing/unetbootin/allow-ntfs.patch b/testing/unetbootin/allow-ntfs.patch
deleted file mode 100644
index d8e72c1912..0000000000
--- a/testing/unetbootin/allow-ntfs.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- src.orig/unetbootin.cpp
-+++ src/unetbootin.cpp
-@@ -572,7 +572,7 @@
- {
- if (!volidcommand.isEmpty())
- {
-- if (QString(callexternapp(volidcommand, QString("-t %2").arg(usbfileinfoL.at(i).canonicalFilePath()))).contains(QRegExp("(vfat|ext2|ext3|ext4)")))
-+ if (QString(callexternapp(volidcommand, QString("-t %2").arg(usbfileinfoL.at(i).canonicalFilePath()))).contains(QRegExp("(vfat|ntfs|ext2|ext3|ext4)")))
- fulldrivelist.append(usbfileinfoL.at(i).canonicalFilePath());
- }
- else
-@@ -580,7 +580,7 @@
- QString tstrblk = QString(callexternapp(blkidcommand, QString("-s TYPE %2").arg(usbfileinfoL.at(i).canonicalFilePath())));
- if (tstrblk.contains('='))
- {
-- if (tstrblk.section('=', -1, -1).remove('"').contains(QRegExp("(vfat|ext2|ext3|ext4)")))
-+ if (tstrblk.section('=', -1, -1).remove('"').contains(QRegExp("(vfat|ntfs|ext2|ext3|ext4)")))
- fulldrivelist.append(usbfileinfoL.at(i).canonicalFilePath());
- }
- }