aboutsummaryrefslogtreecommitdiffstats
path: root/testing/upx
diff options
context:
space:
mode:
authorMitch Tishmack <mitch.tishmack@gmail.com>2017-01-29 17:24:29 -0600
committerTimo Teräs <timo.teras@iki.fi>2017-02-21 06:41:19 +0000
commite33dd69b45870cf5bf18389feea4591eb8d45ff2 (patch)
tree8f4ffbb738d42e5d5873e3469b49cf6a867986dd /testing/upx
parent53cbf43b38c812ae66cd36838514fc6324120618 (diff)
downloadaports-e33dd69b45870cf5bf18389feea4591eb8d45ff2.tar.bz2
aports-e33dd69b45870cf5bf18389feea4591eb8d45ff2.tar.xz
testing/upx: new aport
Diffstat (limited to 'testing/upx')
-rw-r--r--testing/upx/0001-rm-broken-whitespace-check.patch16
-rw-r--r--testing/upx/APKBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/testing/upx/0001-rm-broken-whitespace-check.patch b/testing/upx/0001-rm-broken-whitespace-check.patch
new file mode 100644
index 0000000000..b245a4fb29
--- /dev/null
+++ b/testing/upx/0001-rm-broken-whitespace-check.patch
@@ -0,0 +1,16 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -104,13 +104,6 @@
+ endif
+
+ CHECK_WHITESPACE =
+-ifeq ($(shell uname),Linux)
+-CHECK_WHITESPACE = $(top_srcdir)/src/stub/scripts/check_whitespace.sh $(top_srcdir)
+-ifneq ($(wildcard $(top_srcdir)/.git/.),)
+-CHECK_WHITESPACE = $(top_srcdir)/src/stub/scripts/check_whitespace_git.sh $(top_srcdir)
+-endif
+-check-whitespace : ; $(CHECK_WHITESPACE)
+-endif
+ .PHONY: check-whitespace
+
+ mostlyclean clean distclean maintainer-clean:
diff --git a/testing/upx/APKBUILD b/testing/upx/APKBUILD
new file mode 100644
index 0000000000..e4cbbc5908
--- /dev/null
+++ b/testing/upx/APKBUILD
@@ -0,0 +1,32 @@
+#-*-mode: Shell-script; coding: utf-8;-*-
+# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
+pkgname=upx
+pkgver=3.93
+pkgrel=0
+pkgdesc="UPX - the Ultimate Packer for eXecutables"
+url="https://upx.github.io"
+arch="all"
+license="gpl"
+depends="zlib ucl"
+makedepends="$depends zlib-dev bash"
+source="
+ https://github.com/${pkgname}/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}-src.tar.xz
+ 0001-rm-broken-whitespace-check.patch
+"
+builddir="$srcdir/$pkgname-$pkgver-src"
+
+build() {
+ cd "$builddir"
+ make UPX_LZMA_VERSION=0x465 UPX_LZMADIR="${srcdir}" all || return 1
+}
+
+package() {
+ cd "$builddir"
+ install -Dm0755 src/upx.out "${pkgdir}/usr/bin/upx" || return 1
+}
+md5sums="d8da85311492a5f9e3a1fecc979f879b upx-3.93-src.tar.xz
+1025aa041780c577d60c3dc8495c66c9 0001-rm-broken-whitespace-check.patch"
+sha256sums="893f1cf1580c8f0048a4d328474cb81d1a9bf9844410d2fd99f518ca41141007 upx-3.93-src.tar.xz
+427e30ecf5cd689ccbb07ee55422f9d48d4957211777c7091ba9de28e7c1e28b 0001-rm-broken-whitespace-check.patch"
+sha512sums="41c18c11601c78043a9ae22d87e73c173971b19b62207e7bf058e29a452456d802bf89931324afd3a9848018d1ef2007e0915b41cfb8a97a44d3cebb559cefad upx-3.93-src.tar.xz
+a41dd8b8e9e884c78c410a49b4486963f6dd90759ba49eb05123e81b8e4fbe3d23af2ba5c2acf64218b7edeec7df0793b4030d1375c167a183a4d70d21addf50 0001-rm-broken-whitespace-check.patch"