aboutsummaryrefslogtreecommitdiffstats
path: root/testing/util-vserver/chmod.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-07 14:47:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-07 14:49:20 +0000
commit7435e8a2f9d3fa13f078808f04f00d67685395de (patch)
treeb58f261c45ba5dda1ab1628e42efd80bcd6cfc43 /testing/util-vserver/chmod.patch
parent5ad962dfec7ed2b87a90ac3dd79714db73ab506b (diff)
downloadaports-7435e8a2f9d3fa13f078808f04f00d67685395de.tar.bz2
aports-7435e8a2f9d3fa13f078808f04f00d67685395de.tar.xz
testing/util-vserver: build with busybox only
Diffstat (limited to 'testing/util-vserver/chmod.patch')
-rw-r--r--testing/util-vserver/chmod.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/testing/util-vserver/chmod.patch b/testing/util-vserver/chmod.patch
new file mode 100644
index 0000000000..53861e8932
--- /dev/null
+++ b/testing/util-vserver/chmod.patch
@@ -0,0 +1,12 @@
+diff -ru a/Makefile.am b/Makefile.am
+--- a/Makefile.am 2009-09-29 13:48:10.000000000 +0000
++++ b/Makefile.am 2009-09-29 13:50:00.000000000 +0000
+@@ -149,7 +149,7 @@
+ @mkdir -p $$(dirname '$@')
+ @echo "$(SED) -e '...' $*.pathsubst >$*"
+ @$(SED) -e '$(pathsubst_RULES)' '$<' >'$@.tmp'
+- @-chmod --reference='$<' '$@.tmp'
++ @-chmod $$(stat -c %a '$<') '$@.tmp'
+ @if cmp -s '$@.tmp' '$*'; then \
+ echo "... no changes, reusing old version"; \
+ rm -f '$@.tmp'; \