aboutsummaryrefslogtreecommitdiffstats
path: root/testing/uwsgi
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2013-03-07 08:55:32 +0000
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2013-03-07 08:55:32 +0000
commit145344949e4754123186613cd9ed6254b990af28 (patch)
tree9f2987195f69aab96d6655ad93f8bd359702c2be /testing/uwsgi
parent02aa5dc11fb5463f37e8e20c957b0a39c72fce2e (diff)
downloadaports-145344949e4754123186613cd9ed6254b990af28.tar.bz2
aports-145344949e4754123186613cd9ed6254b990af28.tar.xz
testing/uwsgi: upgrade to 1.4.8
Diffstat (limited to 'testing/uwsgi')
-rw-r--r--testing/uwsgi/APKBUILD17
-rw-r--r--testing/uwsgi/lua-lock.patch71
2 files changed, 11 insertions, 77 deletions
diff --git a/testing/uwsgi/APKBUILD b/testing/uwsgi/APKBUILD
index 3a6a0c64b8..22551376a6 100644
--- a/testing/uwsgi/APKBUILD
+++ b/testing/uwsgi/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
# Maintainer:
pkgname=uwsgi
-pkgver=1.4.3
-pkgrel=1
+pkgver=1.4.8
+pkgrel=0
pkgdesc="uWSGI application container server"
url=http://projects.unbit.it/uwsgi/
arch=all
license=GPL-2
makedepends="linux-headers lua-dev python python-dev zeromq-dev"
subpackages="uwsgi-lua uwsgi-python:py"
-source="http://projects.unbit.it/downloads/uwsgi-${pkgver}.tar.gz futimes.patch include-sched.patch lua-lock.patch"
+source="http://projects.unbit.it/downloads/uwsgi-${pkgver}.tar.gz futimes.patch include-sched.patch"
_builddir=$srcdir/$pkgname-$pkgver
prepare() {
@@ -63,7 +63,12 @@ py() {
mv "$pkgdir/usr/lib/uwsgi/python_plugin.so" "$subpkgdir/usr/lib/uwsgi"
}
-md5sums="98561cfdb93fb72ed68b7afb2ae4df3a uwsgi-1.4.3.tar.gz
+md5sums="10af354eccaae9c447bd5bdc69bcce12 uwsgi-1.4.8.tar.gz
2c9aeb5b2adf1fa45ef4ed6bda47236a futimes.patch
-02c43e001d5f44eb421079e17f9db003 include-sched.patch
-b791fb4994b0350992ffab3f939002ed lua-lock.patch"
+02c43e001d5f44eb421079e17f9db003 include-sched.patch"
+sha256sums="3c35893927a065ed89775cf5a8f66f66d71b060618f4611efbcca76e520aac37 uwsgi-1.4.8.tar.gz
+9ad8375325195e577e6b91a1cf7539817b58fbb4efef248d01a4b704a0e8749f futimes.patch
+25cb58a02a9f1f62be227592a31152e960f51d44a9e9d14751375a9468152e90 include-sched.patch"
+sha512sums="7ead90c0740db0ebc28256b312a98e8de610b62cc82504c738cc2f3d2b0819ae673eb1875ea31abc3e511dc76db9af9fb15f4d1ae2a62f6b67b2a5966cfe2bab uwsgi-1.4.8.tar.gz
+9e867a3483197adb5ab99334d0e9f092dab44201ddbead99a4649309fd0584e6793531a147e096459984d26d0a73754688426df1fb4686c041d3889f3d29fdef futimes.patch
+d454dcc5ee0a121ff44584e0da98055e6596e8a750315fe4ce6a5fbc615697b2a19b9b32c51ac9878587a855ec3f072e87a3e4e097a8b743699f58ed0d84ec0f include-sched.patch"
diff --git a/testing/uwsgi/lua-lock.patch b/testing/uwsgi/lua-lock.patch
deleted file mode 100644
index 059e8e9694..0000000000
--- a/testing/uwsgi/lua-lock.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-diff --git a/plugins/lua/lua_plugin.c b/plugins/lua/lua_plugin.c
-index 6a2a2a9..692c4ef 100644
---- a/plugins/lua/lua_plugin.c
-+++ b/plugins/lua/lua_plugin.c
-@@ -291,6 +291,57 @@ static int uwsgi_api_req_fd(lua_State *L) {
- return 1;
- }
-
-+static int uwsgi_api_lock(lua_State *L) {
-+
-+ int lock_num = 0;
-+
-+ // the spooler cannot lock resources
-+#ifdef UWSGI_SPOOLER
-+ if (uwsgi.i_am_a_spooler) {
-+ lua_pushstring(L, "The spooler cannot lock/unlock resources");
-+ lua_error(L);
-+ }
-+#endif
-+
-+ if (lua_gettop(L) > 0) {
-+ lock_num = lua_isnumber(L, 1) ? lua_tonumber(L, 1) : -1;
-+ if (lock_num < 0 || lock_num > uwsgi.locks) {
-+ lua_pushstring(L, "Invalid lock number");
-+ lua_error(L);
-+ }
-+ }
-+
-+ uwsgi_lock(uwsgi.user_lock[lock_num]);
-+
-+ return 0;
-+}
-+
-+
-+static int uwsgi_api_unlock(lua_State *L) {
-+
-+ int lock_num = 0;
-+
-+ // the spooler cannot lock resources
-+#ifdef UWSGI_SPOOLER
-+ if (uwsgi.i_am_a_spooler) {
-+ lua_pushstring(L, "The spooler cannot lock/unlock resources");
-+ lua_error(L);
-+ }
-+#endif
-+
-+ if (lua_gettop(L) > 0) {
-+ lock_num = lua_isnumber(L, 1) ? lua_tonumber(L, 1) : -1;
-+ if (lock_num < 0 || lock_num > uwsgi.locks) {
-+ lua_pushstring(L, "Invalid lock number");
-+ lua_error(L);
-+ }
-+ }
-+
-+ uwsgi_unlock(uwsgi.user_lock[lock_num]);
-+
-+ return 0;
-+}
-+
- static const luaL_reg uwsgi_api[] = {
- {"log", uwsgi_api_log},
- {"cl", uwsgi_api_cl},
-@@ -300,6 +351,8 @@ static const luaL_reg uwsgi_api[] = {
- {"cache_set", uwsgi_api_cache_set},
- {"register_signal", uwsgi_api_register_signal},
- {"register_rpc", uwsgi_api_register_rpc},
-+ {"lock", uwsgi_api_lock},
-+ {"unlock", uwsgi_api_unlock},
- {NULL, NULL}
- };
-