aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vault
diff options
context:
space:
mode:
authorChristian Kampka <christian@kampka.net>2015-12-12 14:15:40 +0100
committerChristian Kampka <christian@kampka.net>2015-12-12 14:15:40 +0100
commit91892e3daf7c9dd29d21f5843df6ae5af2de52cd (patch)
treeb87e30d14c385b75a7d513ae34da90d3b615bef7 /testing/vault
parent7f4f9c64636718f13163260a3f37c32c3aaa01a2 (diff)
downloadaports-91892e3daf7c9dd29d21f5843df6ae5af2de52cd.tar.bz2
aports-91892e3daf7c9dd29d21f5843df6ae5af2de52cd.tar.xz
testing/vault: new upstream version 0.4.0
Diffstat (limited to 'testing/vault')
-rw-r--r--testing/vault/APKBUILD47
-rw-r--r--testing/vault/Godeps.json233
2 files changed, 7 insertions, 273 deletions
diff --git a/testing/vault/APKBUILD b/testing/vault/APKBUILD
index 6bc894daa0..812a55acd4 100644
--- a/testing/vault/APKBUILD
+++ b/testing/vault/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Christian Kampka <christian@kampka.net>
# Maintainer:
pkgname=vault
-pkgver=0.3.1
-pkgrel=1
+pkgver=0.4.0
+pkgrel=0
pkgdesc="Vault is a tool for securely accessing secrets."
url="https://www.vaultproject.io/"
arch="all"
@@ -15,15 +15,12 @@ pkgusers="vault"
pkggroups="vault"
subpackages=""
options="!strip"
-source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
- Godeps.json
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/hashicorp/${pkgname}/archive/v${pkgver}.tar.gz
vault.confd
vault.hcl
vault.initd"
-_disturl="dev.alpinelinux.org:/archive/$pkgname/"
-_gourl="github.com/hashicorp/vault"
-_builddir="${srcdir}/vault"
+_builddir="${srcdir}/${pkgname}"
prepare() {
cd "${_builddir}"
@@ -35,33 +32,6 @@ prepare() {
done
}
-snapshot() {
- abuild clean
- abuild deps
-
- export GOPATH="${_builddir}"
- mkdir -p $_builddir
- cd "$srcdir"
-
- msg "Checking out v${pkgver} tag"
- git clone -q --branch v${pkgver} https://$_gourl || return 1
-
- cd ${_builddir}
- # use custom godeps file
-
- install -D "$startdir"/Godeps.json \
- $_builddir/Godeps/Godeps.json || return 1
-
- #go get -v -d || return 1
- godep restore || return 1
-
- cd "$srcdir"
- tar zcf $pkgname-$pkgver.tar.gz vault || return 1
- rsync --progress -La $pkgname-$pkgver.tar.gz \
- $_disturl || return 1
- cd $startdir && abuild undeps
-}
-
build() {
cd "$_builddir" || return 1
export GOPATH="${_builddir}"
@@ -84,18 +54,15 @@ package() {
"$pkgdir/etc/${pkgname}.hcl" || return 1
}
-md5sums="86f6ce29bec6c78eca8dc38bb60b8999 vault-0.3.1.tar.gz
-d299fb9fdf7f66fa6d5e073425487fd9 Godeps.json
+md5sums="615a01f957bbefa3f09b83e960186474 vault-0.4.0.tar.gz
2148a788620484be07e1e24feb1cbd34 vault.confd
1f7802f479024809856e3be2e44a1b19 vault.hcl
ca400b34773b25367acc85a950c3c887 vault.initd"
-sha256sums="e8ec4b56b8e700d6e88f4909536c6948bd2f9865538afe227450b1ed4b3c8276 vault-0.3.1.tar.gz
-62284c985b6771d28e37330112701354c7596339d31ccbc4baf0551d8f538360 Godeps.json
+sha256sums="1e85fc0c6acf8c459b70b318a3cb66307dfec2710f7bbdd78b787088d0a012f4 vault-0.4.0.tar.gz
f197536bc5bf4531072c0a5cb17627bf01abd188b0cc2005e0ff1768e6143d32 vault.confd
cacbd75cbaccf1034cd21d3015797cf0c1c1ce9c7e7ef7c1e4db4b54b92fe696 vault.hcl
8274a9c735906980a734a8a720232d8816bfbeb8294d4c96baac2e9885abf6a2 vault.initd"
-sha512sums="83a38fe9860d6d6f62f717a22c5ff27ce2a01e629a3162084c4815512910abe715b55be5eb90ab7bc798793d48149e0fa565f20f2f3fef29cc968d029fbf5b4a vault-0.3.1.tar.gz
-898ea279df93c55c9fc549739530bf63236171afba95f51184f11ce092e6c0ef8bd49382674832c21910ddce92ed9839b3fc582334469c9c783cba352c0e5cf8 Godeps.json
+sha512sums="be42f7e4421671a86a27dcc62a7694720c5834319d8279057e4601cc247846825a2b31fdcda4387c0f6b7854981c97d10182ee5157a2bd108dbed5a2a3242c02 vault-0.4.0.tar.gz
6f3f30e5c9d9dd5117f18fce0e669f0cd752a6be4910405d6b394f15273372731ee887a5ba4c700293e5b8bc2bf40fd69d4337156f77b03549d2dc2c0a666bec vault.confd
8c064aa5dcca84822c1fa85e9d0ff520df46f794b2e9c689a9b4f81f74279387b3aebc08b3ca26cf786c2fcf1a330e765bf5a511074c24f87e5346672346ba1c vault.hcl
34993256eb1700ef0738e24227af7732ea81f9e096b34b5f6a282fce364e9c92319c2fc219083eec0185927dde89d565dfcc0d0507bcdbebd3e003027760d447 vault.initd"
diff --git a/testing/vault/Godeps.json b/testing/vault/Godeps.json
deleted file mode 100644
index c880b13a7e..0000000000
--- a/testing/vault/Godeps.json
+++ /dev/null
@@ -1,233 +0,0 @@
-{
- "ImportPath": "github.com/hashicorp/vault",
- "GoVersion": "go1.5.1",
- "Packages": [
- "./..."
- ],
- "Deps": [
- {
- "ImportPath": "github.com/armon/go-metrics",
- "Rev": "6c5fa0d8f48f4661c9ba8709799c88d425ad20f0"
- },
- {
- "ImportPath": "github.com/armon/go-radix",
- "Rev": "fbd82e84e2b13651f3abc5ffd26b65ba71bc8f93"
- },
- {
- "ImportPath": "github.com/aws/aws-sdk-go/aws",
- "Comment": "v0.9.9-3-g7553d52",
- "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
- },
- {
- "ImportPath": "github.com/aws/aws-sdk-go/internal/endpoints",
- "Comment": "v0.9.9-3-g7553d52",
- "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
- },
- {
- "ImportPath": "github.com/aws/aws-sdk-go/internal/protocol/ec2query",
- "Comment": "v0.9.9-3-g7553d52",
- "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
- },
- {
- "ImportPath": "github.com/aws/aws-sdk-go/internal/protocol/query",
- "Comment": "v0.9.9-3-g7553d52",
- "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
- },
- {
- "ImportPath": "github.com/aws/aws-sdk-go/internal/protocol/rest",
- "Comment": "v0.9.9-3-g7553d52",
- "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
- },
- {
- "ImportPath": "github.com/aws/aws-sdk-go/internal/protocol/restxml",
- "Comment": "v0.9.9-3-g7553d52",
- "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
- },
- {
- "ImportPath": "github.com/aws/aws-sdk-go/internal/protocol/xml/xmlutil",
- "Comment": "v0.9.9-3-g7553d52",
- "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
- },
- {
- "ImportPath": "github.com/aws/aws-sdk-go/internal/signer/v4",
- "Comment": "v0.9.9-3-g7553d52",
- "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
- },
- {
- "ImportPath": "github.com/aws/aws-sdk-go/service/ec2",
- "Comment": "v0.9.9-3-g7553d52",
- "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
- },
- {
- "ImportPath": "github.com/aws/aws-sdk-go/service/iam",
- "Comment": "v0.9.9-3-g7553d52",
- "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
- },
- {
- "ImportPath": "github.com/aws/aws-sdk-go/service/s3",
- "Comment": "v0.9.9-3-g7553d52",
- "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
- },
- {
- "ImportPath": "github.com/coreos/go-etcd/etcd",
- "Comment": "v2.0.0-34-gde3514f",
- "Rev": "de3514f25635bbfb024fdaf2a8d5f67378492675"
- },
- {
- "ImportPath": "github.com/dgrijalva/jwt-go",
- "Comment": "v2.3.0-4-gc1da563",
- "Rev": "c1da56349675b292d3200463e2c88b9aa5e02391"
- },
- {
- "ImportPath": "github.com/duosecurity/duo_api_golang",
- "Rev": "16da9e74793f6d9b97b227a0696fe32bcdaecb42"
- },
- {
- "ImportPath": "github.com/fatih/structs",
- "Rev": "a9f7daa9c2729e97450c2da2feda19130a367d8f"
- },
- {
- "ImportPath": "github.com/go-ldap/ldap",
- "Comment": "v1-24-g12f2865",
- "Rev": "12f28659a82ac70ca6f3fafd977c0e2fdc144f53"
- },
- {
- "ImportPath": "github.com/go-sql-driver/mysql",
- "Comment": "v1.2-119-g527bcd5",
- "Rev": "527bcd55aab2e53314f1a150922560174b493034"
- },
- {
- "ImportPath": "github.com/gocql/gocql",
- "Comment": "1st_gen_framing-268-g2641ef0",
- "Rev": "2641ef08fabdc0182465a14a4f23f1521acb2834"
- },
- {
- "ImportPath": "github.com/golang/snappy",
- "Rev": "723cc1e459b8eea2dea4583200fd60757d40097a"
- },
- {
- "ImportPath": "github.com/google/go-github/github",
- "Rev": "0d67682ce830f252a1d56215f39b71199036361d"
- },
- {
- "ImportPath": "github.com/google/go-querystring/query",
- "Rev": "547ef5ac979778feb2f760cdb5f4eae1a2207b86"
- },
- {
- "ImportPath": "github.com/hashicorp/consul/api",
- "Comment": "v0.5.2-313-gde08067",
- "Rev": "de080672fee9e6104572eeea89eccdca135bb918"
- },
- {
- "ImportPath": "github.com/hashicorp/errwrap",
- "Rev": "7554cd9344cec97297fa6649b055a8c98c2a1e55"
- },
- {
- "ImportPath": "github.com/hashicorp/go-multierror",
- "Rev": "d30f09973e19c1dfcd120b2d9c4f168e68d6b5d5"
- },
- {
- "ImportPath": "github.com/hashicorp/go-syslog",
- "Rev": "42a2b573b664dbf281bd48c3cc12c086b17a39ba"
- },
- {
- "ImportPath": "github.com/hashicorp/golang-lru",
- "Rev": "7f9ef20a0256f494e24126014135cf893ab71e9e"
- },
- {
- "ImportPath": "github.com/hashicorp/hcl",
- "Rev": "4de51957ef8d4aba6e285ddfc587633bbfc7c0e8"
- },
- {
- "ImportPath": "github.com/hashicorp/logutils",
- "Rev": "0dc08b1671f34c4250ce212759ebd880f743d883"
- },
- {
- "ImportPath": "github.com/kardianos/osext",
- "Rev": "6e7f843663477789fac7c02def0d0909e969b4e5"
- },
- {
- "ImportPath": "github.com/lib/pq",
- "Comment": "go1.0-cutoff-59-gb269bd0",
- "Rev": "b269bd035a727d6c1081f76e7a239a1b00674c40"
- },
- {
- "ImportPath": "github.com/mitchellh/cli",
- "Rev": "8102d0ed5ea2709ade1243798785888175f6e415"
- },
- {
- "ImportPath": "github.com/mitchellh/copystructure",
- "Rev": "6fc66267e9da7d155a9d3bd489e00dad02666dc6"
- },
- {
- "ImportPath": "github.com/mitchellh/go-homedir",
- "Rev": "df55a15e5ce646808815381b3db47a8c66ea62f4"
- },
- {
- "ImportPath": "github.com/mitchellh/mapstructure",
- "Rev": "281073eb9eb092240d33ef253c404f1cca550309"
- },
- {
- "ImportPath": "github.com/mitchellh/reflectwalk",
- "Rev": "eecf4c70c626c7cfbb95c90195bc34d386c74ac6"
- },
- {
- "ImportPath": "github.com/ryanuber/columnize",
- "Comment": "v2.0.1-8-g983d3a5",
- "Rev": "983d3a5fab1bf04d1b412465d2d9f8430e2e917e"
- },
- {
- "ImportPath": "github.com/samuel/go-zookeeper/zk",
- "Rev": "177002e16a0061912f02377e2dd8951a8b3551bc"
- },
- {
- "ImportPath": "github.com/ugorji/go/codec",
- "Rev": "1d5269ed4e89d423d40362a0914e1c99adb13cc8"
- },
- {
- "ImportPath": "github.com/vaughan0/go-ini",
- "Rev": "a98ad7ee00ec53921f08832bc06ecf7fd600e6a1"
- },
- {
- "ImportPath": "golang.org/x/crypto/bcrypt",
- "Rev": "aedad9a179ec1ea11b7064c57cbc6dc30d7724ec"
- },
- {
- "ImportPath": "golang.org/x/crypto/blowfish",
- "Rev": "aedad9a179ec1ea11b7064c57cbc6dc30d7724ec"
- },
- {
- "ImportPath": "golang.org/x/crypto/cast5",
- "Rev": "aedad9a179ec1ea11b7064c57cbc6dc30d7724ec"
- },
- {
- "ImportPath": "golang.org/x/crypto/curve25519",
- "Rev": "aedad9a179ec1ea11b7064c57cbc6dc30d7724ec"
- },
- {
- "ImportPath": "golang.org/x/crypto/openpgp",
- "Rev": "aedad9a179ec1ea11b7064c57cbc6dc30d7724ec"
- },
- {
- "ImportPath": "golang.org/x/crypto/ssh",
- "Rev": "aedad9a179ec1ea11b7064c57cbc6dc30d7724ec"
- },
- {
- "ImportPath": "golang.org/x/net/context",
- "Rev": "db8e4de5b2d6653f66aea53094624468caad15d2"
- },
- {
- "ImportPath": "golang.org/x/oauth2",
- "Rev": "82de3fe653a61c1b0174fba87c5f1ca06226ed51"
- },
- {
- "ImportPath": "gopkg.in/asn1-ber.v1",
- "Comment": "v1",
- "Rev": "9eae18c3681ae3d3c677ac2b80a8fe57de45fc09"
- },
- {
- "ImportPath": "gopkg.in/inf.v0",
- "Rev": "3887ee99ecf07df5b447e9b00d9c0b2adaa9f3e4"
- }
- ]
-}