aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vault
diff options
context:
space:
mode:
authorChristian Kampka <christian@kampka.net>2015-10-07 21:24:42 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-10-13 08:13:59 +0200
commitb14eb5dc69cb30f1a3fd8255b3f26365d3858f3e (patch)
tree72fe351eacd2950f7fc92ffff9357dd2accdfb56 /testing/vault
parente6bb38670f0cf12d634feab44d2f4c8beddd3eb0 (diff)
downloadaports-b14eb5dc69cb30f1a3fd8255b3f26365d3858f3e.tar.bz2
aports-b14eb5dc69cb30f1a3fd8255b3f26365d3858f3e.tar.xz
testing/vault: upgrade to 0.3.1
Diffstat (limited to 'testing/vault')
-rw-r--r--testing/vault/APKBUILD28
-rw-r--r--testing/vault/Godeps.json160
2 files changed, 101 insertions, 87 deletions
diff --git a/testing/vault/APKBUILD b/testing/vault/APKBUILD
index aecf99ca7f..f2eeae34c1 100644
--- a/testing/vault/APKBUILD
+++ b/testing/vault/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Christian Kampka <christian@kampka.net>
# Maintainer:
pkgname=vault
-pkgver=0.2.0
+pkgver=0.3.1
pkgrel=0
pkgdesc="Vault is a tool for securely accessing secrets."
url="https://www.vaultproject.io/"
@@ -9,7 +9,7 @@ arch="all"
license="MPL 2.0"
depends=""
depends_dev=""
-makedepends="go godep $depends_dev"
+makedepends="go godep git $depends_dev"
#install="$pkgname.pre-install $pkgname.pre-deinstall $pkgname.post-deinstall"
pkgusers="vault"
pkggroups="vault"
@@ -21,6 +21,10 @@ source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
vault.hcl
vault.initd"
+_disturl="dev.alpinelinux.org:/archive/$pkgname/"
+_gourl="github.com/hashicorp/vault"
+_builddir="${srcdir}/vault"
+
prepare() {
cd "${_builddir}"
local i
@@ -31,10 +35,6 @@ prepare() {
done
}
-_disturl="dev.alpinelinux.org:/archive/$pkgname/"
-_gourl="github.com/hashicorp/vault"
-_builddir="${srcdir}/vault"
-
snapshot() {
abuild clean
abuild deps
@@ -80,20 +80,22 @@ package() {
-D "${_builddir}/bin/${pkgname}" \
"${pkgdir}/usr/sbin/${pkgname}" || return 1
install -m750 -o vault -g vault -d "$pkgdir/var/lib/${pkgname}" || return 1
- install -m750 -o root -g vault -D "$srcdir/${pkgname}.hcl" "$pkgdir/etc/${pkgname}.hcl" || return 1
+ install -m750 -o root -g vault -D "$srcdir/${pkgname}.hcl" \
+ "$pkgdir/etc/${pkgname}.hcl" || return 1
}
-md5sums="e3f826a5d2f294e876d89759c10e62d8 vault-0.2.0.tar.gz
-c7c60a8240345c248e72a57030239b03 Godeps.json
+
+md5sums="86f6ce29bec6c78eca8dc38bb60b8999 vault-0.3.1.tar.gz
+d299fb9fdf7f66fa6d5e073425487fd9 Godeps.json
2148a788620484be07e1e24feb1cbd34 vault.confd
1f7802f479024809856e3be2e44a1b19 vault.hcl
8b75990815b758db94f400de001cbc81 vault.initd"
-sha256sums="9c6c8e74e53b1bb6584ac3a0dea4ca67e981aab7af18802c4c5a910b2bd1b4b1 vault-0.2.0.tar.gz
-3ce579dfe7f7dc2a0519f835e55c85d314b1f90e5d74b29cc2966b6b0534a0d7 Godeps.json
+sha256sums="e8ec4b56b8e700d6e88f4909536c6948bd2f9865538afe227450b1ed4b3c8276 vault-0.3.1.tar.gz
+62284c985b6771d28e37330112701354c7596339d31ccbc4baf0551d8f538360 Godeps.json
f197536bc5bf4531072c0a5cb17627bf01abd188b0cc2005e0ff1768e6143d32 vault.confd
cacbd75cbaccf1034cd21d3015797cf0c1c1ce9c7e7ef7c1e4db4b54b92fe696 vault.hcl
cdbeba798d2b06a178e9c6eb638ff88c4f1c21eaa6c8881a87fac679c8e7c46e vault.initd"
-sha512sums="b53df240e8328dd3de12fd43cee5b3b1b994a328c91a855f6a35c5be2e3d5c49074d899a3b6554908147c185e311e7b45bc2d20e71d0184f6c65d6c27cb5c05e vault-0.2.0.tar.gz
-6092da41eeda3c3fb1766e310fa7ac73b26fcc34cf2b9a51574387eb1137d4e8322631a05b5d75bdc96b15f1d08da2bf98d299856a76ebe92e40d89743288f49 Godeps.json
+sha512sums="83a38fe9860d6d6f62f717a22c5ff27ce2a01e629a3162084c4815512910abe715b55be5eb90ab7bc798793d48149e0fa565f20f2f3fef29cc968d029fbf5b4a vault-0.3.1.tar.gz
+898ea279df93c55c9fc549739530bf63236171afba95f51184f11ce092e6c0ef8bd49382674832c21910ddce92ed9839b3fc582334469c9c783cba352c0e5cf8 Godeps.json
6f3f30e5c9d9dd5117f18fce0e669f0cd752a6be4910405d6b394f15273372731ee887a5ba4c700293e5b8bc2bf40fd69d4337156f77b03549d2dc2c0a666bec vault.confd
8c064aa5dcca84822c1fa85e9d0ff520df46f794b2e9c689a9b4f81f74279387b3aebc08b3ca26cf786c2fcf1a330e765bf5a511074c24f87e5346672346ba1c vault.hcl
038f5fd0b7bc84bd8be82a1cb8ac7a5357319bdb77e07936b4072fcb00a30add1cb3744f3a333d2a8b860c821aab0d88249033f61d2a2125de6bb6b2a4c9aef6 vault.initd"
diff --git a/testing/vault/Godeps.json b/testing/vault/Godeps.json
index 7dcdc3f9a9..c880b13a7e 100644
--- a/testing/vault/Godeps.json
+++ b/testing/vault/Godeps.json
@@ -1,13 +1,13 @@
{
"ImportPath": "github.com/hashicorp/vault",
- "GoVersion": "go1.4.2",
+ "GoVersion": "go1.5.1",
"Packages": [
- "."
+ "./..."
],
"Deps": [
{
"ImportPath": "github.com/armon/go-metrics",
- "Rev": "b2d95e5291cdbc26997d1301a5e467ecbb240e25"
+ "Rev": "6c5fa0d8f48f4661c9ba8709799c88d425ad20f0"
},
{
"ImportPath": "github.com/armon/go-radix",
@@ -15,48 +15,72 @@
},
{
"ImportPath": "github.com/aws/aws-sdk-go/aws",
- "Comment": "v0.6.4-5-g127313c",
- "Rev": "127313c1b41e534a0456a68b6b3a16712dacb35d"
+ "Comment": "v0.9.9-3-g7553d52",
+ "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
},
{
"ImportPath": "github.com/aws/aws-sdk-go/internal/endpoints",
- "Comment": "v0.6.4-5-g127313c",
- "Rev": "127313c1b41e534a0456a68b6b3a16712dacb35d"
+ "Comment": "v0.9.9-3-g7553d52",
+ "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
+ },
+ {
+ "ImportPath": "github.com/aws/aws-sdk-go/internal/protocol/ec2query",
+ "Comment": "v0.9.9-3-g7553d52",
+ "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
},
{
"ImportPath": "github.com/aws/aws-sdk-go/internal/protocol/query",
- "Comment": "v0.6.4-5-g127313c",
- "Rev": "127313c1b41e534a0456a68b6b3a16712dacb35d"
+ "Comment": "v0.9.9-3-g7553d52",
+ "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
},
{
"ImportPath": "github.com/aws/aws-sdk-go/internal/protocol/rest",
- "Comment": "v0.6.4-5-g127313c",
- "Rev": "127313c1b41e534a0456a68b6b3a16712dacb35d"
+ "Comment": "v0.9.9-3-g7553d52",
+ "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
},
{
"ImportPath": "github.com/aws/aws-sdk-go/internal/protocol/restxml",
- "Comment": "v0.6.4-5-g127313c",
- "Rev": "127313c1b41e534a0456a68b6b3a16712dacb35d"
+ "Comment": "v0.9.9-3-g7553d52",
+ "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
},
{
"ImportPath": "github.com/aws/aws-sdk-go/internal/protocol/xml/xmlutil",
- "Comment": "v0.6.4-5-g127313c",
- "Rev": "127313c1b41e534a0456a68b6b3a16712dacb35d"
+ "Comment": "v0.9.9-3-g7553d52",
+ "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
},
{
"ImportPath": "github.com/aws/aws-sdk-go/internal/signer/v4",
- "Comment": "v0.6.4-5-g127313c",
- "Rev": "127313c1b41e534a0456a68b6b3a16712dacb35d"
+ "Comment": "v0.9.9-3-g7553d52",
+ "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
+ },
+ {
+ "ImportPath": "github.com/aws/aws-sdk-go/service/ec2",
+ "Comment": "v0.9.9-3-g7553d52",
+ "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
+ },
+ {
+ "ImportPath": "github.com/aws/aws-sdk-go/service/iam",
+ "Comment": "v0.9.9-3-g7553d52",
+ "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
},
{
"ImportPath": "github.com/aws/aws-sdk-go/service/s3",
- "Comment": "v0.6.4-5-g127313c",
- "Rev": "127313c1b41e534a0456a68b6b3a16712dacb35d"
+ "Comment": "v0.9.9-3-g7553d52",
+ "Rev": "7553d5227962c0f226768d0435881e99ec0cab35"
},
{
"ImportPath": "github.com/coreos/go-etcd/etcd",
- "Comment": "v2.0.0-18-gc904d70",
- "Rev": "c904d7032a70da6551c43929f199244f6a45f4c1"
+ "Comment": "v2.0.0-34-gde3514f",
+ "Rev": "de3514f25635bbfb024fdaf2a8d5f67378492675"
+ },
+ {
+ "ImportPath": "github.com/dgrijalva/jwt-go",
+ "Comment": "v2.3.0-4-gc1da563",
+ "Rev": "c1da56349675b292d3200463e2c88b9aa5e02391"
+ },
+ {
+ "ImportPath": "github.com/duosecurity/duo_api_golang",
+ "Rev": "16da9e74793f6d9b97b227a0696fe32bcdaecb42"
},
{
"ImportPath": "github.com/fatih/structs",
@@ -64,59 +88,35 @@
},
{
"ImportPath": "github.com/go-ldap/ldap",
- "Comment": "v1-14-g406aa05",
- "Rev": "406aa05eb8272fb8aa201e410afa6f9fdcb2bf68"
+ "Comment": "v1-24-g12f2865",
+ "Rev": "12f28659a82ac70ca6f3fafd977c0e2fdc144f53"
},
{
"ImportPath": "github.com/go-sql-driver/mysql",
- "Comment": "v1.2-112-gfb72997",
- "Rev": "fb7299726d2e68745a8805b14f2ff44b5c2cfa84"
+ "Comment": "v1.2-119-g527bcd5",
+ "Rev": "527bcd55aab2e53314f1a150922560174b493034"
},
{
"ImportPath": "github.com/gocql/gocql",
- "Comment": "1st_gen_framing-187-g80e812a",
- "Rev": "80e812acf0ab386dd34271acc10d22514c0a67ba"
- },
- {
- "ImportPath": "github.com/golang/groupcache/lru",
- "Rev": "604ed5785183e59ae2789449d89e73f3a2a77987"
+ "Comment": "1st_gen_framing-268-g2641ef0",
+ "Rev": "2641ef08fabdc0182465a14a4f23f1521acb2834"
},
{
"ImportPath": "github.com/golang/snappy",
- "Rev": "eaa750b9bf4dcb7cb20454be850613b66cda3273"
+ "Rev": "723cc1e459b8eea2dea4583200fd60757d40097a"
},
{
"ImportPath": "github.com/google/go-github/github",
- "Rev": "fccd5bb66f985db0a0d150342ca0a9529a23488a"
+ "Rev": "0d67682ce830f252a1d56215f39b71199036361d"
},
{
"ImportPath": "github.com/google/go-querystring/query",
"Rev": "547ef5ac979778feb2f760cdb5f4eae1a2207b86"
},
{
- "ImportPath": "github.com/hashicorp/aws-sdk-go/aws",
- "Comment": "tf0.4.0-3-ge6ea019",
- "Rev": "e6ea0192eee4640f32ec73c0cbb71f63e4f2b65a"
- },
- {
- "ImportPath": "github.com/hashicorp/aws-sdk-go/gen/ec2",
- "Comment": "tf0.4.0-3-ge6ea019",
- "Rev": "e6ea0192eee4640f32ec73c0cbb71f63e4f2b65a"
- },
- {
- "ImportPath": "github.com/hashicorp/aws-sdk-go/gen/endpoints",
- "Comment": "tf0.4.0-3-ge6ea019",
- "Rev": "e6ea0192eee4640f32ec73c0cbb71f63e4f2b65a"
- },
- {
- "ImportPath": "github.com/hashicorp/aws-sdk-go/gen/iam",
- "Comment": "tf0.4.0-3-ge6ea019",
- "Rev": "e6ea0192eee4640f32ec73c0cbb71f63e4f2b65a"
- },
- {
"ImportPath": "github.com/hashicorp/consul/api",
- "Comment": "v0.5.2-144-g2783f2b",
- "Rev": "2783f2bfec1823362602924f5cd3c894743dca08"
+ "Comment": "v0.5.2-313-gde08067",
+ "Rev": "de080672fee9e6104572eeea89eccdca135bb918"
},
{
"ImportPath": "github.com/hashicorp/errwrap",
@@ -124,7 +124,7 @@
},
{
"ImportPath": "github.com/hashicorp/go-multierror",
- "Rev": "56912fb08d85084aa318edcf2bba735b97cf35c5"
+ "Rev": "d30f09973e19c1dfcd120b2d9c4f168e68d6b5d5"
},
{
"ImportPath": "github.com/hashicorp/go-syslog",
@@ -132,11 +132,11 @@
},
{
"ImportPath": "github.com/hashicorp/golang-lru",
- "Rev": "995efda3e073b6946b175ed93901d729ad47466a"
+ "Rev": "7f9ef20a0256f494e24126014135cf893ab71e9e"
},
{
"ImportPath": "github.com/hashicorp/hcl",
- "Rev": "54864211433d45cb780682431585b3e573b49e4a"
+ "Rev": "4de51957ef8d4aba6e285ddfc587633bbfc7c0e8"
},
{
"ImportPath": "github.com/hashicorp/logutils",
@@ -148,8 +148,8 @@
},
{
"ImportPath": "github.com/lib/pq",
- "Comment": "go1.0-cutoff-51-ga8d8d01",
- "Rev": "a8d8d01c4f91602f876bf5aa210274e8203a6b45"
+ "Comment": "go1.0-cutoff-59-gb269bd0",
+ "Rev": "b269bd035a727d6c1081f76e7a239a1b00674c40"
},
{
"ImportPath": "github.com/mitchellh/cli",
@@ -161,11 +161,11 @@
},
{
"ImportPath": "github.com/mitchellh/go-homedir",
- "Rev": "1f6da4a72e57d4e7edd4a7295a585e0a3999a2d4"
+ "Rev": "df55a15e5ce646808815381b3db47a8c66ea62f4"
},
{
"ImportPath": "github.com/mitchellh/mapstructure",
- "Rev": "2caf8efc93669b6c43e0441cdc6aed17546c96f3"
+ "Rev": "281073eb9eb092240d33ef253c404f1cca550309"
},
{
"ImportPath": "github.com/mitchellh/reflectwalk",
@@ -173,16 +173,16 @@
},
{
"ImportPath": "github.com/ryanuber/columnize",
- "Comment": "v2.0.1-6-g44cb478",
- "Rev": "44cb4788b2ec3c3d158dd3d1b50aba7d66f4b59a"
+ "Comment": "v2.0.1-8-g983d3a5",
+ "Rev": "983d3a5fab1bf04d1b412465d2d9f8430e2e917e"
},
{
"ImportPath": "github.com/samuel/go-zookeeper/zk",
- "Rev": "c86eba8e7e95efab81f6c0455332e49d39aed12f"
+ "Rev": "177002e16a0061912f02377e2dd8951a8b3551bc"
},
{
"ImportPath": "github.com/ugorji/go/codec",
- "Rev": "821cda7e48749cacf7cad2c6ed01e96457ca7e9d"
+ "Rev": "1d5269ed4e89d423d40362a0914e1c99adb13cc8"
},
{
"ImportPath": "github.com/vaughan0/go-ini",
@@ -190,23 +190,35 @@
},
{
"ImportPath": "golang.org/x/crypto/bcrypt",
- "Rev": "cc04154d65fb9296747569b107cfd05380b1ea3e"
+ "Rev": "aedad9a179ec1ea11b7064c57cbc6dc30d7724ec"
},
{
"ImportPath": "golang.org/x/crypto/blowfish",
- "Rev": "cc04154d65fb9296747569b107cfd05380b1ea3e"
+ "Rev": "aedad9a179ec1ea11b7064c57cbc6dc30d7724ec"
+ },
+ {
+ "ImportPath": "golang.org/x/crypto/cast5",
+ "Rev": "aedad9a179ec1ea11b7064c57cbc6dc30d7724ec"
+ },
+ {
+ "ImportPath": "golang.org/x/crypto/curve25519",
+ "Rev": "aedad9a179ec1ea11b7064c57cbc6dc30d7724ec"
+ },
+ {
+ "ImportPath": "golang.org/x/crypto/openpgp",
+ "Rev": "aedad9a179ec1ea11b7064c57cbc6dc30d7724ec"
},
{
- "ImportPath": "golang.org/x/crypto/ssh/terminal",
- "Rev": "cc04154d65fb9296747569b107cfd05380b1ea3e"
+ "ImportPath": "golang.org/x/crypto/ssh",
+ "Rev": "aedad9a179ec1ea11b7064c57cbc6dc30d7724ec"
},
{
"ImportPath": "golang.org/x/net/context",
- "Rev": "d9558e5c97f85372afee28cf2b6059d7d3818919"
+ "Rev": "db8e4de5b2d6653f66aea53094624468caad15d2"
},
{
"ImportPath": "golang.org/x/oauth2",
- "Rev": "b5adcc2dcdf009d0391547edc6ecbaff889f5bb9"
+ "Rev": "82de3fe653a61c1b0174fba87c5f1ca06226ed51"
},
{
"ImportPath": "gopkg.in/asn1-ber.v1",
@@ -214,8 +226,8 @@
"Rev": "9eae18c3681ae3d3c677ac2b80a8fe57de45fc09"
},
{
- "ImportPath": "speter.net/go/exp/math/dec/inf",
- "Rev": "42ca6cd68aa922bc3f32f1e056e61b65945d9ad7"
+ "ImportPath": "gopkg.in/inf.v0",
+ "Rev": "3887ee99ecf07df5b447e9b00d9c0b2adaa9f3e4"
}
]
}