aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vault
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-03-21 21:43:03 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-23 16:28:27 +0000
commitf7e813c88bb392d99d08b0c945c7c4f61e1aab70 (patch)
treebe8313bcf1232c71cd2c42714d071a66ff21460d /testing/vault
parent572a634cb0d2229dcc8d82f382425e379e79a492 (diff)
downloadaports-f7e813c88bb392d99d08b0c945c7c4f61e1aab70.tar.bz2
aports-f7e813c88bb392d99d08b0c945c7c4f61e1aab70.tar.xz
testing/vault: enable checks
Diffstat (limited to 'testing/vault')
-rw-r--r--testing/vault/APKBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/testing/vault/APKBUILD b/testing/vault/APKBUILD
index 8a28b3cd93..1932931a49 100644
--- a/testing/vault/APKBUILD
+++ b/testing/vault/APKBUILD
@@ -12,7 +12,6 @@ install="$pkgname.pre-install"
pkgusers="vault"
pkggroups="vault"
subpackages="$pkgname-openrc"
-options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/$pkgname/archive/v$pkgver.tar.gz
bindata-filename.patch
vault.confd
@@ -35,6 +34,16 @@ build() {
--tags ui
}
+check() {
+ # Manually specify tests because full test suite runs all kinds of
+ # integration tests with other systems and fail.
+ for module in api audit command http logical shamir vault
+ do
+ GOPATH=$HOME/aports/community/vault/src CGO_ENABLED=0 make \
+ test TEST=./$module
+ done
+}
+
package() {
cd "$builddir"