aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vde2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-31 14:44:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-31 14:44:55 +0000
commit79851f369df72a93ef0d3b10d8ce700d7da30672 (patch)
tree291376702650c2ce84d6cff800a34b927a553635 /testing/vde2
parent2e9a487aa9364b646a2dcad16e006a2e3ada0e79 (diff)
downloadaports-79851f369df72a93ef0d3b10d8ce700d7da30672.tar.bz2
aports-79851f369df72a93ef0d3b10d8ce700d7da30672.tar.xz
main/vde2: moved from testing
Diffstat (limited to 'testing/vde2')
-rw-r--r--testing/vde2/APKBUILD47
-rw-r--r--testing/vde2/vde.confd10
-rw-r--r--testing/vde2/vde.initd26
3 files changed, 0 insertions, 83 deletions
diff --git a/testing/vde2/APKBUILD b/testing/vde2/APKBUILD
deleted file mode 100644
index b4bf5bd0d8..0000000000
--- a/testing/vde2/APKBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Maintainer: Michael Zhou <zhoumichaely@gmail.com>
-pkgname=vde2
-pkgver=2.3.1
-pkgrel=3
-pkgdesc="VDE: Virtual Distributed Ethernet. User mode networking for QEMU, UML, etc."
-url="http://vde.sf.net"
-arch="all"
-license="GPL"
-depends="openssl"
-makedepends="openssl-dev libpcap-dev"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-libs"
-source="http://downloads.sourceforge.net/project/vde/vde2/2.3.1/vde2-2.3.1.tar.gz
- vde.initd
- vde.confd
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm "$pkgdir"/usr/lib/*.la \
- "$pkgdir"/usr/lib/vde2/*.la \
- "$pkgdir"/usr/lib/vde2/*/*.la \
- || return 1
-
- install -Dm755 "$srcdir"/vde.initd "$pkgdir"/etc/init.d/vde || return 1
- install -Dm644 "$srcdir"/vde.confd "$pkgdir"/etc/conf.d/vde || return 1
-}
-
-libs() {
- pkgdesc="Virtual Distributed Ethernet libraries"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib/
-}
-
-md5sums="c8c2acb92a72f779e0b484b1543a1cc3 vde2-2.3.1.tar.gz
-21c1b8e841978461aa5c87b3f8abf01d vde.initd
-318c787df292690c4da5b6ed83dc1893 vde.confd"
diff --git a/testing/vde2/vde.confd b/testing/vde2/vde.confd
deleted file mode 100644
index d879453753..0000000000
--- a/testing/vde2/vde.confd
+++ /dev/null
@@ -1,10 +0,0 @@
-# load the tun module
-VDE_MODPROBE_TUN="yes"
-# virtual tap networking device to be used for vde
-VDE_TAP="tap0"
-# mode and group for the socket
-VDE_SOCK_CHMOD="770"
-VDE_SOCK_CHOWN=":qemu"
-
-# This is the actual options string passed to VDE. Change this at your own risk.
-VDE_OPTS="-tap ${VDE_TAP} -daemon"
diff --git a/testing/vde2/vde.initd b/testing/vde2/vde.initd
deleted file mode 100644
index 6400f9bbb2..0000000000
--- a/testing/vde2/vde.initd
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vde/files/vde.init,v 1.4 2010/01/12 12:58:36 dang Exp $
-
-depend() {
- after net.${VDE_TAP}
-}
-
-
-start() {
- ebegin "Starting vde"
- [ "${VDE_MODPROBE_TUN}" == "yes" ] && modprobe tun
- start-stop-daemon --start --quiet \
- --exec /usr/bin/vde_switch -- ${VDE_OPTS}
- eend $? "Failed to start vde"
- chmod -R ${VDE_SOCK_CHMOD} /var/run/vde.ctl
- chown -R ${VDE_SOCK_CHOWN} /var/run/vde.ctl
-}
-
-stop() {
- ebegin "Stopping vde"
- [ "${VDE_MODPROBE_TUN}" == "yes" ] && modprobe -r tun
- start-stop-daemon --stop --quiet --exec /usr/bin/vde_switch
- eend $? "Failed to stop vde"
-}