aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vidcutter
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-04 00:59:15 +0300
committerprspkt <prspkt@protonmail.com>2019-06-04 00:59:15 +0300
commit7cd44f4c96fc6eee5dc29a683068b2a1338fe4ee (patch)
tree21ef580bc8aa9b68dc2600db6a5223d576213993 /testing/vidcutter
parent90e48d762408623643757b2dae51105d1ddc1fe1 (diff)
downloadaports-7cd44f4c96fc6eee5dc29a683068b2a1338fe4ee.tar.bz2
aports-7cd44f4c96fc6eee5dc29a683068b2a1338fe4ee.tar.xz
testing/vidcutter: clarify license, modernize
Diffstat (limited to 'testing/vidcutter')
-rw-r--r--testing/vidcutter/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/testing/vidcutter/APKBUILD b/testing/vidcutter/APKBUILD
index c6beed7436..b1b287ba00 100644
--- a/testing/vidcutter/APKBUILD
+++ b/testing/vidcutter/APKBUILD
@@ -6,26 +6,22 @@ pkgrel=2
pkgdesc="A modern, simple to use, constantly evolving and hella fast MEDIA CUTTER"
url="https://vidcutter.ozmartians.com"
arch="all"
-license="GPL-3"
+license="GPL-3.0-or-later"
depends="python3 ffmpeg mediainfo py3-qt5"
subpackages="$pkgname-doc"
makedepends="mpv-dev python3-dev py3-setuptools"
source="$pkgname-$pkgver.tar.gz::https://github.com/ozmartian/$pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py check
}
package() {
- cd "$builddir"
- python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="9970d9918cca9a7681bc5ca8d8b5d16212cf3dad0f2bc3e9c6727340c340801696dcb7ff4e901c2c0a25b86e9cb165bb3f783c18b4a8fd5f4ddba8490a7fd7a0 vidcutter-6.0.0.tar.gz"