aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vidstab
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-09 15:02:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-10 13:04:35 -0300
commitdd45fb30b5b313fca1b2f6407b7ca00df9fea034 (patch)
tree17dc4c238c9cbee3f0b09ffff54da6d584b5a1fb /testing/vidstab
parent7a53b050efaef2d3e2a3cced51a5b4a5b947a789 (diff)
downloadaports-dd45fb30b5b313fca1b2f6407b7ca00df9fea034.tar.bz2
aports-dd45fb30b5b313fca1b2f6407b7ca00df9fea034.tar.xz
testing/vidstab: new aport
Diffstat (limited to 'testing/vidstab')
-rw-r--r--testing/vidstab/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/vidstab/APKBUILD b/testing/vidstab/APKBUILD
new file mode 100644
index 0000000000..bb55eefddd
--- /dev/null
+++ b/testing/vidstab/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=vidstab
+_pkgname=vid.stab
+pkgver=1.1.0
+pkgrel=0
+arch="all"
+url="http://public.hronopik.de/vid.stab/"
+pkgdesc="Video stabilization library"
+license="GPL-2.0-or-later"
+makedepends="cmake"
+source="$pkgname-$pkgver.tar.gz::https://github.com/georgmartius/vid.stab/archive/v$pkgver.tar.gz"
+subpackages="$pkgname-dev"
+options="!check" # No tests
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="e82a4b6dd854b8415952cc0a8bdea06c01ff40a497c8e98177831e29031ec535b9f47cc30d5444c47bfd91871615a1662e3991185e9eb179acf37ea601073cdf vidstab-1.1.0.tar.gz"